Announcement

Collapse
No announcement yet.

EDID and randr1.2 with radeon

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    For a listing of Common VIDEO MODE-LINES see:

    http://www.phoronix.com/forums/showthread.php?t=12425

    Comment


    • #22
      Running the command startx -- -logverbose 5 from the console gives the EDID information (in /var/log/Xorg.0.log (or /var/log/XFree86.0.log)).

      Anyone know of any other ways to get the EDID information?

      Comment


      • #23
        Originally posted by agd5f View Post
        Add a monitor section and associate it with the output in question then add these to your monitor section:
        Modeline "1440x900_75.00" 136.49 1440 1536 1688 1936 900 901 904 940 -HSync +Vsync
        Option "PerferredMode" "1440x900_75.00"

        See this page for more:
        http://www.intellinuxgraphics.org/dualhead.html
        Sorry for reviving this old thread, but I'm not able to get modelines to work.

        Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1600
        DVI-1 disconnected (normal left inverted right x axis y axis)
        DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 433mm x 271mm
        1680x1050 59.9*+ 60.0
        1600x1200 60.0
        1400x1050 74.8 60.0
        1280x1024 75.0 75.0 60.0 60.0
        1280x960 60.0 60.0
        1152x864 75.0 75.0
        1024x768 75.0 75.1 75.0 70.1 60.0
        832x624 74.6
        800x600 72.2 75.0 75.0 60.3 56.2
        640x480 75.0 72.8 75.0 60.0 59.9
        720x400 70.1
        640x350 70.1
        1280x800@75 75.3
        Here you can see on the last line 1280x800 resolution that I added using --newmode and then --addmode. It works. I can switch to this resolution and use it. Unfortunately these settings are not persistant, and I lose them when X is restarted. So after doing a little research I discovered that I need to add a modeline for this resolution in the moniotor section of the xorg.conf....

        Section "Monitor"
        Identifier "Monitor0"
        VendorName "BNQ"
        ModelName "BenQ FP202W"
        HorizSync 30.0 - 84.0
        VertRefresh 56.0 - 76.0
        Option "DPMS"
        Modeline "1280x800@75" 111.50 1280 1312 1728 1760 800 815 825 841
        Option "PreferredMode" "1280x800@75"
        EndSection
        But it definately isnt working. These changes are not persisntant. And I'm not sure what the heck I'm doing wrong. I know the modeline works, I've tested it on the nvidia driver. It even works with the radeon driver when using xrandr. But when I reboot the setting dissappear and I have to re-add them using --newmode and then --addmode. Maybe I'm missing a step somewhere?

        Comment


        • #24
          Originally posted by duby229 View Post
          Maybe I'm missing a step somewhere?
          You need to associate your monitor section with the output you want to use that mode on. Either change the identifier for the monitor to match the output name:
          Identifier "DVI-0"
          or associate the monitor section with the output in the device section:
          Option "Monitor-DVI-0" "Monitor0"
          See the "Per Output Config" section of this page:
          http://wiki.debian.org/XStrikeForce/HowToRandR12
          Also, you don't need to specify the sync ranges in the monitor section if the edid is available. Manually specifying it can sometimes cause problems if it is not specified correctly as they can limit the modes that are available. Also, if you are using xserver 1.3, the preferredmode option was broken. If so, please upgrade to xserver 1.4 or newer.

          Comment


          • #25
            Originally posted by agd5f View Post
            You need to associate your monitor section with the output you want to use that mode on. Either change the identifier for the monitor to match the output name:
            Identifier "DVI-0"
            or associate the monitor section with the output in the device section:
            Option "Monitor-DVI-0" "Monitor0"
            See the "Per Output Config" section of this page:
            http://wiki.debian.org/XStrikeForce/HowToRandR12
            Also, you don't need to specify the sync ranges in the monitor section if the edid is available. Manually specifying it can sometimes cause problems if it is not specified correctly as they can limit the modes that are available. Also, if you are using xserver 1.3, the preferredmode option was broken. If so, please upgrade to xserver 1.4 or newer.
            Freakin awesome man! Thank you so much. EDID will detect sync rages anyway, so it doesnt matter if I remove them. And I am using xserver 1.5 right now, so preferedmode seems to work nicely.

            Comment

            Working...
            X