Announcement

Collapse
No announcement yet.

RS480/RS690 OSS Compiz Achieved

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by givemesugarr
    and enabled Dri in xorg.conf?! if you didn't maybe, it's quite the chance that dri isn't enabled, but disabled by default. so you wouldn't be able to run compiz.
    That's what I was missing - when I added it, compiz started perfectly. This is really fantastic

    Comment


    • #17
      Originally posted by zombiepig View Post
      That's what I was missing - when I added it, compiz started perfectly. This is really fantastic
      and is stable also in video playback and fast, even when going with 500+ mbs of ram occupied in compiling and the processor at 100% load. i'm really impressed how well compiz works on the radeon driver. the devs have really done a real good job.

      ps. with dri2 and direct rendering this should be even more faster and good.

      Comment


      • #18
        Slow scrolling

        Hi,

        I followed the instructions, i.e.

        I have also enabled DRI in xorg.conf and checked the X log file and everything looks fine. EXA is activated, along with DRI and PageFlipping.

        I managed to start compiz by setting LIBGL_ALWAYS_INDIRECT to 1 and modifying the script to skip check of ati/radeon driver on a laptop.

        Almost everything works fine. Performance is very good overall. The issue I have is that scrolling a window and moving a window around is very slow (I don't have the wobbling effect activated).

        Any idea? I am running Hardy with an XPRESS 200M (5955) on a HP dv5000 laptop.

        Comment


        • #19
          vtence - that sounds like the same steps I took. Maybe try making the changes to xorg.conf that are listed here https://wiki.ubuntu.com/RS485 . I noticed a small performance boost after following those steps.

          Comment


          • #20
            No difference

            zombiepig, thx for your help.

            Unfortunatly, I still cannot make scrolling perf acceptable. Moving windows is really slow as well.

            My xorg.conf looks like this:

            Code:
            Section "Device"
                    Identifier      "Configured Video Device"
                    Driver          "radeon"
                    Option          "AccelMethod" "EXA"
                    Option          "EnablePageFlip" "on"
                    Option          "DRI"   "true"
                    Option          "TexturedVideo" "on"
                    Option          "GARTSize" "64"
            EndSection
            
            Section "DRI"
                    Mode    0666
            EndSection
            
            Section "Extensions"
                    Option "Composite" "Enable"
            EndSection
            I tried without the TexturedVideo option and it does not seem to make any difference.

            IIUC it should not be necessary to specify the Composite option, shouldn't it be on by default in Hardy? What's the use of DRI Mode 0666?

            I'm not sure what else to try. When I run glxinfo, I get:

            Code:
            direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
            but the X log file says DRI is activated:

            Code:
            (II) RADEON(0): Direct rendering experimental on RS400/Xpress 200 enabled

            Comment


            • #21
              Originally posted by vtence View Post
              zombiepig, thx for your help.

              Unfortunatly, I still cannot make scrolling perf acceptable. Moving windows is really slow as well.

              My xorg.conf looks like this:

              Code:
              Section "Device"
                      Identifier      "Configured Video Device"
                      Driver          "radeon"
                      Option          "AccelMethod" "EXA"
                      Option          "EnablePageFlip" "on"
                      Option          "DRI"   "true"
                      Option          "TexturedVideo" "on"
                      Option          "GARTSize" "64"
              EndSection
              
              Section "DRI"
                      Mode    0666
              EndSection
              
              Section "Extensions"
                      Option "Composite" "Enable"
              EndSection
              remove the gartsize line. it limits your board to 64mbyte of ram. leave the gart to the xwindow which will automatically find the best gart size.


              I tried without the TexturedVideo option and it does not seem to make any difference.
              there isn't an option to enable or disable XV overlay, as it is with fglrx, but it is automatically enabled/disabled when compiling the source. you could manually compile the sources and be sure that the driver has compiled with xv and exa enabled.


              IIUC it should not be necessary to specify the Composite option, shouldn't it be on by default in Hardy? What's the use of DRI Mode 0666?
              if your board supports it without issues then is enabled by default together with aiglx and damage. else it's not enabled. and since rs4xx series didn't supported them by default when hardy has been released then they likely aren't enabled.

              I'm not sure what else to try. When I run glxinfo, I get:

              Code:
              direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
              but the X log file says DRI is activated:

              Code:
              (II) RADEON(0): Direct rendering experimental on RS400/Xpress 200 enabled
              that's normal. this is due to the indirect rendering.

              what i can tell you is to recompile the xf86-video-ati manually, the git version if possible, and see if exa and textured are enabled during configure phase.

              also you could use my xorg.conf here:
              http://pastebin.com/m2c944bc5

              be aware that i'm using evdev and that the device options include a lot of tweaks for fglrx. the options not recognized by the radeon driver will just be ignored.
              if you don't use evdev and synaptic touchpad replace the input devices with yours.
              also the monitor section would be different that yours (maybe) and the screen resolutions also could be different.
              if you need help on what the various configs do ask for it.
              you can remove the device options not recognized by radeon without any fear. they would be shown as warnings in the xorg.0.log.

              Comment


              • #22
                I have tried the settings in your xorg.conf file but did not notice any significant improvement.

                I am willing to recompile xf86 from git. I have pulled the source. What tools to I need to compile it and what are the steps? It's the first time I have to recompile a driver :-) From what I understand, I need to run autogen.sh and for that I need autoconf. Anything else? I'm on Hardy 64bits BTW. Don't know if it makes a difference

                Thanks a lot for your help

                Comment


                • #23
                  Originally posted by vtence View Post
                  I have tried the settings in your xorg.conf file but did not notice any significant improvement.

                  I am willing to recompile xf86 from git. I have pulled the source. What tools to I need to compile it and what are the steps? It's the first time I have to recompile a driver :-) From what I understand, I need to run autogen.sh and for that I need autoconf. Anything else? I'm on Hardy 64bits BTW. Don't know if it makes a difference

                  Thanks a lot for your help
                  my deps are the following:

                  1. libtool >= 1.5
                  2. m4 >= 1.4
                  3. autotools (autoconf and automake)
                  4. pkg-config >= 0.18
                  5. binutils >= 2.16
                  6. util-macros >= 0.99.2
                  7. xorg > 6.9
                  8. mesa
                  9. gcc 4

                  now the most part of these pacakges should be met by hardy heron by default since are all what you can call system packages. surely the mesa, xorg, binutils and libtool are there without error.
                  you just clone the repo with git clone, then do
                  Code:
                  ./configure
                  then when finished do
                  Code:
                  make
                  and if you don't get errors you can do the last thing to actually install the package with
                  Code:
                  sudo make install
                  .
                  if you still don't get an improvement or if you see that exa and texturedrender aren't enabled in the configure (there are some lines towards the end of the configure that refer to exa and texturedrender) then you might need to have to compile also alex's drm rework, but for that you'll need also mesa+libdrm from git, and then also dri2proto (compiled before mesa or it will fail compiling).

                  other thing is to see if you actually have the drm module in the kernel by doing a lsmod | grep drm. if it doesn't outputs anything then drm isn't installed and you'll need to compile it.

                  so, the steps should be:

                  first do a
                  Code:
                  lsmod | grep drm
                  . if this outputs nothing (which shouldn't happen since you say that dri is actually enabled) then you'll have to install the following packages in order (else skip to package number 4.):
                  1. dri2proto from git
                  2. mesa from git (and ascertain that you have libdrm in your /usr/lib/ directory by doing a
                  Code:
                  ls -l /usr/lib/ | grep libdrm
                  ) if this outputs nothing then you should actually ascertain that HH installs the shared libs in the right place that it should (/usr/lib/) and not somewhere else and if this library isn't there then you'll have to compile the mesa drm branch from git.
                  3. compile the radeon drm rework from alex's git repo (git://people.freedesktop.org/~agd5f/drm)
                  4. compile the xf86-video-ati that you've cloned from git.

                  the 4. package is needed if you want also the drm rework from git as it is if you only want to use the latest radeon driver.
                  the steps to compile are always the same:
                  a).
                  Code:
                  git clone git://[repository you want to clone]
                  b).
                  Code:
                  cd [cloned directory]
                  c).
                  Code:
                  ./configure
                  d).
                  Code:
                  make
                  e). if make and configure haven't spit out errors do
                  Code:
                  sudo make install
                  (this needs root priviledges)
                  f). if make install hasn't spit out errors then access the console from the xorg login (gdm or kdm) login, and stop the server, remove the radeon and drm modules (
                  Code:
                  rmmod radeon && rmmod drm
                  ) and restart the xserver. the last steps need root priviledges so you'll have to use sudo. and now everything should be ok and work fine.

                  Comment


                  • #24
                    Latest status:

                    I recompiled everything as you explained (after installing a number of packages to enable compilation):

                    - dri2proto from git
                    - mesa from git
                    - radeon drm rework
                    - xf86-video-ati

                    did not get any error so I assume installation went fine. Configure said EXA is enabled. Could not find anything about Textured Video.

                    Still it makes little difference. Moving windows around is still slow and so is scrolling. I think mesa installation went fine, although I don't know if compiling and installing mesa from git also installs mesa-glx and mesa-dri.

                    Thanks for your help anyway, I think I'll have to wait for those patches to get into an official ubuntu update. I've already reached the limits of my understanding ;-)

                    Or maybe it is slow even with all latest sources on an Xpress200M.

                    Comment


                    • #25
                      Originally posted by vtence View Post
                      Latest status:

                      I recompiled everything as you explained (after installing a number of packages to enable compilation):

                      - dri2proto from git
                      - mesa from git
                      - radeon drm rework
                      - xf86-video-ati

                      did not get any error so I assume installation went fine. Configure said EXA is enabled. Could not find anything about Textured Video.

                      Still it makes little difference. Moving windows around is still slow and so is scrolling. I think mesa installation went fine, although I don't know if compiling and installing mesa from git also installs mesa-glx and mesa-dri.

                      Thanks for your help anyway, I think I'll have to wait for those patches to get into an official ubuntu update. I've already reached the limits of my understanding ;-)

                      Or maybe it is slow even with all latest sources on an Xpress200M.
                      i have the same board (different chip 5975 not 5595) and for me it works quite well. maybe you're using the maximum texture filtering for compiz. try using good or speedy texture filtering and disable all effects (leave just base stuff like exposŤ and compiz cube). if you've installed these packages and haven't got errors in compilation and installation they should have installed what you need and the drivers should be ok. maybe you haven't removed the old radeon and drm modules from memory after compiling the new ones (this is needed in order for xorg to load the new modules) and use that. so in this case the problem is due to some compiz issue and the only way to find it is to disable all effects and enable them one by one and see which is the one who is bad.

                      Comment


                      • #26
                        Originally posted by vtence View Post
                        Or maybe it is slow even with all latest sources on an Xpress200M.
                        I'm not sure what's wrong with your setup - but I can confirm that it runs really well on my (wife's) laptop. Definitely runs far better than it did without compiz on the stock hardy setup. In fact, it even gets a better glxgears fps then my intel 3500..!

                        Comment


                        • #27
                          Well I did compile libdrm, mesa and xf86-driver-ati from git; as well as dri2proto, but got not much luck with KWin4 compositing abilities.
                          I have this strange message in Xorg.0.log, though :

                          Code:
                          bash-3.1$ grep AIGLX /var/log/Xorg.0.log
                          (**) Option "AIGLX"
                          (**) AIGLX enabled
                          (EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/r300_dri.so failed (/usr/lib/xorg/modules/dri/r300_dri.so: undefined symbol: _glapi_tls_Context)
                          (EE) AIGLX: reverting to software rendering
                          bash-3.1$
                          I compiled mesa with glx-tls enabled and osmesa. What module could be responsible for this message?
                          Apart from that, messages in Xorg.0.log seem consistent with what is given above :

                          Code:
                          (II) RADEON(0): [dri] Found DRI library version 1.3.0 and kernel module version 1.28.0
                          (II) RADEON(0): Direct rendering experimental on RS400/Xpress 200 enabled
                          (**) RADEON(0): Page Flipping enabled
                          (II) RADEON(0): Will try to use DMA for Xv image transfers
                          (II) RADEON(0): Detected total video RAM=32768K, accessible=65536K (PCI BAR=65536K)
                          (--) RADEON(0): Mapped VideoRAM: 32768 kByte (64 bit DDR SDRAM)
                          (II) RADEON(0): Color tiling enabled by default
                          (II) RADEON(0): Max desktop size set to 2560x1200
                          
                          (snip)
                          
                          (==) RADEON(0): Backing store disabled
                          (II) RADEON(0): [DRI] installation complete
                          (II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
                          (II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
                          (II) RADEON(0): [drm] dma control initialized, using IRQ 17
                          (II) RADEON(0): [drm] Initialized kernel GART heap manager, 5111808
                          (WW) RADEON(0): DRI init changed memory map, adjusting ...
                          (WW) RADEON(0):   MC_FB_LOCATION  was: 0x1fff1e00 is: 0x1fff1e00
                          (WW) RADEON(0):   MC_AGP_LOCATION was: 0xffffffc0 is: 0x21ff2000
                          (II) RADEON(0): RADEONRestoreMemMapRegisters() :
                          (II) RADEON(0):   MC_FB_LOCATION   : 0x1fff1e00 0x1fff1e00
                          (II) RADEON(0):   MC_AGP_LOCATION  : 0x21ff2000
                          (II) RADEON(0): Direct rendering enabled
                          (II) RADEON(0): Render acceleration enabled for R300/R400/R500 type cards.
                          (II) RADEON(0): RADEONEngineInit: num pipes is 4
                          (II) EXA(0): Offscreen pixmap area of 7553024 bytes
                          (II) EXA(0): Driver registered support for the following operations:
                          (II)         Solid
                          (II)         Copy
                          (II)         Composite (RENDER acceleration)
                          (II)         UploadToScreen
                          (II)         DownloadFromScreen
                          (II) RADEON(0): Acceleration enabled
                          So EXA and DRI seem correctly enabled, even though glxinfo says no direct rendering is done.
                          I should add that my chipset is detected as "ATI Radeon XPRESS 200M 5955 (PCIE)".

                          Comment


                          • #28
                            Finally

                            It finally works great. Although I'm not sure what is different.

                            I tried the setting from givemesugar xorg.conf after recompiling everything from source, but that gave me screen corruption under the cursor and in the menus, so I decided to go back to a cleaner state and reinstalled from the ppas and went back to a simpler xorg.conf.

                            Don't ask me why but this time glxinfo reported Direct Rendering and my frame rate in glxgears jumped to 1500 instead of 900.

                            Compiz runs really fast now and the scrolling problem is gone.

                            Thanks for your help guys.

                            Here's my xorg.cof now:

                            Code:
                            Section "Device"
                                    Identifier      "Configured Video Device"
                                    Driver          "ati"
                                    Option          "AccelMethod" "EXA"
                                    Option          "EnablePageFlip" "on"
                                    Option          "DRI"   "true"
                                    Option          "TexturedVideo" "on"
                            EndSection
                            
                            Section "DRI"
                                Group      "video"
                                Mode       0660
                            EndSection
                            
                            Section "Extensions"
                                    Option "Composite" "Enable"
                                    Option "DAMAGE" "true"
                                    Option "RENDER" "true"
                            EndSection
                            
                            Section "ServerFlags"
                                    Option "AIGLX" "on"
                            EndSection
                            Could it be that I'm using ati driver instead of radeon?

                            Comment


                            • #29
                              The "ati" driver is just a wrapper which automatically loads radeon, r128 or mach64 drivers depending on which chip you have. The r128 and mach64 drivers were recently split out into different trees (they all used to be in xf86-video-ati before) so the -ati tree just contains the radeon driver and the -ati wrapper these days.

                              In a perfect world I guess the radeon driver would eventually move into its own tree (xf86-video-radeon) and the -ati tree would just contain the wrapper but the current setup seems to work pretty well other than being a bit confusing at first.

                              Comment


                              • #30
                                Originally posted by vtence View Post
                                It finally works great. Although I'm not sure what is different.

                                I tried the setting from givemesugar xorg.conf after recompiling everything from source, but that gave me screen corruption under the cursor and in the menus, so I decided to go back to a cleaner state and reinstalled from the ppas and went back to a simpler xorg.conf.

                                Don't ask me why but this time glxinfo reported Direct Rendering and my frame rate in glxgears jumped to 1500 instead of 900.

                                Compiz runs really fast now and the scrolling problem is gone.

                                Thanks for your help guys.

                                Here's my xorg.cof now:

                                Code:
                                Section "Device"
                                        Identifier      "Configured Video Device"
                                        Driver          "ati"
                                        Option          "AccelMethod" "EXA"
                                        Option          "EnablePageFlip" "on"
                                        Option          "DRI"   "true"
                                        Option          "TexturedVideo" "on"
                                EndSection
                                
                                Section "DRI"
                                    Group      "video"
                                    Mode       0660
                                EndSection
                                
                                Section "Extensions"
                                        Option "Composite" "Enable"
                                        Option "DAMAGE" "true"
                                        Option "RENDER" "true"
                                EndSection
                                
                                Section "ServerFlags"
                                        Option "AIGLX" "on"
                                EndSection
                                Could it be that I'm using ati driver instead of radeon?
                                then the problem is that one of the options that on my setup make it work well on your chipset isn't supported in the right way (remember that your 5595 is a little different from my 5795 chip). i'll investigate further to see if there are options that are troublesome (even if i don't seem to experince any evident issue).
                                you've forgotten Option "RenderAccel" "true" in your device section. this is another optiomization that you should use because it improves overall visual experience. if it is the one that gives you problems then rendering acceleration isn't well supported on your chipset.

                                Comment

                                Working...
                                X