Announcement

Collapse
No announcement yet.

780G support?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 780G support?

    Are either the radeon or radeonhd crews working on support for the 780G chipset (HD 3200) which AMD has now released worldwide? I understand it has been available in China for a month already. The reviews of it look very rosy, although I presume some of the nice features (Hybrid Crossfire) should not be expected in the open source drivers.

  • #2
    I would be interested to know this as well.

    I'm posting from Ubuntu 7.10 running on the new Gigabyte 780G board (GA-MA78GM-S2H), and so far I'm impressed.

    The NIC and video (DVI) worked right out of the box, although I'm using the VESA driver for now. Simple 2D stuff like Firefox and a couple of movies are still much quicker and much smoother than they were under my old system (oooold Sempron + Radeon 9000).

    Sound doesn't seem to work just quite yet, but that's just as likely to be an error on my end as anything else.

    This system should make for a killer HTPC, and it'll be even better if/when the Radeon(HD) driver gets support for MPEG acceleration and 3D.

    So... I know the AMD guys are busy but... pretty please?

    Comment


    • #3
      It will come in RadeonHD but I don't think for a few more weeks... There will be a fglrx review of the 780G at Phoronix though shortly.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        I'm not finding this anywhere I've just installed Ubuntu on the gigabyte 780g board as well but i can't for the life of me get the on board video to let me dual screens . Thats the reason I bought this board but the AMD catalyst driver won't even detect the other monitor. Does anyone know of a work around? Is there a way I can force X to go explore the interfaces and set it up by hand? AMD's support is non existent. Thanks.

        Comment


        • #5
          Originally posted by SoulNibbler View Post
          I'm not finding this anywhere I've just installed Ubuntu on the gigabyte 780g board as well but i can't for the life of me get the on board video to let me dual screens . Thats the reason I bought this board but the AMD catalyst driver won't even detect the other monitor. Does anyone know of a work around? Is there a way I can force X to go explore the interfaces and set it up by hand? AMD's support is non existent. Thanks.
          With Rv620/635 now out, we will start working on rs780, this shouldn't take too long. Please subscribe to the radeonhd mailinglist to track our progress.

          Thanks

          Comment


          • #6
            Has anyone managed to get xvideo working on 780g using open or closed drivers (test with xvinfo)? I've installed Ubuntu Hardy and Catalyst 8.3 on the Gigabyte board but I don't get xvideo support.
            /Magnus

            Comment


            • #7
              The 780G chips should work more or less with the radeon driver (xf86-video-ati).

              Comment


              • #8
                Even if the radeon driver works on 780G, I don't expect XVideo to work yet. Newer platforms don't have the overlay, and XVideo support using texture is a new thing in the radeon driver, currently supported on the RV500 level, I don't believe they've take it to the RV600 series yet.

                Comment


                • #9
                  Correct. I believe TexturedVideo should work with a 780G using the 8.3 fglrx release, but I haven't actually seen it run myself.

                  There are also reports that you can get pretty decent video playback (albeit unaccelerated) using the X11 output option and radeonhd with acceleration turned off (ie set to ShadowFB). Not sure if this is still true but it was the case a month or two ago.

                  Comment


                  • #10
                    780G Linux benchmarks should be out on Monday (from fglrx).
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #11
                      Just installed the 8.3 driver on a fresh 7.10 Ubuntu install using the gigabyte 780G motherboard.

                      Everything seems to work sweet.

                      Comment

                      Working...
                      X