Announcement

Collapse
No announcement yet.

OSS R500 Driver Gets Textured Video Too

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I bet the quality issues with TexturedVideo will be resolved in the near future with all the stuff going into the open source drivers...

    Comment


    • #12
      I look forward to the day when this gets extended to the Radeon HD 34xx as well (RV620).

      Comment


      • #13
        Originally posted by CrystalCowboy View Post
        I look forward to the day when this gets extended to the Radeon HD 34xx as well (RV620).
        I'm sure it can't be too far away... if RS690 is already supported then the RV620 can't be far behind.

        Comment


        • #14
          Xv working beautifully here with git drm and -ati driver on mobility x1600. I get about %40 cpu at 1.6ghz on athlon64 while watching 720p hd channel, and ~15% at 800mhz on regular channels on mythtv fulscreen at 1680x1050. No diagonal tearing or machine lock ups while changing channels like fglrx
          Last edited by c0un7d0wn; 02-25-2008, 04:43 PM.

          Comment


          • #15
            Originally posted by Porter View Post
            Interestingly, that occurs on both the Xv output and on OpenGL, though the GL output has improved slightly in that regard.
            It's been quite some time; but I think I even got that with -vo x11.

            As far as my previous comments on hardware accelerated video decoding, I think that'd be icing on the cake as fglrx doesn't even support it and I doubt it ever will. It effects me more on my R300/Athlon XP machine that I plan on converting to a DVR box than on my Core Duo/R500 laptop.

            As far as video playback goes, does anyone know the advantages of using the "gl2" output driver over xv? (If any, obviously a moot point currently on >=R500 chips now as gl won't work without mesa3d support)

            Comment


            • #16
              Originally posted by c0un7d0wn View Post
              Xv working beautifully here with git drm and -ati driver on mobility x1600. I get about %40 cpu at 1.6ghz on athlon64 while watching 720p hd channel, and ~15% at 800mhz on regular channels on mythtv fulscreen at 1680x1050. No diagonal tearing or machine lock ups while changing channels like fglrx
              What video player are you using? Do you get the same success using VLC or MPlayer?

              Comment


              • #17
                It's mythtv frontend. Same success with vlc, totem and mplayer.

                Comment


                • #18
                  Originally posted by c0un7d0wn View Post
                  It's mythtv frontend. Same success with vlc, totem and mplayer.
                  Is there any video tearing?

                  Comment


                  • #19
                    I haven't noticed really. But you don't get that horrible diagonal tearing in fglrx. Another thing I noticed is that the video is redirected. I had enabled the metacity compositing and I had a transparent terminal on top of the video and it was working properly.

                    Comment


                    • #20
                      X1600Xt - XV works. Totem, mplayer, vlc - all work. No tearing, performance is good.

                      But TVTime freezes the system. Also Zapping sometimes freezes the system when the channel switching. Also XawTV freezes with -nodga option. It works with -nodga -noxv - but there is no fullscreen video.

                      Comment

                      Working...
                      X