Announcement

Collapse
No announcement yet.

Installing The RadeonHD Driver On Ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    RE:Wont run.

    I think you just to run command like this.
    "sh runthis.sh" anything ending in '.sh" is a shell script and you must tell bash to treat it as so.
    Hope that helps ya.

    Comment


    • #12
      Only if the script is reallly POSIX compatible on systems like *buntu where sh is no symlink to bash but dash. My scripts are, but not all, some have implicit bash depends like some well known ATI scripts

      Comment


      • #13
        Hi rbmorse
        I maded this steps:
        cico-sail@Cico:~$ cd xf86-video-radeonhd/
        cico-sail@Cico:~/xf86-video-radeonhd$ git pull
        fatal: Not a git repository

        :-(

        Comment


        • #14
          Hi Kano
          Your suggestion is correct :-) now I haven't more the previous error.
          But now I have this:
          cico-sail@Cico:~$ apt-get devscripts fakeroot pbuilder
          E: Operazione non valida devscripts (in english can be like: Operation not valid devscripts)
          I need more one more help :-)
          Tank's

          Comment


          • #15
            Sorry forgot the "install" statement after apt-get. Just add this.

            Comment


            • #16
              Hi Kano, sorry for my forgetfulness :-)
              Ok, now I are on the next step where I run the commands:
              apt-get source xserver-xorg-video-radeonhd
              cd xserver-xorg-video-radeonhd*
              sed -i 's/^\(Build-Depends:\).*/\1 debhelper (>= 5), quilt, pkg-config, xserver-xorg-dev (>= 2:1.1), x11proto-video-dev, x11proto-fonts-dev, x11proto-randr-dev (>= 1.1), x11proto-render-dev, automake, autoconf, libtool, xutils-dev, x11proto-xext-dev/' debian/control
              # for use with Debian etch add this (would not hurt anyway)
              sed -i 's#^\(SERVERMINVERS =\).*#\1 $(shell cat /usr/share/xserver-xorg/serverminver 2>/dev/null||echo 2:1.1)#;
              s#^\(VIDEOABI =\).*#\1 $(shell cat /usr/share/xserver-xorg/videoabiver 2>/dev/null||echo 1.0)#;
              s#^\(INPUTABI =\).*#\1 $(shell cat /usr/share/xserver-xorg/inputabiver 2>/dev/null||echo 0)#' debian/xsfbs/xsfbs.mk

              and just here it's all right :-)

              Next with the command:
              cico-sail@Cico:~/xserver-xorg-video-radeonhd-1.1.0$ debuild -S

              I have a lot of messages until this:
              Now signing changes and any dsc files...
              signfile xserver-xorg-video-radeonhd_1.1.0-1.dsc Brice Goglin <bgoglin@debian.org>
              gpg: skipped "Brice Goglin <bgoglin@debian.org>": la chiave segreta non è disponibile (in english: the secret key isn't available)
              gpg: [stdin]: clearsign failed: la chiave segreta non è disponibile
              debsign: gpg error occurred! Aborting....
              debuild: fatal error at line 1174:
              running debsign failed

              They are necessary other helps :-) tank's

              Comment


              • #17
                That's ok, there is a way to skip signing attempts, but it already created the dsc file. I usually just forget about this warning.

                Comment


                • #18
                  Hi Kano, this means that have I to execute the next step?
                  Because if I run he:

                  cico-sail@Cico:~/xserver-xorg-video-radeonhd-1.1.0$ sudo apt-get build-dep xserver-xorg-video-radeonhd

                  I have some messages and finally:
                  [...]
                  Reading state information... Fatto
                  E: Build-Depends dipendenze per xserver-xorg-video-radeonhd non possono essere soddisfatte perché nessuna versione del pacchetto xserver-xorg-dev può soddisfare le richieste di versione
                  I try to translate:
                  "The dependency of xserver-xorg-video-radeonhd cannot be satisfied because no versions of the package xserver-xorg-dev can be satisfy the required version"

                  Comment

                  Working...
                  X