Announcement

Collapse
No announcement yet.

OSS radeon driver for A10-7850K (Kaveri)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSS radeon driver for A10-7850K (Kaveri)

    I've been trying to install these OSS drivers to replace the crappy proprietary ones for various reasons, but I've failed every time. Here's a record of my latest attempt.

    I am running Ubuntu 14.04 with the oibaf PPA enabled. I've got the proprietary AMD drivers installed, version 14.6. Things "work" but I want to switch to the OSS drivers. Here's the system info before my latest attempt: http://paste.ubuntu.com/8108095/

    Here is my latest attempt. The notes are abridged but describe everything I've done:

    apt-get remove --purge fglrx*

    Installed kernel 3.16
    Removed nomodeset kernel option
    update-grub

    apt-get update
    apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
    apt-get install xserver-xorg-video-ati
    apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
    apt-get install mesa-vdpau-drivers

    Confirmed no xorg.conf present
    Confirmed no /etc/ati dir present

    Code:
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name                                Version                Architecture           Description
    +++-===================================-======================-======================-===========================================================================
    un  fglrx-glx                           <none>                 <none>                 (no description available)
    ii  libegl1-mesa-drivers:amd64          10.3~git1408210730.d68 amd64                  free implementation of the EGL API -- hardware drivers
    un  libgl1-mesa-dev                     <none>                 <none>                 (no description available)
    ii  libgl1-mesa-dri:amd64               10.3~git1408210730.d68 amd64                  free implementation of the OpenGL API -- DRI modules
    ii  libgl1-mesa-dri:i386                10.3~git1408210730.d68 i386                   free implementation of the OpenGL API -- DRI modules
    un  libgl1-mesa-dri-experimental        <none>                 <none>                 (no description available)
    ii  libgl1-mesa-glx:amd64               10.3~git1408210730.d68 amd64                  free implementation of the OpenGL API -- GLX runtime
    ii  libgl1-mesa-glx:i386                10.3~git1408210730.d68 i386                   free implementation of the OpenGL API -- GLX runtime
    un  libgl1-mesa-glx-no-multiarch        <none>                 <none>                 (no description available)
    un  libgl1-mesa-swx11-dev               <none>                 <none>                 (no description available)
    ii  mesa-common-dev                     10.3~git1408111930.904 amd64                  Developer documentation for Mesa
    ii  mesa-utils                          8.2.0-1~gd~t           amd64                  Miscellaneous Mesa GL utilities
    ii  mesa-vdpau-drivers:amd64            10.3~git1408210730.d68 amd64                  Mesa VDPAU video acceleration drivers
    un  xlibmesa-dri                        <none>                 <none>                 (no description available)
    un  xlibmesa-gl-dev                     <none>                 <none>                 (no description available)
    un  xlibosmesa-dev                      <none>                 <none>                 (no description available)
    ii  xserver-xorg-dev                    2:1.15.1-0ubuntu2      amd64                  Xorg X server - development files
    ii  xserver-xorg-video-ati              1:7.4.99+git1408121930 amd64                  X.Org X server -- AMD/ATI display driver wrapper
    Rebooted

    "The system is running in low graphics mode
    Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself."

    uname -a:
    Linux gandalf 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:36:11 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

    inxi -G
    Graphics: Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 200 Series]
    X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@0.0hz
    GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits) GLX Version: 3.0 Mesa 10.3.0-devel (git-d682ebe 2014-08-21 trusty-oibaf-ppa+gallium-nine)

    vainfo:
    libva info: VA-API version 0.35.1
    libva info: va_getDriverName() returns -1
    libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
    vaInitialize failed with error code -1 (unknown libva error),exit

    fglrxinfo: command not found (of course)

    glxinfo: http://paste.ubuntu.com/8108133/
    dmesg: http://paste.ubuntu.com/8108096/
    Xorg.0.log: http://paste.ubuntu.com/8108006/

    Can anyone point me to further troubleshooting steps or a possible fix?

  • #2
    The fglrx install replaces a lot of things -- at minimum I think you'll need to uninstall and reinstall the mesa packages among others.

    There's a lot to be said for booting a vanilla distro image first and making sure that works, then using it as a guide to figure out how to get your current system back to as-installed state.

    Comment


    • #3
      You are either running under VM, or you miss microcode(amd-ucode, a bunch of bits that should be placed in correct folder). Because your 3D does not start and falls over to LLVM softpipe. If I understand correctly.
      Last edited by brosis; 08-21-2014, 06:11 PM.

      Comment


      • #4
        I am not running under any kind of virtual machine. This is a live, physical machine with an AMD A10-7850K processor and Gigabyte F2A88XM-D3H motherboard. I don't really know what you mean by missing microcode or amd-ucode, or what to do with that information.

        I might try a vanilla install at some point but I'm not used to reinstalling from scratch because of a misbehaving video driver. On top of that, there is no support in vanilla Ubuntu for the Kaveri APUs, and I need to disable kernel modesetting to get the default graphic drivers to work at all before I can start fixing the rest. Not fun, but if no one can point to what I can do to fix my current setup... On the other hand, I could always hang back 2 major versions of XBMC and deal with crappy proprietary drivers for a year or two until Ubuntu fixes support for it and I don't need bleeding edge drivers.

        One sure thing, I ain't buying an AMD APU or video card for a linux system ever again.

        Comment


        • #5
          Originally posted by splice42 View Post
          I might try a vanilla install at some point but I'm not used to reinstalling from scratch because of a misbehaving video driver.
          Sorry, didn't mean reinstall, I meant try a vanilla install with live CD or on another partition so you have a working system to compare with. Give me a few minutes and I'll check the 14.04 as live CD.

          Originally posted by splice42 View Post
          On top of that, there is no support in vanilla Ubuntu for the Kaveri APUs,
          Have to disagree here, I have a few different Kaveri systems running on vanilla Ubuntu 14.04 with full acceleration (at least 2D/3D, haven't tried video accel).

          Originally posted by splice42 View Post
          and I need to disable kernel modesetting to get the default graphic drivers to work at all before I can start fixing the rest.
          Disabling kernel modesetting will prevent the default graphics drivers from working. You need to leave it enabled.

          Comment


          • #6
            OK, posting this from a 14.04 install disk running as live CD on a Kaveri box :



            This box happens to have a 7700 rather than 7850 (my 7850 box is in the office at the moment) but they all work the same.

            Comment


            • #7
              Originally posted by bridgman View Post
              The fglrx install replaces a lot of things -- at minimum I think you'll need to uninstall and reinstall the mesa packages among others.
              Hold on, looks like you already reinstalled mesa. OK, looking at logs.

              Can you pls check whether booting a 14.04 live CD gives you acceleration ? Did the open source drivers work before you installed fglrx ?

              Comment


              • #8
                OK, kernel driver seems to be coming up OK. X server & glamor driver come up ok on radeonsi GL driver until this happens :

                [ 15.403] (II) AIGLX: Loaded and initialized radeonsi
                [ 15.403] (II) GLX: Initialized DRI2 GL provider for screen 0
                [ 15.446] XXX fail to create fbo.
                [ 15.446] (EE)
                [ 15.446] (EE) Backtrace:
                [ 15.447] (EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x7fac30ab8c78]
                [ 15.447] (EE) 1: /usr/bin/X (0x7fac30910000+0x1ac969) [0x7fac30abc969]
                [ 15.447] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fac2f9f0000+0x10340) [0x7fac2fa00340]
                [ 15.447] (EE) 3: /usr/lib/x86_64-linux-gnu/libglamor.so.0 (glamor_set_screen_pixmap+0x4f) [0x7fac29c242ef]
                [ 15.447] (EE) 4: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_create_textured_screen+0x79) [0x7fac291f1e89]
                [ 15.447] (EE) 5: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_create_textured_screen_ext+0x3d) [0x7fac291f1f1d]
                [ 15.447] (EE) 6: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7fac2a070000+0x4bb2e) [0x7fac2a0bbb2e]
                [ 15.447] (EE) 7: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7fac2a070000+0x448b6) [0x7fac2a0b48b6]
                [ 15.447] (EE) 8: /usr/bin/X (0x7fac30910000+0xc786e) [0x7fac309d786e]
                [ 15.447] (EE) 9: /usr/bin/X (0x7fac30910000+0x59806) [0x7fac30969806]
                [ 15.447] (EE) 10: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf5) [0x7fac2e409ec5]
                [ 15.447] (EE) 11: /usr/bin/X (0x7fac30910000+0x44e7e) [0x7fac30954e7e]
                [ 15.447] (EE)
                [ 15.447] (EE) Segmentation fault at address 0x1c
                [ 15.447] (EE)
                Fatal server error:
                [ 15.447] (EE) Caught signal 11 (Segmentation fault). Server aborting
                [ 15.447] (EE)
                [ 15.447] (EE)
                Please consult the The X.Org Foundation support
                at http://wiki.x.org
                for help.
                Maybe some EGL-related library still needs to be restored (or removed), not sure.

                After booting with the live CD and confirming you have HW acceleration (Gallium 0.4 on Kaveri) can you boot back to your system and try running "LIBGL_DEBUG=verbose glxinfo" ? That might help to understand why you're getting llvmpipe instead of radeonsi for GL.

                Comment


                • #9
                  Originally posted by bridgman View Post
                  Disabling kernel modesetting will prevent the default graphics drivers from working. You need to leave it enabled.
                  Unless the vanilla 14.04 LTS LiveCD has been changed in the last 2-3 months, no, that is untrue in my case. If I don't disable modesetting, I never get into X, the graphics driver crashes. Perhaps it's a combination of my motherboard and CPU and not just the CPU. At any rate, with the default Ubuntu 14.04 LiveCD settings, I cannot boot into X at all. I googled all over back when I experienced this, found someone who said disabling modesetting was the fix, tried it, and it worked fine.

                  That being said, I removed that when I upgraded to kernel 3.16 and tried the OSS drivers, since I know OSS drivers require kernel modesetting. X still crashes, but I'm not sure that's the reason.

                  At any rate I'll dig up my LiveCD or make a new one to re-re-re-re-confirm all of this. It feels like doing the same steps I've already done a dozen times, but since you insist that it should work, I'll try again.

                  Comment


                  • #10
                    Originally posted by splice42 View Post
                    If I don't disable modesetting, I never get into X, the graphics driver crashes. Perhaps it's a combination of my motherboard and CPU and not just the CPU. At any rate, with the default Ubuntu 14.04 LiveCD settings, I cannot boot into X at all. I googled all over back when I experienced this, found someone who said disabling modesetting was the fix, tried it, and it worked fine.
                    OK, I think we're saying the same thing here... sounds like disabling KMS (which AFAIK disables most of the graphics stack) was getting you around a startup crash. Probably best not to think of that as a fix, but rather a workaround with a big performance hit. It's possible you were running the VESA driver with LLVM (the radeon stack hasn't fully supported UMS for a long time), but not 100% sure of that.

                    It'll be interesting to see what happens when you try the live CD again -- we have maybe 50 different COTS Kaveri/mobo systems running here that came up fine on a stock 14.04 install, and I'm pretty sure at least one of them is running exactly the same mobo as you. I have a vague recollection of one problem related to very large RAM complement, will see if I can dig up what that was.

                    Note that essentially all of our testing has been with actual installs -- I just tried the live CD on a couple of systems at home to make sure I wasn't giving you bad info.
                    Last edited by bridgman; 08-22-2014, 12:51 PM.

                    Comment


                    • #11
                      Bah... stupid 5 minute edit limit - s/LLVM/llvmpipe/ in the previous post (auggh... on the previous page)

                      Comment


                      • #12
                        I use Debian, but tried to booting Ubuntu 14.04 i remember few months ago, but here on Kabini system... dpm was disabled by default and ColorTiling/ColorTiling2D ddx options were also disabled by default .

                        Just friendly reminder, it may be not the same on Kaveri or may not be the same with current 14.04 install images . So, boot liveCD and check dmesg/Xorg.0.log (or post them here if you can't understand them) to see what happens there
                        Last edited by dungeon; 08-22-2014, 03:48 PM.

                        Comment


                        • #13
                          So, LiveCD results. I booted off the same media I was using, edited the grub command line and added nomodeset because otherwise it crashes.

                          It's using the radeon oss driver by default, but only allows 1024x768 (I need 1080p) and is using software rendering. On the other hand, I should add the oibaf repository and upgrade the drivers + mesa to get proper support for the processor, as far as I'm aware. Since that + a kernel upgrade to 3.16 would require rebooting, I'll need to do an install eventually to test all of that. I'll find a spare HD somewhere and try it out I guess, but for now here is the info from the booted 14.04 LiveCD. I selected main/universe/restricted/multiverse package sources, updated them, installed pastebinit, inxi and mesa-utils (for glxinfo).

                          lsb_release -a:
                          No LSB modules are available.
                          Distributor ID: Ubuntu
                          Description: Ubuntu 14.04 LTS
                          Release: 14.04
                          Codename: trusty

                          uname -a:
                          Linux ubuntu 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

                          inxi -G:
                          Graphics: Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 200 Series]
                          X.Org: 1.15.1 drivers: fbdev,ati,radeon (unloaded: vesa) Resolution: 1024x768@76.0hz
                          GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits) GLX Version: 2.1 Mesa 10.1.0

                          /usr/lib/nux/unity_support_test -p:
                          OpenGL vendor string: VMware, Inc.
                          OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
                          OpenGL version string: 2.1 Mesa 10.1.0

                          Not software rendered: no
                          Not blacklisted: yes
                          GLX fbconfig: yes
                          GLX texture from pixmap: yes
                          GL npot or rect textures: yes
                          GL vertex program: yes
                          GL fragment program: yes
                          GL vertex buffer object: yes
                          GL framebuffer object: yes
                          GL version is 1.4+: yes

                          Unity 3D supported: no



                          dmesg: http://paste.ubuntu.com/8116853/
                          Xorg.0.log: http://paste.ubuntu.com/8116856/
                          glxinfo: http://paste.ubuntu.com/8116872/


                          I'll probably post the glxinfo with LIBGL_DEBUG set to verbose from the existing system with kernel 3.16/mesa 10.3/xfree-xorg-video-ati 7.4.99 from oibaf later tonight or something like that. It'd be nice if that could lead to an eventual fix, but I'll still be doing the new install on a spare HD to see where I get with that since I figure that may be the best/cleanest option. All my media library is in an external RAID and it's a dedicated PVR, so I just need to save all my various configs... and hopefully remember all the fixes I accumulated to get it where it is. I remember having fun getting AC3/DTS passthrough to work, but that was an XBMC 13 thing I thing....

                          At any rate, I'm rambling. Thanks for the help so far, I feel like I have some hope, maybe.

                          Comment


                          • #14
                            Originally posted by dungeon View Post
                            I use Debian, but tried to booting Ubuntu 14.04 i remember few months ago, but here on Kabini system... dpm was disabled by default and ColorTiling/ColorTiling2D ddx options were also disabled by default .

                            Just friendly reminder, it may be not the same on Kaveri or may not be the same with current 14.04 install images . So, boot liveCD and check dmesg/Xorg.0.log (or post them here if you can't understand them) to see what happens there
                            We generally disable features by default if there are doubts about them working on all systems -- the key thing particularly for distros is making sure the initial boot experience goes well (vs maximizing performance etc..), that's why I'm surprised by the problems splice42 is reporting.

                            Comment


                            • #15
                              Originally posted by bridgman View Post
                              We generally disable features by default if there are doubts about them working on all systems -- the key thing particularly for distros is making sure the initial boot experience goes well (vs maximizing performance etc..), that's why I'm surprised by the problems splice42 is reporting.
                              I know that and i am fine with that, but just wanna help OP somwhow if he try default image .

                              But according to first post he use pretty recent mesa, but with libglamor so he get "XXX fail to create fbo." for some reason. Might we just some bug in current mesa with that combination .

                              Comment

                              Working...
                              X