Announcement

Collapse
No announcement yet.

AMD "Hawaii" Open-Source GPU Acceleration Still Not Working Right

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #81
    Originally posted by drSeehas View Post
    Sure?
    AFAIR Oland was released after Bonaire (GCN 1.1).

    Curacao = Bonaire?
    Yes, I'm sure. Oland is SI-based. Curacao = pitcairn.

    Comment


    • #82
      SI

      Originally posted by agd5f View Post
      ... Oland is SI-based.
      SI = Southern Islands (R1000, GCN 1.0)
      or
      SI = Sea Islands (R1100, GCN 1.1)
      ?
      Curacao = pitcairn.
      Thx!
      Why another name for the same chip?

      Comment


      • #83
        Originally posted by drSeehas View Post
        Why another name for the same chip?
        I suppose for same purposes why 7XXX turn into R9 / R7.

        Comment


        • #84
          Originally posted by drSeehas View Post
          SI = Southern Islands (R1000, GCN 1.0)
          or
          SI = Sea Islands (R1100, GCN 1.1)
          ?

          SI =Southern Islands (GCN 1.0)
          CI = Sea Islands (GCN 1.1)

          Comment


          • #85
            Jerome Glisse started sending some patches for both mesa and kernel which are fixing certain hawaii issues. So hopefully it will start working soon....

            Comment


            • #86
              It's now working more or less. Grab the latest ucode here http://people.freedesktop.org/~agd5f...e/ucode.tar.gz and use the http://cgit.freedesktop.org/~agd5f/l...-next-3.17-wip kernel tree, plus this ddx patch http://people.freedesktop.org/~agd5f...tionally.patch

              Comment


              • #87
                Originally posted by agd5f View Post
                And of course mesa git i guess .

                Cheers

                Comment


                • #88
                  Originally posted by agd5f View Post
                  So, Alex, what was the problem? The typos uncovered by Jerome and bugs in firmware only?

                  Also as a side question, is there any news on hyperz issues? I mean is it known what causes this weird corruption in shadows? From a user prospective this is one of the last annoying bugs in radeonsi for me.

                  BTW, thanks for all your work!

                  Comment


                  • #89
                    Seems like firmware issue mostly (it is not opensource for me, so i don't know ), nop packet 0x21 which makes it work .

                    Comment


                    • #90
                      Originally posted by dungeon View Post
                      And of course mesa git i guess .

                      Cheers
                      mesa version shouldn't matter as long as it has hawaii support.

                      Comment

                      Working...
                      X