Announcement

Collapse
No announcement yet.

New Kernel Old Radeon 9200

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Kernel Old Radeon 9200

    I have an RV280 and a new install.

    That means I have kernel 2.6.22 or 23 (currently 23).

    I have Xorg 7.2 and Xorg-server-1.3.

    And I want to run TV-OUT S-Video, specifically on bootup.

    I can't get it to work.

    The binary driver simply doesn't support the new xorg, and getting the old 7.1 (on gentoo) is a pain in the toucas. And it doesn't support the kernel anyway (although there's a way around that).

    The open source driver (I'm using latest and it should support TVout) won't initialize svideo unless I have a VGA monitory connected and then doesn't give me a synchronized signal, the monitor rolls horizontally as if the timing were wrong.

    So my question is: how can I get this to work?

    My only option to date that I know will work is to buy a Geforce 6200 or a newer radeon so I can use their binary drivers.

    Any advice will be greatly appreciated.

    Raydude

  • #2
    Originally posted by raydude View Post
    So my question is: how can I get this to work?
    The odds aren't very good. The technical information is not likely to be made available anytime soon (per discussions with AMD's official rep hanging out here in the forums...); they've signed deals with media companies and the media protection companies to not enable that output edge without having Macrovision turned on in a way that can't be disabled. My advice to you is if you want to output from the 9200, you probably want to get a VGA to Composite/S-Video converter box for $60-120 and just forget the integrated version that's deliberately crippled on the card.

    Comment


    • #3
      Most easy way would be using fbdev/vesa.

      Comment


      • #4
        In this particular case it sounds like the tv output is sometimes being enabled but the timing isn't right. I believe the radeon driver may already have the tv output working in which case this is just a case of getting the display detection and timing right. You might want to subscribe to xorg or xorg-ati mailing lists and ask there.

        Svartalf is right about the legal concerns though. Our current thinking is that we're OK enabling the output without Macrovision as long as (a) we continue to hide the mechanisms for turning MV on and off, and (b) we never get in a situation where there is a standard API for informing a player app that the outputs are protected and the OSS driver says "sure, that output is protected, you betcha" while continuing to send out unprotected video.

        Anyways, ping one of the xorg lists, see what they say, and let us know. We're not planning on making any changes in the way open source drivers are supported as a result of Alex or others joining AMD -- what we *are* trying to do is significantly improve the level of support we give to open source developers in general.
        Last edited by bridgman; 12-01-2007, 10:00 AM.

        Comment


        • #5
          Originally posted by raydude View Post
          I have an RV280 and a new install.

          That means I have kernel 2.6.22 or 23 (currently 23).

          I have Xorg 7.2 and Xorg-server-1.3.

          And I want to run TV-OUT S-Video, specifically on bootup.

          I can't get it to work.

          The open source driver (I'm using latest and it should support TVout) won't initialize svideo unless I have a VGA monitory connected and then doesn't give me a synchronized signal, the monitor rolls horizontally as if the timing were wrong.

          So my question is: how can I get this to work?

          Raydude
          The open source driver supports tv-out, however, only NTSC seems to work reliably so far. Also, the only way to detect that a tv is attached is via load detection, which at the moment does not work reliably on the tvdac so it is disabled by default. You can enable load detection by setting Option "TVDACLoadDetect" "true" in the device section of your config. YMMV. I suppose I should add a driver option at some point to force tv-out on.

          Comment


          • #6
            I got it to work. Note this is the versions I'm running (all under gentoo):

            Code:
            equery list xorg
            [ Searching for package 'xorg' in all categories among: ]
             * installed packages
            [I--] [  ] app-doc/xorg-docs-1.4-r1 (0)
            [I--] [  ] x11-base/xorg-server-1.3.0.0-r2 (0)
            [I--] [  ] x11-base/xorg-x11-7.2 (0)
            Code:
            equery list ati
            [ Searching for package 'ati' in all categories among: ]
             * installed packages
            [I--] [ ~] x11-drivers/xf86-video-ati-6.7.196-r1 (0)
            Code:
            equery list xrandr
            [ Searching for package 'xrandr' in all categories among: ]
             * installed packages
            [I--] [  ] x11-apps/xrandr-1.2.2 (0)
            The trick is to force the VGA output on, even when the VGA monitor isn't connected. You also have to force the modeline for 800x600 as it won't be auto detected correctly unless a VGA monitor is connected.

            I got the modeline by grabbing it out of /var/log/Xorg.0.log.

            Code:
            Section "Module"
                Load        "dbe"   # Double buffer extension
                SubSection  "extmod"
                   Option      "omit xfree86-dga"   # don't initialise the DGA extension
                EndSubSection
                Load        "freetype"
            EndSection
            
            Section "Files"
                FontPath   "/usr/share/fonts/misc/"
                FontPath   "/usr/share/fonts/Type1/"
                FontPath   "/usr/share/fonts/100dpi/"
                FontPath   "/usr/share/fonts/75dpi/"
            EndSection
            
            Section "ServerFlags"
            EndSection
            
            Section "InputDevice"
                Identifier  "Keyboard1"
                Driver      "kbd"
                Option "AutoRepeat" "500 30"
                Option "XkbRules"   "xorg"
                Option "XkbModel"   "pc104"
                Option "XkbLayout"  "us"
            EndSection
            
            Section "InputDevice"
                Identifier  "Mouse1"
                Driver      "mouse"
                Option "Protocol"    "Auto" # Auto detect
                Option "Device"      "/dev/input/mice"
                Option "ZAxisMapping"   "4 5 6 7"
            EndSection
            
            Section "Device"
                    Identifier      "Radeon 9200"
                    Boardname       "ATI Radeon"
                    Busid           "PCI:3:0:0"
                    Driver          "radeon"
                    Vendorname      "ATI"
                    Option          "Monitor-VGA-0"         "VGA Monitor"
                    Option          "Monitor-S-video"       "S-Video Monitor"
            EndSection
            
            Section "Monitor"
                    Identifier      "VGA Monitor"
                    Vendorname      "LG"
                    Modelname       "CRT 1280x1024"
                    Option          "DPMS"
                    Option          "PreferredMode" "800x600"
                    Option          "Enable" "true" # force vga on, this is necessary.
                    HorizSync       30-96
                    VertRefresh     50-160
                   #force VGA to the same resolution as S-Video
                    Modeline "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
            EndSection
            
            Section "Monitor"
                    Identifier      "S-Video Monitor"
                    Vendorname      "Unknown"
                    Modelname       "TV or Beamer"
                    Option          "DPMS"
                    Option          "Enable" "true" # Force S-Video on, it is not detected correctly
                   # Force the 800x600 modeline. THIS IS THE ONLY MODE FOUND TO WORK.
                    Modeline "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
            EndSection
            
            Section "Screen"
                    Identifier      "Default Screen"
                    Device          "Radeon 9200"
                    Defaultdepth    24
                    Monitor         "S-Video Monitor"
                    SubSection "Display"
                            Depth   24
                            Modes           "800x600"
                    EndSubSection
            EndSection
            
            Section "ServerLayout"
                    Identifier      "Default Layout"
                    Screen          "Default Screen"
                    InputDevice     "Keyboard1"
                    InputDevice     "Mouse1"
            #       Option          "AIGLX" "true"
            EndSection
            
            # Section "DRI"
            #    Mode 0666
            # EndSection
            I hope someone else finds it useful.

            Raydude

            Comment


            • #7
              New option added

              FWIW, I just added an option to the driver (ati git master) to force tv-out to always be detected as attached. I also added an option to force the default tv-standard if you want something besides the bios default.

              Option "ForceTVOut" "true"

              Option "TVStandard" "ntsc"

              See the radeon man page for more info.

              Comment


              • #8
                Wow, that was fast

                Comment


                • #9
                  That was fast! Thanks much!

                  Raydude

                  Comment


                  • #10
                    Originally posted by bridgman View Post
                    Wow, that was fast
                    Heh... Alacrity is one of those things you need to keep in mind with us crazies.

                    Comment


                    • #11
                      agd5f,

                      I have another problem. I'm running latest git with the new options you added and it brings up the TV just fine (it still brings up VGA though which is odd).

                      The problem is when I play a video stream I get blank display. I switched to the latest git because when I was forcing S-Video I got clone output on the TV of what was on the VGA screen, but when I ran video it only showed on the VGA, not on the TV (TV was blank).

                      I was hoping the git version would give me primary video on the TV but now I get no video at all. Is there a way to specify primary display?

                      Thanks again for all your help,

                      Raydude

                      Update: actually it looks like I'm not running git. I have to figure this out:
                      Code:
                      (WW) RADEON(0): Option "ForceTVOut" is not used
                      (WW) RADEON(0): Option "TVStandard" is not used
                      Last edited by raydude; 12-01-2007, 07:02 PM.

                      Comment


                      • #12
                        Originally posted by raydude View Post
                        agd5f,

                        I have another problem. I'm running latest git with the new options you added and it brings up the TV just fine (it still brings up VGA though which is odd).
                        Is there something in your config that's forcing it on? I'd probably need to see your xorg config and log. You can force the VGA port off by adding a monitor section to your config and associating it with the VGA port and telling it to turn off the output on startup, or ignore it all together. See this page for more on randr xorg.conf configuration:
                        http://www.intellinuxgraphics.com/dualhead.html

                        Originally posted by raydude View Post
                        The problem is when I play a video stream I get blank display. I switched to the latest git because when I was forcing S-Video I got clone output on the TV of what was on the VGA screen, but when I ran video it only showed on the VGA, not on the TV (TV was blank).

                        I was hoping the git version would give me primary video on the TV but now I get no video at all. Is there a way to specify primary display?
                        The video overlay can only be sourced to one crtc at a time. In dualhead mode the overlay follows the window, in clone mode you have to pick which crtc you want to display on. You can force the overlay onto the crtc of your choice with by toggling the XV_CRTC output attribute using an application like xvattr, e.g.:
                        xvattr -a XV_CRTC -v 1
                        set the value to 0 (crtc 0), 1 (crtc 1), or -1 (auto).
                        In your case since the VGA port is active the overlay is displaying on the crtc driving that output. So you can either disable the VGA output or use XV_CRTC to toggle the crtc the overlay is sourced to.

                        Comment


                        • #13
                          Originally posted by agd5f View Post
                          Is there something in your config that's forcing it on?
                          If I don't force on the VGA output then the S-Video does not sync. Its as if something is not initialized properly when the only thing connected is S-Video. I get pixels but the frame is torn. Kinda shredded like paper horizontally.

                          Originally posted by agd5f View Post
                          xvattr -a XV_CRTC -v 1
                          This completely fixed it for me. I don't care if the VGA is on as long as the svideo output is working and with that command it does.

                          Thank you so much you saved me $50.00

                          Raydude

                          Comment


                          • #14
                            Okay. Last problem. I think.

                            I'm running mythtv on this box and for some reason when mythfrontend runs it can't allocate any video buffers. However, if I choose setup and proceed through the menus until I get to the screen that allows me to configure the drawing engine (xv-blit, opengl, x11lib, etc) then tell it to save the setting, then exit back to the main menu and click play movie (or dvd or what ever) then it works just fine.

                            It has this behavior no matter which output, vga or svideo. And I'm pretty sure its not mythtv because another similar system with an NV card works fine.

                            If I exit mythfrontend, then I have to run setup again to get it to draw.

                            This is an oddball problem, I must say.

                            Raydude

                            Comment


                            • #15
                              Originally posted by raydude View Post

                              It has this behavior no matter which output, vga or svideo. And I'm pretty sure its not mythtv because another similar system with an NV card works fine.

                              If I exit mythfrontend, then I have to run setup again to get it to draw.
                              It sounds like a myth problem to me. For some reason myth is choosing the wrong Xv port or something? Just a guess. I haven't used myth in years. See if Xv works with another app like tvtime or xine. If it does, I'd say it's a myth issue.

                              Comment

                              Working...
                              X