Announcement

Collapse
No announcement yet.

Dual Head with X1400 with RadeonHD 1.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dual Head with X1400 with RadeonHD 1.0

    I've been trying to use RadeonHD to power my Thinkpad t60p with an X1400 card. The laptop display is the stock 1400x1050, and I power a 24" Dell LCD at 1920x1200 via DVI (with a dock/port-replicator). All on Fedora 8.

    This all works with fglrx (sortof), but with radeonhd, the laptop panel is right, but the external lcd is at the wrong resolution.

    xrandr can set the external LCD to the proper resolution, but the actual Gnome desktop doesn't resize to the full screen (the background image does, but the gnome-panel/windows stay inside the smaller resolution).

    Is there something obvious I'm missing to make the external monitor always hit the proper resolution? xorg.conf changes don't seem to help.

    Thanks - let me know if any further detail is needed.

  • #2
    You might want to ping the developers on the radeonhd mailing list -- radeonhd at opensuse.org. I think you need to subscribe first -- radeonhd+subscribe at opensuse.org.

    Comment


    • #3
      I didn't want to post this directly to the mailing list, as I figured it was more of a user/support question than a development issue.

      Comment


      • #4
        Originally posted by sgarrity View Post
        I've been trying to use RadeonHD to power my Thinkpad t60p with an X1400 card. The laptop display is the stock 1400x1050, and I power a 24" Dell LCD at 1920x1200 via DVI (with a dock/port-replicator). All on Fedora 8.

        This all works with fglrx (sortof), but with radeonhd, the laptop panel is right, but the external lcd is at the wrong resolution.

        xrandr can set the external LCD to the proper resolution, but the actual Gnome desktop doesn't resize to the full screen (the background image does, but the gnome-panel/windows stay inside the smaller resolution).

        Is there something obvious I'm missing to make the external monitor always hit the proper resolution? xorg.conf changes don't seem to help.

        Thanks - let me know if any further detail is needed.
        What I guess is a conflict between RandR and Xinerama. Try to disable Xinerama and see what you get.

        Comment


        • #5
          Originally posted by fatfatwolf View Post
          What I guess is a conflict between RandR and Xinerama. Try to disable Xinerama and see what you get.
          Thanks for the reply - how do I diable Xinerama? In xorg.conf?

          Comment

          Working...
          X