Announcement

Collapse
No announcement yet.

Catalyst 14.4 Has Advantages Over Linux 3.15 + Mesa 10.3 Git

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by dungeon View Post
    Yep i can confirm that issue with 0AD, just installed it. It is not even maxed out i leaved it to default and just enable postprocessing and yes all is black .

    And when i select Smooth LOS game just segfaults .
    alpha16 new graphics options are a bit bugged. You should restart the game after changing graphics options.

    Comment


    • #62
      Originally posted by oibaf View Post
      alpha16 new graphics options are a bit bugged. You should restart the game after changing graphics options.
      Yep game immediately segfault when i check that option, but not when i am in start menu Of course that is workaround with Smooth LOS, but postprocessing remains black whatever or how i set it.

      Spotted blackiness in Unigine Sanctuary today too, i don't know how Michel can benchmark that driver when rendering is so broken . Who cares if fps is faster when rendering is broken

      Last edited by dungeon; 05-20-2014, 03:11 PM.

      Comment


      • #63
        Originally posted by dungeon View Post
        Yep game immediately segfault when i check that option, but not when i am in start menu Of course that is workaround with Smooth LOS, but postprocessing remains black whatever or how i set it.

        Spotted blackiness in Unigine Sanctuary today too, i don't know how Michel can benchmark that driver when rendering is so broken . Who cares if fps is faster when rendering is broken

        well in my 7700 since llvm 3.5 this issue dont happen to me in any unigine demo anymore and yes oibaf is right if i restart the game with all options active it works just fine for me, the issue is just when you switch them in realtime, llvm 3.5 also fix some weirdness in Civ5 BnW under wine i had with old LLVM stack. Also i noticed that my 7700 dont slowdown either with 3.15 kernel + PTE patches compared to 3.14, so i guess many of this radeonsi issue apply mostly to GCN 1.1+ hardware.

        in my case the only bug i seen affecting my GCN 1.0 card is you truck game trace

        Comment


        • #64
          Originally posted by jrch2k8 View Post
          well in my 7700 since llvm 3.5 this issue dont happen to me in any unigine demo anymore
          I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .

          Comment


          • #65
            Originally posted by dungeon View Post
            I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .
            Nope, just rebuilded mesa against llvm3.5-svn209039 the same issue in Sanctuary .

            So jrch2k8 did you compare it against swrast or fglrx, do you have that half black wall, missing lighting from windows, etc

            This is how it looks like with fglrx

            Last edited by dungeon; 05-20-2014, 07:16 PM.

            Comment


            • #66
              Originally posted by dungeon View Post
              I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .
              hd 7790 (llvm\mesa git) and intel hd 2500

              Comment


              • #67
                Originally posted by dungeon View Post
                I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .

                Comment


                • #68
                  Much thanks Pontostroy for the screenshot and the video. Swrast and intel driver behave OK there, but as you can see on radeonsi all shadows are broken, darker, missing and missplaced .

                  Comment


                  • #69
                    How to run this utility after unpacked it?

                    Comment


                    • #70
                      Originally posted by Azrael5 View Post
                      How to run this utility after unpacked it?
                      Just run a script Sanctuary is 32bit so if you use 64bit OS you will need 32bit graphics stack installed too, and which one that will be of course depends on the driver you use .

                      Comment


                      • #71
                        Originally posted by dungeon View Post
                        Much thanks Pontostroy for the screenshot and the video. Swrast and intel driver behave OK there, but as you can see on radeonsi all shadows are broken, darker, missing and missplaced .
                        With current git shadows looks fine.

                        Comment


                        • #72
                          Originally posted by dungeon View Post
                          I overall considered radeon driver at 40-80% GL performance level of Windows Catalyst. And we are at the same level for more then 10 (fuckin' years baby yes ) years, so nothing changed for that matter in more then 10 years . I use r200 driver ~10 years (and compared it from the dri1 times when it perform the best that is around 2006. just before AMD cames with their opensource strategy), and now i see radeonsi is on the same level when compared with Windows Catalyst, so i can clearly say - absolutly nothing changed there with GL performance wise .

                          When i say that i always excluded bugs in radeon (there are many bugs out there), i just considered that N/A .
                          Openarena:
                          10 years ago, hd4830 with no DPM did 1 fps software rendering with radeon; and 300 fps in catalyst, with 40fps at pixel_vomit map with bloom+flares+hires textures.
                          Today hd830 with radeon has automatic DPM and it does 280 fps and 40 fps at pixel_vomit map with bloom+flares+hires textures (since kernel 3.15+Mesa 10.2.2).
                          Alone the fact how open radeon destroyed closed source macos, which has similar marketshare to linux, shows a LOT.

                          Your R100 card is over 10 years old, what improvement do you expect? Pick more modern card and do a time travel. This is considering Linux.

                          With windumbs, there is no point in time travel because it has HUGE marketshare. So referencing windumbs has only a point as a maximum achievable performance and not as a usable alternatives. Because in that case, thats completely wrong forum.

                          Comment


                          • #73
                            Originally posted by verde View Post
                            I strongly believe after all those years that opensource AMD drivers will NEVER be on par with the closedsource when we talk about Gaming.

                            Even when they perform better, is because tesselation and shaders are missing.

                            And then because of the quality of the AMD closed-source drivers, I chose nVidia GPU again. Their drivers are in excellent shape and their legacy support very good.
                            I play games with the free radeon driver. It works really well and its alot more stable than both catalyst and nvidia

                            I was surprised how well the modern intel gpus run too with mesa

                            Comment


                            • #74
                              Originally posted by brosis View Post
                              pixel_vomit map
                              Correction, its called projectile vomit, "pvomit". It uses a lot of light sources. Very resource heavy if bloom and flare effects are enabled.

                              Comment


                              • #75
                                Originally posted by Pontostroy View Post
                                With current git shadows looks fine.
                                Yeah, i know for few days

                                https://bugs.freedesktop.org/show_bug.cgi?id=79035

                                Comment

                                Working...
                                X