Announcement

Collapse
No announcement yet.

How to enable opengl 3.3 on r9 270?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to enable opengl 3.3 on r9 270?

    Question in the title. Using Ubuntu 14.04 with 3.14 kernel and oibaf PPA(mesa 10.2)

    Reading around I should have openGL 3.3, but it's only 3.0? I can't run a lot of benchmarks/games that require later GL versions.

  • #2
    OpenGL 3.1 and higher are only available with the core profile. If you run "glxinfo | grep core" it should give you the highest version available with a core profile.

    Comment


    • #3
      Originally posted by droste View Post
      OpenGL 3.1 and higher are only available with the core profile. If you run "glxinfo | grep core" it should give you the highest version available with a core profile.
      OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.2.0-devel (git-857f3a6 trusty-oibaf-ppa)

      Is this normal? I can't run unigine heaven It works just fine with fglrx

      Comment


      • #4
        Hm maybe kernel too old? AFAIK radeonsi should be at OGL 3.3.

        you could try to run it with MESA_GL_VERSION_OVERRIDE=3.2 and MESA_GLSL_VERSION_OVERRIDE=150 set.

        Code:
        MESA_GL_VERSION_OVERRIDE=3.2 MESA_GLSL_VERSION_OVERRIDE=150 ./heaven

        Comment


        • #5
          Originally posted by droste View Post
          Hm maybe kernel too old? AFAIK radeonsi should be at OGL 3.3.

          you could try to run it with MESA_GL_VERSION_OVERRIDE=3.2 and MESA_GLSL_VERSION_OVERRIDE=150 set.

          Code:
          MESA_GL_VERSION_OVERRIDE=3.2 MESA_GLSL_VERSION_OVERRIDE=150 ./heaven
          Tried with both kernel 3.14 and 3.13, it's the same on both. HDMI audio doesn't work on 3.14 so I'm back on 3.13...

          Trying that just outputs a black screen

          Code:
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          GLFfp::create_shader(): can't create shader
          0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
          OpenGL error: invalid value

          Comment


          • #6
            Hum, not sure what I did but the override seems to be working now. I wonder why I don't have 3.3 core by default though, the x.org site notes that you need LLVM 3.5 maybe that's it?

            Comment


            • #7
              You need LLVM 3.5, which hasn't been released yet, so you have to compile it manually from git or svn. Then, you have to reconfigure and recompile Mesa. The Mesa ./configure script must print that it found LLVM 3.5.

              Comment


              • #8
                Fglrx is 50% faster than the open source driver (in unigine heaven, anyways)

                Thanks for the help.

                Comment


                • #9
                  Originally posted by marek View Post
                  You need LLVM 3.5, which hasn't been released yet, so you have to compile it manually from git or svn. Then, you have to reconfigure and recompile Mesa. The Mesa ./configure script must print that it found LLVM 3.5.
                  is LLVM 3.5 the same as LLVM 3.4.1? if not, does LLVM 3.4.1 help somehow?
                  Last edited by asdfblah; 04-12-2014, 09:06 PM.

                  Comment


                  • #10
                    Where are you seeing LLVM 4.1 ? The most recent release is 3.4 and 3.5 is "work in process" :

                    http://llvm.org/releases/download.html

                    EDIT -- ahh, I see, you meant 3.4.1... but not sure where you are seeing that either

                    Comment

                    Working...
                    X