Announcement

Collapse
No announcement yet.

xf86-ati build errors after 'require libdrm 2.4.51' patch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • xf86-ati build errors after 'require libdrm 2.4.51' patch

    So. After the "require libdrm 2.4.51" patch, i am unable to build xf86-video-ati from git (i can if i revert that patch).
    I have Debian Testing which ships libdrm 2.4.51 and i even built drm from git myself today (2.4.52), but i still get
    Code:
    Requested 'libdrm >= 2.4.51' but version of libdrm is 2.4.46
    when i configure. I recloned both drm and xf86-video-ati so thats not a problem.

    How can i find out which library/file is the culprit (maybe i have some stray files from previous builds?)? What is the mechanism of determining the installed library version?

  • #2
    Code:
    cat /usr/lib{,32,64}/pkgconfig/libdrm.pc | grep Version:
    this should list two times the same version and it should be larger than 2.4.51. If this is not the case then you are either missing a separate development package for libdrm or you didn't install it correctly when building it on your own.

    Comment


    • #3
      Originally posted by droste View Post
      Code:
      cat /usr/lib{,32,64}/pkgconfig/libdrm.pc | grep Version:
      this should list two times the same version and it should be larger than 2.4.51. If this is not the case then you are either missing a separate development package for libdrm or you didn't install it correctly when building it on your own.
      Ok thanks. Turns out i had /usr/local/lib/pkgconfig/libdrm.pc which had the old version, surely from an older compilation - since then i moved to use the /usr/lib/x86_64-linux-gnu/ directory so that file remained in local and that is the first place to look for pkgconfig.

      Comment

      Working...
      X