Announcement

Collapse
No announcement yet.

Radeon 8000M problematic on Linux?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon 8000M problematic on Linux?

    Hi all,

    I recently bought a budget Asus laptop (X550D model) with a quad-core Richland A8-5550 APU storing an integrated 8550G and a discrete 8670m.

    The device came OS free so I installed and used Windows 8 x64 on it for about 3 months without problems.

    Today I wanted to give Linux a try on it but it totaly failed no matter the distro.

    It completely hangs and freezes during boot and no graphical interface is started. It doesn't even allow me to access the other ttys. I tried the following distros, one by one with the same result: Fedora 20, OpeSUSE 13.1, Ubuntu 13.10, Antergos (Arch) Latest.

    The farthest I got was with Antergos iso. I managed to boot with nomedeset on and install the distro but after reboot the same thing happened. When appending nomodeset to it again (Linux 3.13 kernel) I get *ERROR*No UMS support in radeon module but this time I can acces the other ttys and do a reboot.

    The other distros couldn't be started successfully even with nomodeset on.

    Any ideas?

    Thank you!

  • #2
    Well, the first thing to do would be to try an up to date kernel.

    On archlinux:
    Code:
    pacman -U http://arch.miffe.org/x86_64/linux-mainline-3.14rc7-1-x86_64.pkg.tar.xz
    and grub-mkconfig -o /boot/grub/grub.cfg or so I think, it's a while since I did that the last time.

    The second, to report a kernel bug at bugzilla.kernel.org (after searching if there already is one)
    Last edited by ChrisXY; 03-21-2014, 11:19 AM.

    Comment


    • #3
      Try Ubuntu 14.04. It will be released in april, so it makes no sense to install saucy now, even less if you have new hardware:
      http://cdimage.ubuntu.com/daily-live/current/
      If that doesn't help, try installing the newest kernel you can find here: http://kernel.ubuntu.com/~kernel-ppa/mainline/ (right now it is: http://kernel.ubuntu.com/~kernel-ppa...14-rc7-trusty/ )

      Comment


      • #4
        Hi all,

        Thank you for your suggestions.

        Unfortunately the problem is distro agnostic (It doesn't work with 14.04 either).
        Tried 3.14 rc7 kernel with the same result. I still can't boot without setting nomodeset at boot.

        Ubuntu displays running in low graphics mode error message and just hangs there while in Arch everything stops after Reached Target Graphical Interface

        Do you guys have any tips for me for better bug reporting? Like what should I include to help devs better figure out my problem?

        Thanks.

        Comment


        • #5
          Boot into tty on Arch and try to disable your discrete card with the following command:
          echo OFF > /sys/kernel/debug/vgaswitcheroo/switch and see if it works.
          Also make sure you have installed xf86-video-ati and mesa related packages.

          Comment


          • #6
            Boot into tty on Arch and try to disable your discrete card with the following command:
            echo OFF > /sys/kernel/debug/vgaswitcheroo/switch and see if it works.
            Also make sure you've installed xf86-video-ati and mesa related packages.

            Comment


            • #7
              Originally posted by Adriannho View Post
              Tried 3.14 rc7 kernel with the same result. I still can't boot without setting nomodeset at boot.
              First, I believe with nomodeset you will not get any acceleration at all since everything that is not KMS has been unsupported for quite some time now.

              I have seen runpm being buggy and creating hangs, so just maybe it actually gets better when disabling it?

              So
              Code:
              radeon.runpm=0
              or if that doesn't help, you can try if it is dpm:
              Code:
              radeon.dpm=0
              (or better both?)

              If it still doesn't work then it is at least established that not the relatively new power management stuff is the cause. If it does work, then knowing it is the cause would be good news too.

              Originally posted by Adriannho View Post
              Ubuntu displays running in low graphics mode error message and just hangs there while in Arch everything stops after Reached Target Graphical Interface
              Can you get hold of a second computer? If so, getting error messages through ssh should be easy, (but only if the problem is just the graphical output. If it hard locks the whole machine, this will not help). For archlinux and other systemd based distributions
              Code:
              systemd.unit=rescue.target
              in the bootloader should boot without a graphical user interface and should let you log in in a shell. Possibly just appending "3" for "runlevel 3" works for others and possibly systemd still supports that? I have no idea...

              Originally posted by Adriannho View Post
              Do you guys have any tips for me for better bug reporting? Like what should I include to help devs better figure out my problem?
              lspci for the hardware
              dmesg > logfile, but that requires being able to log in, best through ssh or so.
              If it hard lock ups right at booting, and if you have a second computer you might want to try if you get netconsole to work: https://wiki.archlinux.org/index.php...arting_at_Boot to get a log to submit.

              Comment


              • #8
                Maybe an issue with the combined GPU's is causing this?

                The first thing I would try would be going into BIOS/UEFI and disabling any kind of hybrid graphics so that either only the on-chip or only the discrete GPU is supported. If this can't be done or does not work, I would then try removing the discrete GPU entirely and just using the APU's graphics, which are supposed to be pretty good. Hang onto the discrete GPU in that case as support may emerge later.

                How did Windows use the two GPU's: in a hybrid mode (discrete only on high loads) or in hybrid crossfire? I know Radeon does not support the latter, don't know if it supports the former.

                Another option is this: remove the hard drive, put it in any machine with Evergreen (HD5000 series) or later AMD graphics, then install your OS and the catalyst proprietary driver. Put the disk back in the laptop with both GPUs enabled and see if it works.

                Comment


                • #9
                  I have a HP laptop with A10-5750M + 8750M and I was able to install and use OpenSUSE 13.1 succesfully. It was the KDE Live edition if that makes any difference. After install, I also finally installed fglrx and things are working fine on that laptop and OpenGL and OpenCL both work. OpenCL apps can see both GPUs, and for OpenGL you can only use one GPU at a time and there is a setting in Catalyst Control Center to choose which GPU to use which is nice. I am overall satisfied and definitely your hardware should also work but may require some effort.

                  I do remember having some trouble and finally after some trial-and-error I discovered one set of flags that worked. The machine is with someone else right now. When I will go over, I will check and let you know the flags that I finally set on the kernel there. In the meantime, keep your hopes up.

                  Comment


                  • #10
                    Stupid bug! Things get weirder and weirder.

                    First, I want to thank you all for suggestions thus far.

                    After reinstalling Ubuntu it booted and went fine for the first two times and for a second there I believed everything was ok. After halting my laptop and then restarting, it went hanging on me again. After several reboots it still hangs

                    Originally posted by ChrisXY
                    I have seen runpm being buggy and creating hangs, so just maybe it actually gets better when disabling it?
                    Actually this was the first thing that crossed my mid. Unfortunately both options produced the same results.
                    I'm quite sure PM is ok for me. When I did managed to boot into Ubuntu the driver seemed to properly clock the GPU and fans as it was quiet and cool as it is in windows. I even managed to manually change power profile to batttery.

                    Originally posted by Karol
                    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch and see if it works
                    Tried it;it says something like no such file or directory

                    Originally posted by Luke
                    The first thing I would try would be going into BIOS/UEFI and disabling any kind of hybrid graphics so that either only the on-chip or only the discrete GPU is supported. If this can't be done or does not work, I would then try removing the discrete GPU entirely and just using the APU's graphics, which are supposed to be pretty good. Hang onto the discrete GPU in that case as support may emerge later.
                    The machine I'm using comes with a VERYminimalist BIOS. Such options as GPU selection or disablement are not present. And my machine is still under warranty and I'm not supposed to open it, otherwise I fear I might lose the warranty.

                    Originally posted by Luke
                    How did Windows use the two GPU's: in a hybrid mode (discrete only on high loads) or in hybrid crossfire? I know Radeon does not support the latter, don't know if it supports the former.
                    It's hybrid mode (NO crossfire)

                    Originally posted by ChrisXY
                    If it hard lock ups right at booting
                    Apparently it's not hard lock (at least in Ubuntu). In Arch I couldn't reach the terminal but this might be due to some special config the Antergos devs have made. In Ubuntu the other TTYs are available and I CAN log in. Booting into text mode with
                    Code:
                    text
                    added to GRUB also works really well.

                    Tried
                    Code:
                    startx
                    command from the terminal just to see what happens and that freezes everything, even the other virtual terminals.

                    Will lspci and dmesg help out if I execute them from the other TTYs without resorting to ssh?

                    Comment


                    • #11
                      "Will lspci and dmesg help out if I execute them from the other TTYs without resorting to ssh? "

                      Yes, they could.
                      Old X server logs would be probably more helpful, though. They are usually saved even when X.org crashes.
                      Old kernel logs (when Xorg crashes) could probably also be found on the HDD.

                      Comment


                      • #12
                        So, here is the result of lspci and dmesg commands plus the Xorg log file.

                        lspci: https://drive.google.com/file/d/0B8s...it?usp=sharing

                        dmesg: https://drive.google.com/file/d/0B8s...it?usp=sharing

                        Xorg log file: https://drive.google.com/file/d/0B8s...it?usp=sharing
                        thanks!

                        Comment


                        • #13
                          *UPDATE*

                          Definitely a RadeonSI bug.

                          Tried the fglrx driver available in the software center and it work like a charm.

                          I could mark the topic solved, but I would have liked it to be able to use RadeonSI (

                          Ah, maybe one day....

                          Comment


                          • #14
                            Did you read this thread? http://www.phoronix.com/forums/showt...t-what-they-do , read it and test the commands provided there.

                            Originally posted by Adriannho View Post
                            So, here is the result of lspci and dmesg commands plus the Xorg log file.

                            lspci: https://drive.google.com/file/d/0B8s...it?usp=sharing

                            dmesg: https://drive.google.com/file/d/0B8s...it?usp=sharing

                            Xorg log file: https://drive.google.com/file/d/0B8s...it?usp=sharing
                            thanks!
                            I couldn't read a thing... can you send the logs to pastebin.com ?

                            Comment


                            • #15
                              It's an issue with runtime pm. Append radeon.runpm=0 to the kernel command line in grub to work around it. You can follow the progress of debugging it here:
                              https://bugs.freedesktop.org/show_bug.cgi?id=75127

                              Comment

                              Working...
                              X