Announcement

Collapse
No announcement yet.

Radeon 8000M problematic on Linux?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    You should have installed Ubuntu 14.04 development instead -- that's the first thing I did when I got a new Kabini APU laptop (A4-5000) in December. Worked perfectly out of the box with open source drivers ever since. The only thing really holding it back is the horrible performance of GLAMOR, which is still a lot faster than Catalyst's even worse 2D rendering.

    Comment


    • #17
      Originally posted by mmstick View Post
      You should have installed Ubuntu 14.04 development instead
      I have (K)ubuntu 14.04 (development, and now final) installed. The testing was mostly done on it.

      Originally posted by AGD5F
      agd5f
      It's an issue with runtime pm. Append radeon.runpm=0 to the kernel command line in grub to work around it. You can follow the progress of debugging it here:
      https://bugs.freedesktop.org/show_bug.cgi?id=75127
      I tried disabling both runpm and dpm many times, but it simply didn't work. Also, the problems described in the linked bug post differ from the one I'm experiencing.

      Well, after a lot of testing I think I narrowed down the problem to a kernel regression.

      This explains the strange behaviour I experienced after installing arch and ubuntu. It worked for the first 2-3 times, and after that, it would no longer boot.

      It seems that when upgrading kernel (in Ubuntu) from 13.0.19 to 13.0.24, my machine becomes unbootable with radeon (fglrx can boot perfectly fine with 13.0.24 though).
      When selecting the old kernel in Grub I can boot with no problem again.

      (I have to add that booting kernel 3.12 also leads to a failure).

      Does anyone have any idea about something that went between the afore mentioned kernel releases that could cause my system to become unbootable?
      Also, I would need advice on how to proceed next and better isolate the problem (pet commit).

      Thanks!

      Comment


      • #18
        Originally posted by Adriannho View Post
        Does anyone have any idea about something that went between the afore mentioned kernel releases that could cause my system to become unbootable?
        Also, I would need advice on how to proceed next and better isolate the problem (pet commit).
        Please use git to bisect the problem and file a bug (https://bugs.freedesktop/org).

        Comment


        • #19
          Originally posted by agd5f View Post
          Please use git to bisect the problem and file a bug (https://bugs.freedesktop/org).
          Well, I did that, and after all, it seems you were right Alex, it was runpm's fault.

          But the bug is very different to the one you pointed in the link.
          Also, for me, setting
          Code:
          radeon.runpm=0
          didn't work.

          Bug report https://bugs.freedesktop.org/show_bug.cgi?id=77930

          Similar situation: http://forums.gentoo.org/viewtopic-p-7529160.html

          Comment

          Working...
          X