Announcement

Collapse
No announcement yet.

Radeon HD 2400 Pro Terrible? Or just something I'm missing?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon HD 2400 Pro Terrible? Or just something I'm missing?

    I recently got a Radeon HD 2400 Pro, and tried it on the latest daily of Ubuntu 14.04 (as of maybe two days ago). The game I tried on it (StepMania) ran pretty badly seemingly (not going above 60; randomly staying at 30 FPS at times).

    This happened on both Ubuntu with Unity, and Xubuntu with and without desktop compositing. I've even tried running StepMania with vblank_mode=0 to no avail, and vsync was disabled in-game. I've tried it with the included 3.13 kernel, and latest daily kernel too, and with radeon.dpm=1 (although if I checked the logs correctly, it would seem all the clock states are the same, making dpm useless?).

    Under Windows, StepMania gets about 100 FPS with both the OpenGL and Direct3D renderer. I believe glxgears had a framerate of around 1500 (if that means anything).

    I'd rather have Linux on the computer, but I need StepMania to have the best performance possible. Is there anything I could do or maybe overlooked to have better performance with StepMania?

  • #2
    You could add
    Code:
    SwapBuffersWait "false"
    to your xorg.conf in the device section.

    Comment


    • #3
      You also need to disable swapbufferswait in xorg.conf in order to enable tearing (or going over display rate in fullscreen apps).

      That said, it's an extremely low-end card, a $10 6450 would beat it silly.

      Comment


      • #4
        Originally posted by curaga View Post
        You also need to disable swapbufferswait in xorg.conf in order to enable tearing (or going over display rate in fullscreen apps).
        I did this (Xorg's log also says it's disabled; also disabled Pageflipping and EAXVsync), but StepMania still refuses to go over 60 FPS. Vsync still disabled in-game. glxgears on desktop doesn't go past 60 FPS on it's own either, yet dragging a window on the desktop shows tearing (with and without compositing on Xubuntu).

        Comment


        • #5
          Originally posted by Espionage724 View Post
          I did this (Xorg's log also says it's disabled; also disabled Pageflipping and EAXVsync), but StepMania still refuses to go over 60 FPS. Vsync still disabled in-game. glxgears on desktop doesn't go past 60 FPS on it's own either, yet dragging a window on the desktop shows tearing (with and without compositing on Xubuntu).
          Set env var vblank_mode=0 and try running the game.

          Comment


          • #6
            I was attaching vblank_mode=0 to it as well but it still didn't work.

            Due to some permissions thing, I was running StepMania as root, so I ran it like vblank_mode=0 sudo '/opt/sm-ssc/stepmania'; not too sure if the env variable gets ignored when using sudo or what. After taking ownership of the folder however and using that env var, StepMania's framerate was fine (above 60)

            Comment


            • #7
              sudo clears the env.

              Comment


              • #8
                sudo:

                -E, --preserve-env preserve user environment when running command

                Comment


                • #9
                  Why do You have to run the game as root?

                  Comment


                  • #10
                    Originally posted by Mat2 View Post
                    Why do You have to run the game as root?
                    I compiled StepMania from source and did a sudo make install, which made the folder owned by root.

                    Strangely though, I don't recall needing to run as root even with the sudo make install on Ubuntu, but needed it on Xubuntu. I think it was also fine without root on Kubuntu, but only after changing some GTK theme setting (not entirely sure though).

                    Comment

                    Working...
                    X