Announcement

Collapse
No announcement yet.

So I built myself a new rig...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • So I built myself a new rig...

    ...and Linux only boots off a live USB stick when using AMD's nonfree driver in UEFI mode. Linux won't boot when using free or nonfree drivers in Legacy mode or the free driver in UEFI mode. All I get is a blinking underscore during those instances.

    I consequently installed Linux by booting the live USB stick using AMD's nonfree driver in UEFI mode and then switched to AMD's free driver after upgrading to kernel 3.13 and uninstalled the nonfree driver. Now I get a blinking underscore when booting as well.

    My hardware:
    • Intel i5 4670K
    • AMD R9 290X
    • Gigabyte GA-Z87X-UD5H
    What can I do to fix this? It took long enough just to figure out how to boot Linux on this newly built rig of mine. I used SUSE Studio Image Writer to create the live USB stick and have tried Manjaro, openSUSE, and GParted Live.

  • #2
    Can you show me
    Code:
    lspci -vnn
    To verify if it should work with 64 bit special from
    http://nightly.kanotix.acritox.com/latest/
    In gfxdetect mode.

    Comment


    • #3
      A silent hang during boot, before initializing the proper gfx drivers? I had that once, turned out a piece of firmware was missing (the new kernel required the UVD files, which I hadn't had installed before). I don't get why there's no error message, but that seems to be the way it is.


      My R9 290 (without the X) requires:
      radeon/PITCAIRN_ce.bin radeon/PITCAIRN_mc.bin radeon/PITCAIRN_me.bin radeon/PITCAIRN_pfp.bin radeon/PITCAIRN_rlc.bin radeon/PITCAIRN_smc.bin radeon/TAHITI_uvd.bin

      in /lib/firmware, initrd and/or built into the kernel, depending on your configuration. AFAIK the R9 290X needs the same files.

      Comment


      • #4
        Originally posted by Kano View Post
        Can you show me
        Code:
        lspci -vnn
        To verify if it should work with 64 bit special from
        http://nightly.kanotix.acritox.com/latest/
        In gfxdetect mode.
        Not quite sure what you're asking for but I'll do it. I booted the live USB stick with nonfree drivers in UEFI mode (as I cannot access my installation currently). Here you go.

        Originally posted by rohcQaH View Post
        A silent hang during boot, before initializing the proper gfx drivers? I had that once, turned out a piece of firmware was missing (the new kernel required the UVD files, which I hadn't had installed before). I don't get why there's no error message, but that seems to be the way it is.


        My R9 290 (without the X) requires:
        radeon/PITCAIRN_ce.bin
        radeon/PITCAIRN_mc.bin
        radeon/PITCAIRN_me.bin
        radeon/PITCAIRN_pfp.bin
        radeon/PITCAIRN_rlc.bin
        radeon/PITCAIRN_smc.bin
        radeon/TAHITI_uvd.bin

        in /lib/firmware, initrd and/or built into the kernel, depending on your configuration. AFAIK the R9 290X needs the same files.
        My installation has those files in the location you specified.

        Comment


        • #5
          It's simple why i wanted the full output. You see this:

          00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])

          and

          01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii XT [Radeon HD 8970] [1002:67b0] (prog-if 00 [VGA controller])

          Which would be like an Optimus setup. Don't enable Intel GPU in your firmware when you don't know what you do. I guess Gigabyte has it as default as somebody with Nvidia GPU had the Intel GPU active as well with a Z87 board...

          Comment


          • #6
            Originally posted by Kano View Post
            It's simple why i wanted the full output. You see this:

            00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])

            and

            01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii XT [Radeon HD 8970] [1002:67b0] (prog-if 00 [VGA controller])

            Which would be like an Optimus setup. Don't enable Intel GPU in your firmware when you don't know what you do. I guess Gigabyte has it as default as somebody with Nvidia GPU had the Intel GPU active as well with a Z87 board...
            Ahhh, I see what you mean now. I don't see how that happened, though. On my old desktop (built it myself too), I had an Intel CPU and a Nvidia GPU and never had that issue with booting live USB sticks. Is there a way to disable the Intel GPU in the UEFI? I haven't been able to find a way yet.

            Comment


            • #7
              As you did not find it, I even downloaded the manual of your board. Guess what, you can find the setting in the Peripherals section:

              Internal Graphics - Disable (or Auto if available)

              Hard to believe that you did not see that...

              Comment


              • #8
                Originally posted by Kano View Post
                Which would be like an Optimus setup. Don't enable Intel GPU in your firmware when you don't know what you do. I guess Gigabyte has it as default as somebody with Nvidia GPU had the Intel GPU active as well with a Z87 board...
                Just having an integrated and discrete card does not make it a hybrid GPU setup...

                A discrete PCI-e card should automatically disable the integrated graphics on most motherboards.

                Comment


                • #9
                  As i do not own Optimus i tested radeon+Intel, radeon+nouveau successfully, but i could not fake real Optimus with binary nvidia driver. 2 or more cards from the same vendor did not work as well. For nouveau i needed an override to init it with Intel first and kernel 3.13. Vdpau can be switched with PRIME, vaapi needed a patch. I got am hotfix for vaapi but it crashes inside the app still when you use a non supported card with it. Nouveau does not work on a system without CSM, can not test this with radeon as i only have got old Evergreen cards. But binary drivers do not really work well on Desktops when Intel onboard is active, even when no monitor is connected.

                  Comment


                  • #10
                    I had a very similar issue when I attempted to test a discrete GPU with Linux in my APU build. IIRC, the bios had some dual-GPU mode set by default and I had to switch it to auto for Linux to boot properly.
                    I hate it when something is caused by an incorrect BIOS configuration :/ IIRC, the option was hidden and at the very end of all the configuration options on my ASRock board, too

                    Comment

                    Working...
                    X