Announcement

Collapse
No announcement yet.

Fast Color Clears Come To AMD's RadeonSI Gallium3D Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Even with llvm 3.4 it should still advertise OpenGL 3.1, if you're stuck at 2.1 it's most likely because of missing floating point textures. Are you passing --enable-texture-float to configure when building mesa?

    Comment


    • #22
      Weird... I tried to install LLVM 3.5, but it is not taken into account by mesa. I suppose it has to be configured at build time. By the way, I do not compile the packages myself, so if texture float is not enable in Debian packages it will be a problem... I'be just bought Europa Universalis, and I hoped to play under Linux. But for now, the display is so laggy I can't event try.



      Here is the output of glxinfo | grep OpenGL :
      OpenGL vendor string: VMware, Inc.
      OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
      OpenGL version string: 2.1 Mesa 10.1.0-rc2
      OpenGL shading language version string: 1.30
      OpenGL extensions:

      Comment


      • #23
        Originally posted by jery View Post
        Weird... I tried to install LLVM 3.5, but it is not taken into account by mesa. I suppose it has to be configured at build time. By the way, I do not compile the packages myself, so if texture float is not enable in Debian packages it will be a problem... I'be just bought Europa Universalis, and I hoped to play under Linux. But for now, the display is so laggy I can't event try.



        Here is the output of glxinfo | grep OpenGL :
        OpenGL vendor string: VMware, Inc.
        OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
        OpenGL version string: 2.1 Mesa 10.1.0-rc2
        OpenGL shading language version string: 1.30
        OpenGL extensions:
        That's definitely very wrong. You are getting software rendering, because the radeon driver isn't even loading.

        Comment


        • #24
          That's true ! I did not even notice it was written renderer = llvmpipe... I need to check my logs to find why

          Comment


          • #25
            BTW, you should rebuild Mesa after installing LLVM. Otherwise, bad things may happen.

            Comment


            • #26
              The non-init of the driver was coming from the non presence of glamor in current Debian Jessie...

              I added Kanotix repository and now everything works ! well, at least opengl 3.1.

              Thx a lot

              Comment

              Working...
              X