Announcement

Collapse
No announcement yet.

Fast Color Clears Come To AMD's RadeonSI Gallium3D Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The RadeonSI driver is in a good shape and the performance should be close to r600g. I only tested Team Fortress 2 and it was smooth. However, these components should be fresh and built in this order, or obtained from other sources:

    - kernel
    - llvm
    - libdrm
    - mesa (make sure the llvm version reported by the configure script matches what you compiled)
    - glamor
    - xf86-video-ati
    - enable 2D tiling manually in xorg.conf
    - enable dynamic power management if it's not enabled by default
    - you can also set R600_DEBUG=hyperz to get a small performance boost
    Last edited by marek; 03-07-2014, 07:16 PM.

    Comment


    • #17
      Originally posted by Kemosabe View Post
      Quite misleading statement since the article is about RadeonSI which is ~100% not recommendable for daily use.
      not true for opensuse tumbleweed or even opensuse 13.1 at least for HD 7950
      Last edited by tomtomme; 03-07-2014, 08:24 PM.

      Comment


      • #18
        Originally posted by r1348 View Post
        As the article stated: AMD Radeon HD7000 and newer.
        Some of them only: to be exact, only GCN cards use RadeonSI. Older rebranded cards won't use RadeonSI.

        Comment


        • #19
          OpenGL 3.X not available ?

          hi all,

          I'm running Debian Jessie/Sid on a 7850 with the latest available packages, but OpenGL support is still being reported at 2.1 (kernel 3.13, mesa 10.1-rc2, llvm 3.4).
          Do I need to switch on something ?

          Switching to another distro is not an option

          Thanks

          Comment


          • #20
            Originally posted by jery View Post
            hi all,

            I'm running Debian Jessie/Sid on a 7850 with the latest available packages, but OpenGL support is still being reported at 2.1 (kernel 3.13, mesa 10.1-rc2, llvm 3.4).
            Do I need to switch on something ?

            Switching to another distro is not an option

            Thanks
            It seems I've found the answer myself ! I need to upgrade for llvm 3.5 !
            http://www.phoronix.com/forums/showt...ovements/page4

            Comment


            • #21
              Even with llvm 3.4 it should still advertise OpenGL 3.1, if you're stuck at 2.1 it's most likely because of missing floating point textures. Are you passing --enable-texture-float to configure when building mesa?

              Comment


              • #22
                Weird... I tried to install LLVM 3.5, but it is not taken into account by mesa. I suppose it has to be configured at build time. By the way, I do not compile the packages myself, so if texture float is not enable in Debian packages it will be a problem... I'be just bought Europa Universalis, and I hoped to play under Linux. But for now, the display is so laggy I can't event try.



                Here is the output of glxinfo | grep OpenGL :
                OpenGL vendor string: VMware, Inc.
                OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
                OpenGL version string: 2.1 Mesa 10.1.0-rc2
                OpenGL shading language version string: 1.30
                OpenGL extensions:

                Comment


                • #23
                  Originally posted by jery View Post
                  Weird... I tried to install LLVM 3.5, but it is not taken into account by mesa. I suppose it has to be configured at build time. By the way, I do not compile the packages myself, so if texture float is not enable in Debian packages it will be a problem... I'be just bought Europa Universalis, and I hoped to play under Linux. But for now, the display is so laggy I can't event try.



                  Here is the output of glxinfo | grep OpenGL :
                  OpenGL vendor string: VMware, Inc.
                  OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
                  OpenGL version string: 2.1 Mesa 10.1.0-rc2
                  OpenGL shading language version string: 1.30
                  OpenGL extensions:
                  That's definitely very wrong. You are getting software rendering, because the radeon driver isn't even loading.

                  Comment


                  • #24
                    That's true ! I did not even notice it was written renderer = llvmpipe... I need to check my logs to find why

                    Comment


                    • #25
                      BTW, you should rebuild Mesa after installing LLVM. Otherwise, bad things may happen.

                      Comment


                      • #26
                        The non-init of the driver was coming from the non presence of glamor in current Debian Jessie...

                        I added Kanotix repository and now everything works ! well, at least opengl 3.1.

                        Thx a lot

                        Comment

                        Working...
                        X