No announcement yet.

[VDPAU] Can only get MPEG1/2 decoding to work

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by chii View Post
    OpenGL renderer string: Gallium 0.4 on AMD RV770
    The is no UVD support on RV770 at this time.


    • #12
      Originally posted by chithanh View Post
      The is no UVD support on RV770 at this time.
      ah ok thx, that explains everything


      • #13

        Originally posted by tiredoffglrx View Post
        $ mplayer test.mp4
        Starting playback...
        [VD_FFMPEG] Trying pixfmt=0.
        Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
        VO: [vdpau] 1280x720 => 1280x720 H.264 VDPAU acceleration 
        [VD_FFMPEG] XVMC-accelerated MPEG-2.
        A:  18.1 V:  18.1 A-V:  0.000 ct: -0.001   0/  0  3%  1%  1.4% 3 0
        I find this a bit confusing: H264/MPEG2, VDPAU/XVMC - which is it then?
        I think it's using VDPAU... But I'm not sure, don't know too much about mplayer's outputs, that is confusing...

        Originally posted by tiredoffglrx View Post
        mpv's output (thanks for the suggestion!) seems to be far more sane in that regard:

        $ mpv test.mp4
        Playing: test.mp4
        Detected file format: QuickTime / MOV (libavformat)
        Clip info:
         major_brand: mp42
         minor_version: 0
         compatible_brands: mp42mp41isomavc1
         creation_time: 2013-06-20 11:01:31
        [stream] Video (+) --vid=1 (*) (h264)
        [stream] Audio (+) --aid=1 --alang=und (*) (aac)
        Trying to use hardware decoding.
        Selected video codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 [lavc:h264]
        Selected audio codec: AAC (Advanced Audio Coding) [lavc:aac]
        AO: [pulse] 48000Hz stereo 2ch floatle
        VO: [vdpau] 1280x720 => 1280x720 vdpau 
        [vo/vdpau] Compositing window manager detected. Assuming timing info is inaccurate.

        Anyway, thanks for all the help. With this and hardware accelerated flash working at last I couldn't be happier.

        Thanks again for everything!
        Yes, mpv's outputs are nice and clean, and to use hardware video decoding with vdpau on mpv all you need is --vo=vdpau and --hwdec=vdpau