Announcement

Collapse
No announcement yet.

GLAMOR'ized Radeon Driver Shows Hope Over EXA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by pa2708 View Post
    Thanks for the hints Grad! The packages and build order were ok. The placement of options between xorg.conf and glamor.conf, though, seems to be really touchy. After a few iterations with that (ending up with everything in xorg.conf, and an empty glamor.conf since I believe one has to be present), glamor now initializes, but there's a segfault in r600_dri.so before the display comes up. Should be able to track that down from the stack dump. One step closer!
    I had a crashing issue too. In my case i found it was caused by the presence of the /usr/lib/x86_64-linux-gnu/egl/egl_gallium.so library, put there by a system package installed by default (it showed up in the xorg log's segfault message). It seems it had some disagreements with my build of mesa as i didnt build mesa with --enable-egl. Removing the library or building mesa with --enable-egl fixed this issue.

    Comment


    • #42
      The stack dump showed that the crash was happening in sb, the optional shader optimizer. Started X with R600_DEBUG=nosb and everything came up!

      The X display came up slowly (a couple minutes), and individual windows take some time (10-20 seconds?) to start, but within a given window performance was quite reasonable. Text scrolling in xterm with an antialiased font is the fastest I've ever seen, 3.4 seconds for ls -lR in a directory tree with 27K files/directories.

      Moving windows around is glass-smooth, except that motion is frozen for around half a second anytime the moved window overlaps another window or the edge of the screen. No visual corruption of any kind.

      Overall, it's not ready to be enabled permanently (on my rig), but it shows lots of promise. Best of all, it seems to be under active development again. Will give it another shot in a few months or if a major upgrade is made.

      Comment


      • #43
        On the 7560D there isnt much of a speed or visual difference vs exa (it ISNT FASTER though). Or anything for that matter, except the minor bugs i mentioned with transparent tray icons etc. Moving windows, scrolling, opening windows seems to be pretty much the same on xfce 4.10. Also, it seems that is uses less CPU% for mundane tasks like painting ordinary windows, scrolling in Seamonkey etc (this is a highly subjective observation though).

        Comment


        • #44
          Originally posted by pa2708 View Post
          The stack dump showed that the crash was happening in sb,
          If its the same one, then it looks like it got squished: https://bugs.freedesktop.org/show_bug.cgi?id=70088

          Comment


          • #45
            Originally posted by oibaf View Post
            There are some glamor speedups and fixes in the queue, see http://lists.freedesktop.org/archive...ober/date.html
            BTW, these just get merged: http://cgit.freedesktop.org/xorg/driver/glamor/log/ .

            I also updated my PPA with them.

            Comment


            • #46
              Originally posted by oibaf View Post
              BTW, these just get merged: http://cgit.freedesktop.org/xorg/driver/glamor/log/ .

              I also updated my PPA with them.
              Thanks oibaf, I will try them.
              ## VGA ##
              AMD: X1950XTX, HD3870, HD5870
              Intel: GMA45, HD3000 (Core i5 2500K)

              Comment

              Working...
              X