Announcement

Collapse
No announcement yet.

Radeon Driver Now Supports X-Video GLAMOR

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon Driver Now Supports X-Video GLAMOR

    Phoronix: Radeon Driver Now Supports X-Video GLAMOR

    Earlier this week I wrote about X-Video support coming to GLAMOR and now it's been implemented by the xf86-video-ati Radeon driver...

    http://www.phoronix.com/vr.php?view=MTQ3MjU

  • #2
    Ok, there is a commit that says something about initial xv support, but how can actually be used?
    I compiled everything from the latest git (mesa, glamor, xf86-ati) and xv isnt working at all on my system.

    Code:
    ~$ xvinfo 
    X-Video Extension version 2.2
    screen #0
     no adaptors present
    I have an A8-5500 APU (7560D IGP). vdpau works fine.
    Last edited by gradinaruvasile; 09-29-2013, 06:24 AM.

    Comment


    • #3
      Originally posted by gradinaruvasile View Post
      Ok, there is a commit that says something about initial xv support, but how can actually be used?
      I compiled everything from the latest git (mesa, glamor, xf86-ati) and xv isnt working at all on my system.

      Code:
      ~$ xvinfo 
      X-Video Extension version 2.2
      screen #0
       no adaptors present
      I have an A8-5500 APU (7560D IGP). vdpau works fine.
      HD 6770 mesa, glamor, xf86-ati -git

      Code:
      xvinfo 
      X-Video Extension version 2.2
      screen #0
        Adaptor #0: "GLAMOR Textured Video"
          number of ports: 16
          port base: 123
          operations supported: PutImage 
          supported visuals:
            depth 24, visualID 0x5d
          number of attributes: 5
            "XV_BRIGHTNESS" (range -1000 to 1000)
                    client settable attribute
                    client gettable attribute (current value is 0)
            "XV_CONTRAST" (range -1000 to 1000)
                    client settable attribute
                    client gettable attribute (current value is 0)
            "XV_SATURATION" (range -1000 to 1000)
                    client settable attribute
                    client gettable attribute (current value is 0)
            "XV_HUE" (range -1000 to 1000)
                    client settable attribute
                    client gettable attribute (current value is 0)
            "XV_COLORSPACE" (range 0 to 1)
                    client settable attribute
                    client gettable attribute (current value is 0)
          maximum XvImage size: 8192 x 8192
          Number of image formats: 2
            id: 0x32315659 (YV12)
              guid: 59563132-0000-0010-8000-00aa00389b71
              bits per pixel: 12
              number of planes: 3
              type: YUV (planar)
            id: 0x30323449 (I420)
              guid: 49343230-0000-0010-8000-00aa00389b71
              bits per pixel: 12
              number of planes: 3
              type: YUV (planar)

      Comment


      • #4
        Originally posted by gradinaruvasile View Post
        Ok, there is a commit that says something about initial xv support, but how can actually be used?
        I compiled everything from the latest git (mesa, glamor, xf86-ati) and xv isnt working at all on my system.

        Code:
        ~$ xvinfo 
        X-Video Extension version 2.2
        screen #0
         no adaptors present
        I have an A8-5500 APU (7560D IGP). vdpau works fine.
        You need to enable Xv in glamor. Configure glamor with --enable-xv . I sent a patch to enable Xv by default in glamor, but it hasn't been applied yet:
        http://lists.freedesktop.org/archive...er/000396.html

        Comment


        • #5
          Thanks for the reply. I already figured it out (forget to post here, i posted it in the other thread i started, in the xorg drivers section).

          Xv works now.

          OTOH encountered a compilation issue, i only could compile it if i used the --disable-selective-werror configure switch (there were all kind of warnings related to xv) - compiling without xv worked without issues.

          Comment


          • #6
            Originally posted by agd5f View Post
            You need to enable Xv in glamor. Configure glamor with --enable-xv . I sent a patch to enable Xv by default in glamor, but it hasn't been applied yet:
            http://lists.freedesktop.org/archive...er/000396.html
            picked up today:
            http://cgit.freedesktop.org/xorg/dri...39a7725a16d785

            Comment

            Working...
            X