Announcement

Collapse
No announcement yet.

Kernel 3.11 + radeon.dpm=1 results in extremely slow performance

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by AnonymousCoward View Post
    yes .
    Done, and it works.

    Wow, the open source driver is awesome! Now only if the power level switch is fixed! (I am stuck on power level 2. Its a known bug for dual screen setups). Well done open source devs!

    I have also turned on GLAMOR 2D acceleration but even without that everything feels so much smoother than catalyst! Flightgear shows the textures correctly!!! (that NEVER happened with catalyst)!! There is no more lag and spikes with firefox page scrolling, or the animations with gnome 3!

    Radeon opensource driver kicks the crapalyst drivers butt day and night and makes catalyst maintainers look very immature!
    Last edited by xtachx; 09-22-2013, 05:52 PM.

    Comment


    • #12
      Originally posted by xtachx View Post
      Done, and it works.

      Wow, the open source driver is awesome! Now only if the power level switch is fixed! (I am stuck on power level 2. Its a known bug for dual screen setups). Well done open source devs!

      I have also turned on GLAMOR 2D acceleration but even without that everything feels so much smoother than catalyst! Flightgear shows the textures correctly!!! (that NEVER happened with catalyst)!! There is no more lag and spikes with firefox page scrolling, or the animations with gnome 3!

      Radeon opensource driver kicks the crapalyst drivers butt day and night and makes catalyst maintainers look very immature!
      Which desktop environment are you using on Fedora 19? I'm using KDE 4.11 along with kernel 3.11 and as soon as I'm logged in and the desktop loads, the screen shows bars and becomes unusable. Not sure if I'm doing something wrong or if it's a KDE bug.

      Also, how do you turn on GLAMOR 2D acceleration? I'm interested in getting every ounce of performance I can.

      Comment


      • #13
        Originally posted by dmaxel View Post
        Which desktop environment are you using on Fedora 19? I'm using KDE 4.11 along with kernel 3.11 and as soon as I'm logged in and the desktop loads, the screen shows bars and becomes unusable. Not sure if I'm doing something wrong or if it's a KDE bug.

        Also, how do you turn on GLAMOR 2D acceleration? I'm interested in getting every ounce of performance I can.
        Well, unfortunately I am back to catalyst because the fan speed is too loud. I will wait till that bug is fixed. The noise drives me crazy. However, once that is fixed, catalyst can be replaced with the opensource drivers. They are just as good for single screen setups.

        I am using Gnome 3.


        To turn on Glamor, add this to xorg.conf:

        Code:
         Option	"AccelMethod"           "glamor"
        However, you need to add the following section before the other one:

        Code:
        Section "Module"
        	Load "dri2"
        	Load "glamoregl" 
        EndSection

        Comment


        • #14
          DON'T use glamor on kde, it's bugged: https://bugs.freedesktop.org/show_bug.cgi?id=69341
          ## VGA ##
          AMD: X1950XTX, HD3870, HD5870
          Intel: GMA45, HD3000 (Core i5 2500K)

          Comment

          Working...
          X