Announcement

Collapse
No announcement yet.

Kernel 3.11 + radeon.dpm=1 results in extremely slow performance

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kernel 3.11 + radeon.dpm=1 results in extremely slow performance

    Hi, any help here? I tried the radeon driver once again today (I have dual screen so I still suffer from the loud fan bug and generally use catalyst). However, after I heard that the radeon driver is at par with catalyst I tried it again today. Everything seemed to be slw as molasses, the gnome 3 menu looks like a slideshow being opened, flightgear gives 1 FPS, I kid you not!! (70 FPS on catalyst) and you should have listed to the fan! It sounded like a jet engine, especially when the aircraft is about to take off!! Youtube videos look like they were made in powerpoint.

    Any ideas as to what could be going wrong? I did check with dmesg, and dpm was on. The power level was at 0, but I forced it to "high" (level 2). That didnt help as well.
    Last edited by xtachx; 09-22-2013, 05:50 AM.

  • #2
    Originally posted by xtachx View Post
    Hi, any help here? I tried the radeon driver once again today (I have dual screen so I still suffer from the loud fan bug and generally use catalyst). However, after I heard that the radeon driver is at par with catalyst I tried it again today. Everything seemed to be slw as molasses, the gnome 3 menu looks like a slideshow being opened, flightgear gives 1 FPS, I kid you not!! (70 FPS on catalyst) and you should have listed to the fan! It sounded like a jet engine, especially when the aircraft is about to take off!! Youtube videos look like they were made in powerpoint.

    Any ideas as to what could be going wrong? I did check with dmesg, and dpm was on. The power level was at 0, but I forced it to "high" (level 2). That didnt help as well.
    What version of mesa are you using? What graphics card do you have?

    Post the output of "glxinfo | grep OpenGL" it might be that it's using software rendering for some reason.

    Comment


    • #3
      1 FPS = software rendering

      Which distro are you on? In addition to the 3.11 kernel you need up-to-date Mesa and radeon Xorg driver

      Comment


      • #4
        Originally posted by Azultra View Post
        1 FPS = software rendering

        Which distro are you on? In addition to the 3.11 kernel you need up-to-date Mesa and radeon Xorg driver
        Using Fedora 19. My order of operations were:

        1. Boot kernel 3.11 in runlevel 3
        2. remove catalyst
        3. reinstall mesa
        4. change the boot params in grub2.cfg and add radeon.dpm=1
        5. reboot


        I will reboot and try again

        Comment


        • #5
          Originally posted by Azultra View Post
          1 FPS = software rendering

          Which distro are you on? In addition to the 3.11 kernel you need up-to-date Mesa and radeon Xorg driver
          You were right. I reinstalled everything from scratch again and this time, its 40 FPS. Much better!! Now only if the loud fan is fixed :-)

          So I installed mesa-libGL, x11-xorg-drv-ati, and removed catalyst. Is that all or do I have to install something else? Oh I did add the radeon.dpm=1 at grub commandline.

          Originally posted by archibald View Post
          What version of mesa are you using? What graphics card do you have?

          Post the output of "glxinfo | grep OpenGL" it might be that it's using software rendering for some reason.
          glxinfo | grep OpenGL
          OpenGL vendor string: X.Org
          OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
          OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0
          OpenGL core profile shading language version string: 1.40
          OpenGL core profile context flags: (none)
          OpenGL core profile extensions:
          OpenGL version string: 3.0 Mesa 9.2.0
          OpenGL shading language version string: 1.30
          OpenGL context flags: (none)
          OpenGL extensions:

          dmesg | grep dpm
          [ 19.932029] [drm] radeon: dpm initialized

          dmesg | grep drm

          [ 19.184251] [drm] Initialized drm 1.1.0 20060810
          [ 19.205212] [drm] radeon kernel modesetting enabled.
          [ 19.205426] [drm] initializing kernel modesetting (JUNIPER 0x1002:0x68B8 0x174B:0xE160).

          .....


          ------------------------

          Well everything works now except flash on youtube. It just draws a blank! Any ideas?
          Last edited by xtachx; 09-22-2013, 07:20 AM.

          Comment


          • #6
            Have you set

            VDPAU_DRIVER=r600
            LIBVA_DRIVER_NAME=vdpau

            as environment variable?

            Comment


            • #7
              Originally posted by ObiWan View Post
              Have you set

              VDPAU_DRIVER=r600
              LIBVA_DRIVER_NAME=vdpau

              as environment variable?
              Yes I have, I have this in my bashrc:

              export LIBVA_DRIVER_NAME=vdpau
              export VDPAU_DRIVER=r600

              Flash still fails and youtube videos do not play. Additionally, if I start VLC with this param:

              vlc --ffmpeg-hw -v

              I get this error when a video plays:

              [0x7f5ca4c45a98] avcodec decoder warning: threaded frame decoding is not compatible with ffmpeg-hw, disabled
              [0x7f5ca4c45a98] avcodec decoder warning: threaded slice decoding is not compatible with ffmpeg-hw, disabled


              Edit: I have got youtube to work. I dont know what I did. However, I am not sure if it works correctly. When i right click on the video and click "stats for nerds

              accelerated video rendering, software video decoding.

              Should the decoding AND the rendering be hardware?
              Last edited by xtachx; 09-22-2013, 03:42 PM.

              Comment


              • #8
                Originally posted by xtachx View Post
                Edit: I have got youtube to work. I dont know what I did. However, I am not sure if it works correctly. When i right click on the video and click "stats for nerds

                accelerated video rendering, software video decoding.

                Should the decoding AND the rendering be hardware?
                It should be accelerated for both rendering and decoding. But I think it only works with 'regular flash' and not with 'pepper flash' that comes with chrome/chromium.

                So if you are using 'regular flash' make sure you have this in /etc/adobe/mms.cfg

                Code:
                EnableLinuxHWVideoDecode=1
                OverrideGPUValidation=1
                This should enable vdpau support in flash.

                Comment


                • #9
                  Originally posted by AnonymousCoward View Post
                  It should be accelerated for both rendering and decoding. But I think it only works with 'regular flash' and not with 'pepper flash' that comes with chrome/chromium.

                  So if you are using 'regular flash' make sure you have this in /etc/adobe/mms.cfg

                  Code:
                  EnableLinuxHWVideoDecode=1
                  OverrideGPUValidation=1
                  This should enable vdpau support in flash.
                  I dont use chromium, I use firefox, so yes its regular flash. The folder /etc/adobe isnt there, should I make one?

                  Comment


                  • #10
                    Originally posted by xtachx View Post
                    The folder /etc/adobe isnt there, should I make one?
                    yes .

                    Comment


                    • #11
                      Originally posted by AnonymousCoward View Post
                      yes .
                      Done, and it works.

                      Wow, the open source driver is awesome! Now only if the power level switch is fixed! (I am stuck on power level 2. Its a known bug for dual screen setups). Well done open source devs!

                      I have also turned on GLAMOR 2D acceleration but even without that everything feels so much smoother than catalyst! Flightgear shows the textures correctly!!! (that NEVER happened with catalyst)!! There is no more lag and spikes with firefox page scrolling, or the animations with gnome 3!

                      Radeon opensource driver kicks the crapalyst drivers butt day and night and makes catalyst maintainers look very immature!
                      Last edited by xtachx; 09-22-2013, 05:52 PM.

                      Comment


                      • #12
                        Originally posted by xtachx View Post
                        Done, and it works.

                        Wow, the open source driver is awesome! Now only if the power level switch is fixed! (I am stuck on power level 2. Its a known bug for dual screen setups). Well done open source devs!

                        I have also turned on GLAMOR 2D acceleration but even without that everything feels so much smoother than catalyst! Flightgear shows the textures correctly!!! (that NEVER happened with catalyst)!! There is no more lag and spikes with firefox page scrolling, or the animations with gnome 3!

                        Radeon opensource driver kicks the crapalyst drivers butt day and night and makes catalyst maintainers look very immature!
                        Which desktop environment are you using on Fedora 19? I'm using KDE 4.11 along with kernel 3.11 and as soon as I'm logged in and the desktop loads, the screen shows bars and becomes unusable. Not sure if I'm doing something wrong or if it's a KDE bug.

                        Also, how do you turn on GLAMOR 2D acceleration? I'm interested in getting every ounce of performance I can.

                        Comment


                        • #13
                          Originally posted by dmaxel View Post
                          Which desktop environment are you using on Fedora 19? I'm using KDE 4.11 along with kernel 3.11 and as soon as I'm logged in and the desktop loads, the screen shows bars and becomes unusable. Not sure if I'm doing something wrong or if it's a KDE bug.

                          Also, how do you turn on GLAMOR 2D acceleration? I'm interested in getting every ounce of performance I can.
                          Well, unfortunately I am back to catalyst because the fan speed is too loud. I will wait till that bug is fixed. The noise drives me crazy. However, once that is fixed, catalyst can be replaced with the opensource drivers. They are just as good for single screen setups.

                          I am using Gnome 3.


                          To turn on Glamor, add this to xorg.conf:

                          Code:
                           Option	"AccelMethod"           "glamor"
                          However, you need to add the following section before the other one:

                          Code:
                          Section "Module"
                          	Load "dri2"
                          	Load "glamoregl" 
                          EndSection

                          Comment


                          • #14
                            DON'T use glamor on kde, it's bugged: https://bugs.freedesktop.org/show_bug.cgi?id=69341
                            ## VGA ##
                            AMD: X1950XTX, HD3870, HD5870
                            Intel: GMA45, HD3000 (Core i5 2500K)

                            Comment

                            Working...
                            X