Announcement

Collapse
No announcement yet.

AMD Publishes HDA Audio GPU Documentation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Ericg View Post
    I'm assuming "--set audio" takes on/off/auto as arguments? With defaulting to auto, i would hope. So the only thing I should have to do is plug in my HDMI cable and point a stream from Pulseaudio at the HDMI connection and I should get output on the other end of the connection?

    Side question, is xrandr persistent? I know screen settings werent really persistent, but other settings? Like if i wanted to turn HDMI audio off with

    Code:
     xrandr --output HDMI-0 --set audio off
    would that persist across reboots?
    It currently defaults to off (there are still some systems that have problems) and randr settings are not persistent (although perhaps some desktop environments store the user's randr property preferences). I'd like to eventually switch to auto by default, but for now you'll need to set it to auto youself.

    Comment


    • #17
      Amazing. LPCM 24-bit 7.1 channel audio on my Linux box is very close!!!

      Comment


      • #18
        I am also not affected by HDMI audio since I use classic methods and dedicated audio interfaces. Nevertheless: Good to read these news. A lot of people DO use HDMI adio. Things like this make life just better.
        I recently threw money for Mom's new PC at AMD, and I'll continue to throw (as soon as I happen to have some). My eyes are on a E-1800 system for HTPC purposes...

        Comment


        • #19
          Now only if NVIDIA will follow suit with code for their HDMI audio implementations as used on their cards, but not holding my breath...

          Comment


          • #20
            Originally posted by agd5f View Post
            Support for SI/TN and newer hardware was added in 3.12. Additionally, with 3.12 you no longer need to boot with radeon.audio=1. You can enable/disable audio on the fly with xrandr. E.g., xrandr --output HDMI-0 --set audio auto
            That didn't work. Setting radeon.audio=1 helped, though.
            Trinity, 5800K.

            Thanks, this was the last big missing feature for me!
            Here's hoping that xbmc will work with vdpau -- but ubuntu doesn't even build the gallium state tracker in xorg-edgers yet.

            Comment


            • #21
              Originally posted by agd5f View Post
              Support for SI/TN and newer hardware was added in 3.12. Additionally, with 3.12 you no longer need to boot with radeon.audio=1. You can enable/disable audio on the fly with xrandr. E.g., xrandr --output HDMI-0 --set audio auto
              Really? I did some tests with 3.12 and I thought it didn't work because I didn't know of the new xrandr option.

              Any chance to fix QT's raster engine? SI is starting to be fast and supports lots of features, it's a pity being not able to use it
              ## VGA ##
              AMD: X1950XTX, HD3870, HD5870
              Intel: GMA45, HD3000 (Core i5 2500K)

              Comment


              • #22
                Originally posted by HokTar View Post
                That didn't work. Setting radeon.audio=1 helped, though.
                Are you sure you were using a recent 3.12 kernel? Make sure your kernel has:
                http://git.kernel.org/cgit/linux/ker...1b124a6d2fa5b0

                Comment


                • #23
                  Here we go: http://mailman.alsa-project.org/pipe...er/066578.html

                  Have fun with testing.

                  Comment


                  • #24
                    Originally posted by agd5f View Post
                    Are you sure you were using a recent 3.12 kernel? Make sure your kernel has:
                    http://git.kernel.org/cgit/linux/ker...1b124a6d2fa5b0
                    I'm using 3.12-rc1 from the ubuntu kernel ppa, I suppose it should be there, though I haven't checked.

                    Edit: I checked that the patch was merged 3-4 days before rc1 was tagged so I suppose my kernel must have it, too.

                    I only get:
                    ~$ xrandr --output HDMI-0 --set audio enable
                    X Error of failed request: BadName (named color or font does not exist)
                    Major opcode of failed request: 140 (RANDR)
                    Minor opcode of failed request: 11 (RRQueryOutputProperty)
                    Serial number of failed request: 37
                    Current serial number in output stream: 37

                    If I write "auto", "on", etc. it's still the same story.
                    As I said, with radeon.audio=1 works, which is already good enough for me until ubuntu sorts itself out.
                    Last edited by HokTar; 09-22-2013, 05:30 PM.

                    Comment


                    • #25
                      Originally posted by HokTar View Post
                      I'm using 3.12-rc1 from the ubuntu kernel ppa, I suppose it should be there, though I haven't checked.

                      Edit: I checked that the patch was merged 3-4 days before rc1 was tagged so I suppose my kernel must have it, too.

                      I only get:
                      ~$ xrandr --output HDMI-0 --set audio enable
                      X Error of failed request: BadName (named color or font does not exist)
                      Major opcode of failed request: 140 (RANDR)
                      Minor opcode of failed request: 11 (RRQueryOutputProperty)
                      Serial number of failed request: 37
                      Current serial number in output stream: 37

                      If I write "auto", "on", etc. it's still the same story.
                      As I said, with radeon.audio=1 works, which is already good enough for me until ubuntu sorts itself out.
                      What output do you get for:
                      Code:
                      cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v

                      Comment


                      • #26
                        Originally posted by Tyler_K View Post
                        What output do you get for:
                        Code:
                        cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v
                        ~$ cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v
                        X.Org X Server 1.13.4
                        xrandr program version 1.3.5
                        Server reports RandR version 1.4


                        So is my xrandr version too old? That would be simple explanation, I guess.
                        Btw, thanks for your help!

                        Comment


                        • #27
                          With v2.0 specs released. Anssi could implement Bitstream Audio within minutes:



                          :-)

                          Thanks all involved.

                          Comment

                          Working...
                          X