Announcement

Collapse
No announcement yet.

Linux DRM graphic stack backports

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux DRM graphic stack backports

    http://www.linuxsystems.it/linux-drm...ack-backports/

    If someone is interested I'm maintaining a patchset which backports latest graphic stack from git to stable kernels.
    That means you will have all the advantages of latest graphic stack with the stability of a stable kernel with latest bugfixes.
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

  • #2
    New patch against 3.12 which backports drm from 3.13-rc1-pre:
    http://www.linuxsystems.it/linux-drm...ack-backports/
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

    Comment


    • #3
      Interesting. I wonder if I can slap this into the mainline AUR package.

      Do you know if these backports include the dynamic powering on/off of the dGPU in hybrid laptops?

      Comment


      • #4
        Yes, it does. The drm subsystem will be exactly the same of 3.13 with this patch.
        ## VGA ##
        AMD: X1950XTX, HD3870, HD5870
        Intel: GMA45, HD3000 (Core i5 2500K)

        Comment


        • #5
          Originally posted by darkbasic View Post
          Yes, it does. The drm subsystem will be exactly the same of 3.13 with this patch.
          Very nice, thanks for doing this.

          Time to see if my laptop doesn't lose it's mind with this new kernel.

          Comment


          • #6
            Welp, that didn't work so well.

            Locked up the machine on X start. Will have to investigate it more, maybe it didn't play well with some of the patches in the AUR pkgbuild.

            Comment


            • #7
              Does it hang *after* starting X? Can you post you Xorg.0.log after the crash?
              I didn't see the AUR patches but I don't think they can conflict. Maybe you should report the bug upstream.
              ## VGA ##
              AMD: X1950XTX, HD3870, HD5870
              Intel: GMA45, HD3000 (Core i5 2500K)

              Comment


              • #8
                Originally posted by darkbasic View Post
                Does it hang *after* starting X? Can you post you Xorg.0.log after the crash?
                I didn't see the AUR patches but I don't think they can conflict. Maybe you should report the bug upstream.
                I was getting this, followed by a segfault:

                Code:
                [  6698.798] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
                [  6698.798] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
                [  6698.798] (EE) 
                Fatal server error:
                [  6698.798] (EE) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
                [  6698.798] (EE) 
                [  6698.798] (EE)
                It would happen right as I did startx. First time it got to the desktop and locked up, second time it didn't even get that far.

                Did a little looking around, and some thread from a few years ago reported that same error, and said that adding nouveau drivers fixed it. It's strange, because I don't have a bit of Nvidia hardware in this machine, but figured I'd give it a shot anyway, and sure enough X started up without a problem.

                Not only that, looks like the dGPU is set to dynamic power, which is new:

                Code:
                [root@localhost echo]# cat /sys/kernel/debug/vgaswitcheroo/switch 
                0:DIS: :DynPwr:0000:01:00.0
                1:IGD:+:Pwr:0000:00:02.0
                Which is neat! But it kind of feels like the laptop fans are louder than ever. If anything, it seems like the major difference is that they just go from full volume all the way down to almost inaudible more often than they did before (previously they would just kinda stay at a constant volume until I did something GPU intensive, at which point it'd kick up to full volume).

                I'll have to run some tests to see how it doess on battery life now that I've got this running.

                Comment


                • #9
                  Actually, turns out that I wasn't using the radeon.runpm=1 kernel option.

                  Trouble is, with that, I get hard CPU locks. I also am getting random lockups with some of the driver modules as well. Am posting from a different machine right now so I don't have the Xorg logs on hand.

                  Is likely going to be best (for me at least) to stay back on stock 3.12 until the mainline moves to 3.13.

                  Comment


                  • #10
                    Of course you can wait for 3.13 to stabilize, but even with stable there is no guarantee that it will work fine on your system. Instead you can report the bug and let the developers become aware of your issue. If they ask you the kernel version tell them drm-next-3.13 20131109 or link the patchset on my website.
                    ## VGA ##
                    AMD: X1950XTX, HD3870, HD5870
                    Intel: GMA45, HD3000 (Core i5 2500K)

                    Comment

                    Working...
                    X