Announcement

Collapse
No announcement yet.

AMD Radeon GPUs Run Great With Linux 3.11 Kernel, Mesa 9.3-devel

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by Xeno View Post
    Unfortunatelly it's not so straight-forward.
    As an ATI card owner, that word has a whole new meaning to it. Making an initramfs is the easy part. (you know what I am saying you have an ati card as well)

    Depends on config you might need two different initramfs images, add/remove radeon kernel module to blacklist and reboot to switch. Another question if fglrx libs won't interfere with radeon driver (it may try to load proprietary OpenGL libs instead of mesa ones). Maybe with custom lib paths magic and handcrafted xorg.conf files.
    I have a dual screen, and about 500 backups of my hand crafted and mastered xorg.conf (where is that xkcd comic again?). However I should be able to remove fglrx from kernel 3.11 initramfs with dracut, and have a custom entry in xorg.conf to not blacklist radeon. (and possibly /etc/modprobe.d/blaclist.conf). The question is, can I automate this based on which kernel the system boots...


    Usually if I wanted to try fglrx, I install driver/kmod, do initramfs/blacklist dance (bl radeon, backup current init img, create new one) reboot an test.
    When i'm done, I uninstall catalyst and its kmod, remove radeon from blacklist then restore initarmfs image, reboot.

    Also I always use driver rpms from RPMFusion (my distro is Fedora). Driver pack from AMD site overwrite xorg and mesa libs.

    I use fedora as well. I am afraid to remove kmod-catalyst - there is no guarantee that it will start again when I install it. I am scared of ATI drivers really. IT can make or break my weekend! I would rather try it on a separate kernel or an USB live image.

    Comment


    • #42
      Originally posted by Xeno View Post
      BTW can you check what's the performance compared to catalyst?
      Sorry I don't have windows installed (well I have, but only as a VM) and I don't want to install fglrx on my perfectly fine running system

      Comment


      • #43
        Originally posted by droste View Post
        Do you have 2 monitors attached?

        If that's the case see: https://bugzilla.kernel.org/show_bug.cgi?id=60523

        My current workaround: Deactivate one screen when I don't use it.
        Droste, I can confirm now after checking that it is the exact same bug. I am stuck in power level 2. (I have tested with a liveUSB, so things were slow). No matter what I do, the power level doesnt change at all!


        Is there any more test you would like me to run?

        Comment


        • #44
          You could add yourself to the CC list of the bug in case Alex Deucher (agd5f) has something new to test.
          Right now there's nothing else you could do... Well other than trying to fix the bug by yourself

          Comment


          • #45
            BTW, AMD guys, is there anything still missing from the radeon kernel module that would prevent fglrx from using it instead of its own kernel module? Except for the will of the Catalyst team to rewrite the user space part to use the DRM API to talk to kernel, of course.

            Comment


            • #46
              Hi,

              I have ubuntu 13.04, kde 4.11.1 and kernel 3.8.
              I removed fglrx to use open source drivers. I had low resolution problem at startup and I solved it removing "nomodeset" option from /etc/default/grub.
              So I decided to install kernel 3.11 and now I have the low resolution problem back, that is when I start ubuntu I get the 1280x1024 resolution, but my maximum resolution is 1920x1080. The /etc/default/grub is the same I changed for kernel 3.8 so I don't understand why it doesn't work well anymore.
              I need kernel 3.11 because it has the optimization for radeno gpu's and at this moment my ATI MSI HD6870 is working at 65 C temperature with kernel 3.8 and I would like see whether I can have some cooler temperatures with kernel 3.11.

              Can you help me for the resolution problem?
              Thanks

              Comment


              • #47
                Originally posted by Frankiod View Post
                Hi,

                I have ubuntu 13.04, kde 4.11.1 and kernel 3.8.
                I removed fglrx to use open source drivers. I had low resolution problem at startup and I solved it removing "nomodeset" option from /etc/default/grub.
                So I decided to install kernel 3.11 and now I have the low resolution problem back, that is when I start ubuntu I get the 1280x1024 resolution, but my maximum resolution is 1920x1080. The /etc/default/grub is the same I changed for kernel 3.8 so I don't understand why it doesn't work well anymore.
                I need kernel 3.11 because it has the optimization for radeno gpu's and at this moment my ATI MSI HD6870 is working at 65 C temperature with kernel 3.8 and I would like see whether I can have some cooler temperatures with kernel 3.11.

                Can you help me for the resolution problem?
                Thanks
                dunno about ubuntu but in arch this problem don't exist, but whatever please try this options in grub(/etc/default/grub) <-- dunno if that exist in ubuntu, if not go directly to grub.cfg

                irqpoll threadirq radeon.dpm=1 radeon.audio=1

                Comment


                • #48
                  Probably the best thing to do first, is to check if the radeon driver is actually loaded during boot. Check dmesg, it should show something like this:

                  Code:
                  [drm] radeon kernel modesetting enabled.

                  Comment


                  • #49
                    Originally posted by Frankiod View Post
                    Hi,

                    I have ubuntu 13.04, kde 4.11.1 and kernel 3.8.
                    I removed fglrx to use open source drivers. I had low resolution problem at startup and I solved it removing "nomodeset" option from /etc/default/grub.
                    So I decided to install kernel 3.11 and now I have the low resolution problem back, that is when I start ubuntu I get the 1280x1024 resolution, but my maximum resolution is 1920x1080. The /etc/default/grub is the same I changed for kernel 3.8 so I don't understand why it doesn't work well anymore.
                    I need kernel 3.11 because it has the optimization for radeno gpu's and at this moment my ATI MSI HD6870 is working at 65 C temperature with kernel 3.8 and I would like see whether I can have some cooler temperatures with kernel 3.11.

                    Can you help me for the resolution problem?
                    Thanks

                    Are you by chance using the packages from the kernel ppa? Installing those on my machine result in "missing firmware" errors and no hardware acceleration.

                    Comment


                    • #50
                      My comments with kernel 3.11:

                      * uvd works like a charm even with Adobe Flash!
                      * dpm works but IMO it's too easily triggered in upclocking. A simple alt-tab will often upclock to maximum clock for a short period, this wil also ramp up the fan which is a bit annoying.
                      * I would like to see hdmi audio enabled by default.

                      Comment

                      Working...
                      X