Announcement

Collapse
No announcement yet.

Radeon DPM Support Should Now Be In Good Shape

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by gradinaruvasile View Post
    PS.
    1. Making use of the dpm feature requires more than just the kernel and compiled mesa/etc - you have to make absolutely sure the new libs are actually used. Even after an update you have to recheck (ldd /usr/bin/glxinfo), maybe ldconfig decides to do a stunt and puts back some old libs...
    Now that you've mentioned it I decided to check that, too but unfortunately: nothing. I've even tried to use the latest libdrm version from git but nope, nothing changed.
    The strange thing is that dmesg does not provide anything that could explain what is happening, everything is fine there. I can even work on a console without any trouble but as soon as I try to open anything in kde the whole system freezes.

    So, I guess I'm lost on this one and have to file a bug report, as I can't think of anything else that I could've forgotten to check.

    Comment


    • #32
      Originally posted by ledti View Post
      That's interesting. I've also been experiencing hard locks very randomly (every few days) ever since using DPM/mesa-git/mainline/etc, but I wasn't sure what was causing it. In my case, it usually happens while I'm using the computer and I'm forced to reset my computer manually. I've since enabled the magic sysrq key in hopes that I can get a kernel log of it the next time it happens.
      Well magic keys arent that magic as they dont work in this case.

      What works for me until now is disabling dpms (not turning off monitor by screensaver at all).

      Comment


      • #33
        Originally posted by Alderon View Post
        Now that you've mentioned it I decided to check that, too but unfortunately: nothing. I've even tried to use the latest libdrm version from git but nope, nothing changed.
        The strange thing is that dmesg does not provide anything that could explain what is happening, everything is fine there. I can even work on a console without any trouble but as soon as I try to open anything in kde the whole system freezes.

        So, I guess I'm lost on this one and have to file a bug report, as I can't think of anything else that I could've forgotten to check.
        Whats the output of
        Code:
        glxinfo | grep OpenGL
        I have

        Code:
        OpenGL vendor string: X.Org
        OpenGL renderer string: Gallium 0.4 on AMD ARUBA
        OpenGL version string: 3.0 Mesa 9.3.0-devel (git-0794f63)
        OpenGL shading language version string: 1.30

        Comment


        • #34
          Requested output:

          [alex@Pandora ~]$ glxinfo | grep OpenGL
          OpenGL vendor string: X.Org
          OpenGL renderer string: Gallium 0.4 on AMD BARTS
          OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.3.0-devel (git-8294d96)
          OpenGL core profile shading language version string: 1.40
          OpenGL core profile context flags: (none)
          OpenGL core profile extensions:
          OpenGL version string: 3.0 Mesa 9.3.0-devel (git-8294d96)
          OpenGL shading language version string: 1.30
          OpenGL context flags: (none)
          OpenGL extensions:

          Comment


          • #35
            Originally posted by gradinaruvasile View Post
            Well magic keys arent that magic as they dont work in this case.

            What works for me until now is disabling dpms (not turning off monitor by screensaver at all).
            Apparently it happened again last night while the computer was suspended... since I couldn't wake it and was forced to hard reset again. I tried the sysrq keys but I don't even know if they work in that scenario in the first place. Maybe our issues are unrelated. I've long since set dpms to only activate after 1 hour and 30 minutes, so it usually never activates for me.

            Comment


            • #36
              Originally posted by gradinaruvasile View Post
              Whats the output of
              Code:
              OpenGL vendor string: X.Org
              OpenGL renderer string: Gallium 0.4 on AMD ARUBA
              OpenGL version string: 3.0 Mesa 9.3.0-devel (git-0794f63)
              OpenGL shading language version string: 1.30
              Somehow my last answer didn't make it through, so please excuse the delay. I'm always using the git version:
              Code:
              OpenGL renderer string: Gallium 0.4 on AMD BARTS
              OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.3.0-devel (git-2572e3b)
              OpenGL core profile shading language version string: 1.40
              OpenGL version string: 3.0 Mesa 9.3.0-devel (git-2572e3b)
              Last edited by Alderon; 08-07-2013, 01:22 AM. Reason: forgot code tags

              Comment


              • #37
                Originally posted by Alderon View Post
                Somehow my last answer didn't make it through, so please excuse the delay. I'm always using the git version:
                Code:
                OpenGL renderer string: Gallium 0.4 on AMD BARTS
                OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.3.0-devel (git-2572e3b)
                OpenGL core profile shading language version string: 1.40
                OpenGL version string: 3.0 Mesa 9.3.0-devel (git-2572e3b)
                Hm the driver seems ok. How did you get the 3.1 opengl? Its some specific compile option?

                Well, the freezing issue... It seems just disabling dpms doesnt solve it. Last night i left my computer running, i set the screensaver only to blank the monitor and in the morning it was frozen stiff. The monitor had active signal (black), but it was still frozen.
                Now i experiment with simulating mouse movements every 15 minutes to wake up the monitor if its off (30 mins didnt work).

                Comment


                • #38
                  I don't really compile it myself, there's "mesa-git" on Arch Linux for that and the maintainer is very capable, so I don't really want to do stuff he can do better.
                  Does it sometimes freeze even while your screen is active or really only when the screen turns off?
                  Edit:
                  Sorry, just read that you already stated that sysrq doesn't help you.
                  Last edited by Alderon; 08-07-2013, 03:54 AM.

                  Comment


                  • #39
                    Originally posted by gradinaruvasile View Post
                    How did you get the 3.1 opengl?
                    You have to use an updated mesa-utils/glxinfo that can show profiles.

                    Comment


                    • #40
                      Originally posted by DanL View Post
                      You have to use an updated mesa-utils/glxinfo that can show profiles.
                      Hmm. I compiled glxinfo from the mesa demos git and i still have the same output.

                      Comment


                      • #41
                        Is this going to be enabled by default in kernel 3.12? I cant wait

                        Comment


                        • #42
                          Originally posted by edoantonioco View Post
                          Is this going to be enabled by default in kernel 3.12? I cant wait
                          Kernel 3.11 already has full dpm support, you have to add "radeon.dpm=1" to the kernel command line.

                          Comment


                          • #43
                            Originally posted by gradinaruvasile View Post
                            Kernel 3.11 already has full dpm support, you have to add "radeon.dpm=1" to the kernel command line.
                            Then that wouldn't be enabled by default, now would it?

                            Comment


                            • #44
                              Originally posted by gradinaruvasile View Post
                              Kernel 3.11 already has full dpm support, you have to add "radeon.dpm=1" to the kernel command line.
                              Thanks for the info , but seems to be than I have more FPS in games like team fortress 2 and portal having this feature disabled, so, now I have it disabled
                              (my GPU is Radeon HD 4200). Thats weird.

                              Comment


                              • #45
                                Originally posted by edoantonioco View Post
                                Thanks for the info , but seems to be than I have more FPS in games like team fortress 2 and portal having this feature disabled, so, now I have it disabled
                                (my GPU is Radeon HD 4200). Thats weird.
                                Did you download the appropiate firmware and put it in /lib/firmware/radeon ?
                                Run dmesg | grep dpm in terminal, if it failed to intialize then you need the right ucode...

                                I'm not sure which you should d/l... Seeing how you have a HD4000 series card you should download:
                                RV710_smc.bin
                                RV730_smc.bin
                                RV740_smc.bin
                                RV770_smc.bin

                                and put it all in /lib/firmware/radeon
                                Then reboot and run dmesg | grep dpm to verify if DPM intialized.
                                Last edited by Bushido_root; 09-18-2013, 05:07 PM.

                                Comment

                                Working...
                                X