Announcement

Collapse
No announcement yet.

Radeon DRM: Dynamic Power Management Updates

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #71
    Originally posted by Alejandro Nova View Post
    Linux 3.11 rc0 here, and I report UVD is finally working with my E-450. Since E-350 and E-450 are basically the same, you shouldn't have issues.

    OTOH, I get this when I try to enable the new Dynamic Power Management code.
    I should have mentioned that I am only trying with dpm enabled. dpm works great on my E-350. UVD might work if I disable dpm, but I don't want to.

    Comment


    • #72
      After enabling the power management with radeon.dpm=1, my system (sony Z2 notebook with radeon Radeon HD 6730M/6770M/7690M XT) freezes most of the time completely after starting X.
      Or if I X starts, after a while it freezes with the following error message:
      Code:
      (EE) [mi] EQ overflow continuing.  300 events have been dropped.
      (EE) 
      (EE) Backtrace:
      (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x7f9f1339b476]
      (EE) 1: /usr/bin/X (0x7f9f131eb000+0x6d472) [0x7f9f13258472]
      (EE) 2: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f9f0b72e000+0x5f44) [0x7f9f0b733f44]
      (EE) 3: /usr/bin/X (0x7f9f131eb000+0x96927) [0x7f9f13281927]
      (EE) 4: /usr/bin/X (0x7f9f131eb000+0xc0328) [0x7f9f132ab328]
      (EE) 5: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f9f122ee000+0xfbd0) [0x7f9f122fdbd0]
      (EE) 6: /usr/bin/X (0x7f9f131eb000+0x1b4730) [0x7f9f1339f730]
      (EE) 7: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f9f122ee000+0xfbd0) [0x7f9f122fdbd0]
      (EE) 8: /lib/x86_64-linux-gnu/libc.so.6 (ioctl+0x7) [0x7f9f1100b747]
      (EE) 9: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmIoctl+0x28) [0x7f9f120e6338]
      (EE) 10: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmCommandWriteRead+0x1c) [0x7f9f120e873c]
      (EE) 11: /usr/lib/x86_64-linux-gnu/libdrm_radeon.so.1 (0x7f9f0f954000+0x26c3) [0x7f9f0f9566c3]
      (EE) 12: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7f9f0fb5f000+0x41c5b) [0x7f9f0fba0c5b]
      (EE) 13: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7f9f0fb5f000+0x262a1) [0x7f9f0fb852a1]
      (EE) 14: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7f9f0fb5f000+0x34497) [0x7f9f0fb93497]
      (EE) 15: /usr/lib/xorg/modules/libexa.so (0x7f9f0f73c000+0xe19d) [0x7f9f0f74a19d]
      (EE) 16: /usr/lib/xorg/modules/libexa.so (0x7f9f0f73c000+0xec50) [0x7f9f0f74ac50]
      (EE) 17: /usr/lib/xorg/modules/libexa.so (0x7f9f0f73c000+0xcc66) [0x7f9f0f748c66]
      (EE) 18: /usr/bin/X (0x7f9f131eb000+0x139ed8) [0x7f9f13324ed8]
      (EE) 19: /usr/bin/X (0x7f9f131eb000+0x1330e6) [0x7f9f1331e0e6]
      (EE) 20: /usr/bin/X (0x7f9f131eb000+0x58ac1) [0x7f9f13243ac1]
      (EE) 21: /usr/bin/X (0x7f9f131eb000+0xm_libc_start_main+0xf5) [0x7f9f10f3bea5]
      (EE) 23: /usr/bin/X (0x7f9f131eb000+0x478c1) [0x7f9f132328c1]
      Anyone else with that problem?

      Comment


      • #73
        yesterday i pulled the new drm-fixes-3.11 commits and compiled the kernel.
        it seems that the problem is now fixed.

        Comment


        • #74
          Hello everyone.

          Can You guys please point me to instruction on how to compile latest kernel with radeon dpm patches and mesa 9.2 on Ubuntu?

          Comment


          • #75
            Running a Radeon 6670 1GB GDDR5 card (Turks) and on boot with radeon.dpm=1 I get vertical blue lines on all three heads. Using the latest fedora rawhide kernel (3.11rc1) on 19 with firmwares downloaded from the main firmware site unpacked into /usr/lib/firmware/radeon/ and rebuilding my initrd. Mother board is a MSI 990-FXA and processor is a Pheonom II X6 1090T

            Comment


            • #76
              Originally posted by Lemonzest View Post
              Running a Radeon 6670 1GB GDDR5 card (Turks) and on boot with radeon.dpm=1 I get vertical blue lines on all three heads. Using the latest fedora rawhide kernel (3.11rc1) on 19 with firmwares downloaded from the main firmware site unpacked into /usr/lib/firmware/radeon/ and rebuilding my initrd. Mother board is a MSI 990-FXA and processor is a Pheonom II X6 1090T
              3.11RC1 does not have these fixes, you need either the drm-fixes-3.11 branch from Alex Deucher or you have to wait for RC2

              Comment


              • #77
                With the newest drm-fixes-3.11 as of today, UVD still does not work on my Radeon HD 6870 and results in a soft-GPU lockup during boot. This is WITH and WITHOUT dpm enabled.

                Code:
                d2kx@d2kx-desktop:~$ dmesg | grep UVD
                [    3.820948] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [    4.832160] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [    5.843376] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [    6.854589] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [    7.865805] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [    8.877008] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [    9.888222] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [   10.899468] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [   11.910683] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [   12.921898] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!
                [   12.941771] [drm:r600_uvd_init] *ERROR* UVD not responding, giving up!!!
                [   12.941823] [drm:evergreen_startup] *ERROR* radeon: error initializing UVD (-1).
                HOWEVER, the good news is dpm is fully fixed on my HD 6870 and now it properly clocks in 3D games and 3D performance is literally amazing... Left 4 Dead 2 with all settings maxed plays great and is on par with Catalyst and that is without the R600 shader optimizations forthcoming in Mesa...
                Last edited by d2kx; 07-19-2013, 08:57 AM.

                Comment


                • #78
                  Originally posted by d2kx View Post
                  With the newest drm-fixes-3.11 as of today, UVD still does not work on my Radeon HD 6870 and results in a soft-GPU lockup during boot. This is WITH and WITHOUT dpm enabled.
                  Make sure you have the latest rlc and the uvd ucode available to your kernel. If you are building the ucode and driver into the kernel, make sure you run 'make clean' after updating the ucode since the kernel doesn't track whether ucode files change or not. e.g.,
                  https://bugs.freedesktop.org/show_bug.cgi?id=66519

                  Comment


                  • #79
                    Originally posted by agd5f View Post
                    Make sure you have the latest rlc and the uvd ucode available to your kernel. If you are building the ucode and driver into the kernel, make sure you run 'make clean' after updating the ucode since the kernel doesn't track whether ucode files change or not. e.g.,
                    https://bugs.freedesktop.org/show_bug.cgi?id=66519
                    Thank you so much :-) I've got it working now!

                    Comment


                    • #80
                      Originally posted by Lemonzest View Post
                      Running a Radeon 6670 1GB GDDR5 card (Turks) and on boot with radeon.dpm=1 I get vertical blue lines on all three heads. Using the latest fedora rawhide kernel (3.11rc1) on 19 with firmwares downloaded from the main firmware site unpacked into /usr/lib/firmware/radeon/ and rebuilding my initrd. Mother board is a MSI 990-FXA and processor is a Pheonom II X6 1090T
                      All working now with 3.11rc2 rawhide kernel, gpu dropped 16c

                      Comment

                      Working...
                      X