Announcement

Collapse
No announcement yet.

xf86-video-ati-7.0.0 causes segmentation fault in dual intel+amd graphics laptop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • xf86-video-ati-7.0.0 causes segmentation fault in dual intel+amd graphics laptop

    Maybe I'll have more luck here than in the gentoo forums. Basically, since updating to xf86-video-ati-7.0.0, if my discrete gpu is enabled, X doesn't start (segfaults). Logs:

    http://pastebin.com/vm4vEW8z <- video-ati-6.14, ati GPU enabled (works ok)
    http://pastebin.com/XfKAkLSs <- video-ati-7.0, ati GPU enabled (segfaults)
    http://pastebin.com/YjxNwsMQ <- video-ati-7.0, ati GPU disabled (works ok)

    Differences in the logs between xf86-video-ati-6.14 and xf86-video-ati-7.0:

    * With 6.14 and the ati GPU enabled, Xorg seems to detect the ati card (it loads intel_drv in line 91 and ati_drv in line 96) but doesn't try to initialize the ati card (it uses the intel card, as it should, and there are no more messages about radeon/ati after line 96, just intel).

    * With 7.0 and the ati GPU enabled, Xorg loads intel_drv (91), ati_drv (96) and a new (?) radeon_drv (102). Now there are several messages mentioning radeon after the intel messages (lines 150- and 471-), and then it segfaults.

    * With 7.0 and the ati GPU disabled before starting X, Xorg just loads intel_drv (88). No mention of radeon anywhere and no problems afterwards.

    I could disable the amd gpu in a service before xdm starts, but that's not a solution, it's an ugly workaround. I'd rather find out why 6.14 worked fine and 7.0 doesn't.

    Thanks!

  • #2
    I have the same problem, and it's happening to a lot of people. See this upstream bug report. The only solution right now is to downgrade.

    Comment


    • #3
      Originally posted by Xipeos View Post
      I have the same problem, and it's happening to a lot of people. See this upstream bug report. The only solution right now is to downgrade.
      Thanks. Good to know I'm not alone. Will post a "me too" in the bugzilla with my logs.

      Comment

      Working...
      X