Announcement

Collapse
No announcement yet.

WebGL and Open Source AMD drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WebGL and Open Source AMD drivers

    Is it supposed to work ok??

    I runned the khronos test and the screen went blank one or two times. The same thing when i enabled MapsGL in Google maps.
    Code:
    glxinfo | grep -i opengl
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD BARTS
    OpenGL version string: 2.1 Mesa 8.0.3
    OpenGL shading language version string: 1.20
    OpenGL extensions:
    Chrome experiments seem to work quite well. No antialliasing as far as i can tell.

  • #2
    WebGL works generally quite good for me, google mapsgl has a bit flickering on scrolling but it works ok.
    In chromium many of the khronos tests passed, some failed and then it froze the tab (I didn't wait very long, so maybe it was just working, but no cpu usage).

    Comment


    • #3
      Forgot to mention that i use firefox and that i haven't messed with any acceleration options in the about:config menu. Also dmesg reported GPU lockup.

      Comment


      • #4
        For me it mostly works on opensource driver.

        Khronos test reports: Results: (8818 of 8840 passed) (yeah, some tests failed -> not perfect).
        WebGL basically works (using stock Ubuntu 12.04 drivers). For example I can see cool spheres in Peacekeeper browser test, etc.

        OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
        Browser: tested on firefox 12.0 & 13.0

        Comment


        • #5
          Originally posted by 0xBADCODE View Post
          Khronos test reports: Results: (8818 of 8840 passed) (yeah, some tests failed -> not perfect).
          How the hell did you do this. I'm also using mesa with a juniper and I get the following with ff12: Results: (8351 of 8852 passed)

          Do you use latest code from git? or latest from a stable branch? distro provided mesa?

          Comment


          • #6
            i run the khronos tests again and it locked my system completely (hard reboot)

            Comment

            Working...
            X