Announcement

Collapse
No announcement yet.

A8-3500M + Radeon HD 6650M: make it cool?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • A8-3500M + Radeon HD 6650M: make it cool?

    Ok, so I've got an Acer AS5560G-SB448 with A8-3500M + Radeon HD 6620G.
    It is running pretty well, but seems a touch on the warm side, idles at about 60-65^C. Seems a little high for a 35 watt part with the fan blowing about 1/3 to 1/2 power....

    power management method is set to profile, profile is set to low. Doesn't seem to make any difference from profile set to default. Setting the method to "dynpm" crashes the kernel in a very bad way. There is zero problem with performance, my GPU needs are very low, and compositing is unbelievably fluid.

    Now questions about this processors specifications and what I can expect to be able to do with it;

    1) CPU cores idle at 800 MHz, and max out at 1500 MHz. Now I know that the thing is *supposed* to "turbocore" up to 2400 MHz, but this doesn't seem to actually happen. Any way to make this work? Any way to get the thing to scale down LOWER than 800 MHz? 800 MHz seems a little higher than it needs to be. Any way to shut down excess cores when not needed?
    2) Voltages... they scaling properly for CPU and GPU? Any way to monitor these? Any way to check the GPU frequency?

    Objective here is to damn the performance, force it to use as little power as possible. Any suggestions?

  • #2
    powermanagement still sucks with open source drivers. you should use fglrx drivers with a laptop.

    My laptop and every others overheat with OSS drivers

    Comment


    • #3
      Originally posted by Morgan00 View Post
      powermanagement still sucks with open source drivers. you should use fglrx drivers with a laptop.

      My laptop and every others overheat with OSS drivers
      Unless you have something USEFUL to add, don't waste the time saying anything.

      Comment


      • #4
        Read topics on this forum and check tests from phoronix, you will see that OSS drivers use a lot more power than fglrx drivers for the same usage.
        You just won't be able to do a lot about this whatever low profile or not you set. (and dynpm is not really stable on a lot of pc)

        And thank you for your concern, but I "waste my time" as I see fit

        Comment


        • #5
          Originally posted by Morgan00 View Post
          Read topics on this forum and check tests from phoronix, you will see that OSS drivers use a lot more power than fglrx drivers for the same usage.
          You just won't be able to do a lot about this whatever low profile or not you set. (and dynpm is not really stable on a lot of pc)

          And thank you for your concern, but I "waste my time" as I see fit
          Go waste your time OUT OF MY THREAD!!!!

          Comment


          • #6
            Originally posted by droidhacker View Post
            1) CPU cores idle at 800 MHz, and max out at 1500 MHz. Now I know that the thing is *supposed* to "turbocore" up to 2400 MHz, but this doesn't seem to actually happen. Any way to make this work? Any way to get the thing to scale down LOWER than 800 MHz? 800 MHz seems a little higher than it needs to be. Any way to shut down excess cores when not needed?

            2) Voltages... they scaling properly for CPU and GPU? Any way to monitor these? Any way to check the GPU frequency?
            Don't have much info on the CPU side -- in theory everything needed for CPU power management is enabled in the system BIOS but we have seen some reports recently where CPU power draw seems to be higher with the open drivers. Not sure why that is yet.

            On the GPU side, IIRC agd5f said that we were not reducing GPU voltages on APU parts yet.

            Comment


            • #7
              It appears that a fair amount of undervolting is possible with Llano. However this helps more with the load consumption than with idle (because idle parts are typically gated off). On Linux you will probably need to decompile your ACPI DSDT and adjust the voltage in the various power states. Then compile it and pass to kernel via ACPI_CUSTOM_DSDT option. Reportedly 0.2-0.3V can be shaved off on Llano before the system becomes unstable.

              Some general information on hacking your DSDT can be found at gentoo-wiki.com.

              Comment


              • #8
                Originally posted by bridgman View Post
                Don't have much info on the CPU side -- in theory everything needed for CPU power management is enabled in the system BIOS but we have seen some reports recently where CPU power draw seems to be higher with the open drivers. Not sure why that is yet.

                On the GPU side, IIRC agd5f said that we were not reducing GPU voltages on APU parts yet.
                Guess that would explain it then... I don't suppose you've got an ETA for when that may be implemented?
                Is there any way I could go about forcing the voltage down manually?

                Comment


                • #9
                  Originally posted by chithanh View Post
                  It appears that a fair amount of undervolting is possible with Llano. However this helps more with the load consumption than with idle (because idle parts are typically gated off). On Linux you will probably need to decompile your ACPI DSDT and adjust the voltage in the various power states. Then compile it and pass to kernel via ACPI_CUSTOM_DSDT option. Reportedly 0.2-0.3V can be shaved off on Llano before the system becomes unstable.

                  Some general information on hacking your DSDT can be found at gentoo-wiki.com.
                  Thanks, that helps!

                  Comment


                  • #10
                    The information is in:
                    Code:
                    [disi@disi-bigtop]~ % cat /sys/kernel/debug/dri/0/radeon_pm_info 
                    default engine clock: 680000 kHz
                    current engine clock: 299980 kHz
                    default memory clock: 900000 kHz
                    current memory clock: 900000 kHz
                    voltage: 950 mV
                    Needs to have debugfs enabled in the kernel. If you use an external monitor, then the memory clock is fixed... this is on a dedicated AMD 6970M with the latest radeon driver
                    You can change the clocks by choosing a profile:
                    Code:
                    [disi@disi-bigtop]~ % cat /sys/class/drm/card0/device/power_method 
                    profile
                    [disi@disi-bigtop]~ % cat /sys/class/drm/card0/device/power_profile 
                    low
                    https://wiki.archlinux.org/index.php/ATI#Powersaving is a nice list of options.

                    My C-50 APU has similar options but half the memory clock and a third of the max GPU speed.
                    seems to be fixed:
                    Code:
                    [disi@disi-netbook]~% cat /sys/kernel/debug/dri/0/radeon_pm_info 
                    default engine clock: 200000 kHz
                    current engine clock: 200000 kHz
                    default memory clock: 533000 kHz
                    Last edited by disi; 06-09-2012, 06:55 AM.

                    Comment


                    • #11
                      Thanks, nice to know where to get the numbers from.
                      However, I think mine is broken...
                      Code:
                      $ cat /sys/kernel/debug/dri/0/radeon_pm_info 
                      default engine clock: 200000 kHz
                      current engine clock: 6520 kHz
                      default memory clock: 667000 kHz
                      6.52 MHz doesn't seem reasonable.

                      Comment


                      • #12
                        Hello, droidhacker.
                        I have 7560G, that simply same laptop, but 17". (Don't forget to update BIOS, by the way.)

                        Originally posted by droidhacker View Post
                        power management method is set to profile, profile is set to low. Doesn't seem to make any difference from profile set to default.
                        Because you also need to disable discrete GPU in BIOS or by
                        Code:
                        echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch
                        Originally posted by droidhacker View Post
                        CPU cores idle at 800 MHz, and max out at 1500 MHz. Now I know that the thing is *supposed* to "turbocore" up to 2400 MHz, but this doesn't seem to actually happen. Any way to make this work?
                        Answer for this question is here: http://support.amd.com/us/Processor_TechDocs/41131.pdf (2.5.3.1.1)
                        To ensure proper OS operation, boosted P-states should be hidden from the operating system.
                        So boosted P-states (up to 2.4 GHz) is here, works (check CPB here /sys/devices/system/cpu/cpuN/cpufreq/cpb), you just doesn't see it. To see it use cpufreq-aperf or cpupowerutils (run "cpupower monitor").
                        Originally posted by droidhacker View Post
                        Any way to shut down excess cores when not needed?
                        AFAIK it happen automatically. See 2.5.3.2.3.2 for details.
                        Originally posted by droidhacker View Post
                        Any way to get the thing to scale down LOWER than 800 MHz? 800 MHz seems a little higher than it needs to be.
                        It doesn't make sense: http://mjg59.livejournal.com/88608.html
                        Originally posted by droidhacker View Post
                        Thanks, nice to know where to get the numbers from.
                        However, I think mine is broken...
                        Code:
                        $ cat /sys/kernel/debug/dri/0/radeon_pm_info 
                        default engine clock: 200000 kHz
                        current engine clock: 6520 kHz
                        default memory clock: 667000 kHz
                        6.52 MHz doesn't seem reasonable.
                        I would like to know answer for this too: https://bugzilla.kernel.org/show_bug.cgi?id=43114
                        Last edited by RussianNeuroMancer; 06-09-2012, 04:59 PM.

                        Comment


                        • #13
                          Originally posted by RussianNeuroMancer View Post
                          Hello, droidhacker.
                          I have 7560G, that simply same laptop, but 17". (Don't forget to update BIOS, by the way.)

                          Because you also need to disable discrete GPU in BIOS or by
                          Code:
                          echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch
                          Answer for this question is here: http://support.amd.com/us/Processor_TechDocs/41131.pdf (2.5.3.1.1)

                          So boosted P-states (up to 2.4 GHz) is here, works (check CPB here /sys/devices/system/cpu/cpuN/cpufreq/cpb), you just doesn't see it. To see it use cpufreq-aperf or cpupowerutils (run "cpupower monitor").
                          AFAIK it happen automatically. See 2.5.3.2.3.2 for details.
                          It doesn't make sense: http://mjg59.livejournal.com/88608.html
                          I would like to know answer for this too: https://bugzilla.kernel.org/show_bug.cgi?id=43114
                          THANK YOU very much!!!
                          It didn't occur to me that it had both GPUs powered on and sucking battery. In fact, it didn't even register with me that it has two!!!
                          Discrete is now disabled in bios, and idle temp is just over 40 degrees.

                          Comment

                          Working...
                          X