Announcement

Collapse
No announcement yet.

Open-Source ATI Driver Gets TV-Out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Open-Source ATI Driver Gets TV-Out

    Phoronix: Open-Source ATI Driver Gets TV-Out

    Thanks to recent commits in the RandR 1.2 branch for the open-source X.Org Radeon driver, it's now possible to use S-Video and composite TV output on your ATI graphics card without any patches. This is not limited to the R200 series but will also work with the R300 series and theoretically any graphics card supported by the xf86-video-ati driver. In this guide have outlined the instructions for enabling TV output support from the Radeon driver git code as well as some of the current limitations.

    http://www.phoronix.com/vr.php?view=10814

  • #2
    Hi,

    Is the video overlay working properly with this driver?


    Trek1701

    Comment


    • #3
      but of course.

      Comment


      • #4
        Hi,

        I'm having trouble building the driver. autogen.sh runs smoothly, but when I use the make command I get this:

        make all-recursive
        make[1]: Entering directory `/home/lynn/Desktop/xf86-video-ati'
        Making all in src
        make[2]: Entering directory `/home/lynn/Desktop/xf86-video-ati/src'
        /bin/bash ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/xorg -I/usr/include/drm -I/usr/include/X11/dri -g -O2 -MT ati.lo -MD -MP -MF .deps/ati.Tpo -c -o ati.lo ati.c
        gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/xorg -I/usr/include/drm -I/usr/include/X11/dri -g -O2 -MT ati.lo -MD -MP -MF .deps/ati.Tpo -c ati.c -fPIC -DPIC -o .libs/ati.o
        In file included from ati.c:65:
        radeon_probe.h:46:22: error: xf86Crtc.h: No such file or directory
        In file included from ati.c:65:
        radeon_probe.h:225: error: expected specifier-qualifier-list before 'xf86CrtcPtr'
        ati.c:228: error: 'PACKAGE_VERSION_MAJOR' undeclared here (not in a function)
        ati.c:228: error: 'PACKAGE_VERSION_MINOR' undeclared here (not in a function)
        ati.c:228: error: 'PACKAGE_VERSION_PATCHLEVEL' undeclared here (not in a function)
        make[2]: *** [ati.lo] Error 1
        make[2]: Leaving directory `/home/lynn/Desktop/xf86-video-ati/src'
        make[1]: *** [all-recursive] Error 1
        make[1]: Leaving directory `/home/lynn/Desktop/xf86-video-ati'
        make: *** [all] Error 2
        Does anyone know the solution?

        Thanks
        -Lynn

        Comment


        • #5
          Originally posted by lynn View Post
          Hi,

          I'm having trouble building the driver. autogen.sh runs smoothly, but when I use the make command I get this:



          Does anyone know the solution?
          Looks like you're missing some headerfiles from the xorg-server package (and maybe other X libs)
          Forgot to install the appropriate -devel package(s)?
          Last edited by mlau; 08-15-2007, 03:15 PM.

          Comment


          • #6
            Which header files and dev packages, specifically? I've been installing various things that sound related, such as xorg-dev and xlibs-dev, but I keep getting the same make error.

            Thanks
            -Lynn

            Comment


            • #7
              maybe xorg-server development files would do the trick.

              Comment


              • #8
                Originally posted by lynn View Post
                Which header files and dev packages, specifically? I've been installing various things that sound related, such as xorg-dev and xlibs-dev, but I keep getting the same make error.

                Thanks
                -Lynn
                Yoshi's right. To find out what's missing, use your distributions package system. For instance, on debian go to http://packages.debian.org/ and at the bottom, search for the missing file - xf86Crtc.h. It tells you that the file exists in the xserver-xorg-dev package.
                Now, this is debian. I don't know if this works for you.

                Comment


                • #9
                  Originally posted by lynn View Post
                  Which header files and dev packages, specifically? I've been installing various things that sound related, such as xorg-dev and xlibs-dev, but I keep getting the same make error.
                  According to gentoo's portage this particular
                  header belongs to the 'xorg-server' package,
                  assuming your distro is already using >= X 7.0

                  Comment


                  • #10
                    Thanks to you guys I have the TV-out working, but now there's another problem. The colors on the TV appear as if their brightness has been inverted. For example, bright orange becomes dark orange and dark blue becomes light blue.

                    This is my LCD monitor and this is my tv screen. Any ideas?

                    Comment

                    Working...
                    X