Announcement

Collapse
No announcement yet.

Open-Source ATI Driver Gets TV-Out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by garv View Post
    Ok, I keep running into a problem at the autogen.sh stage. aclocal seems to be giving me a problem.

    I first received an error involving autoreconf. Turns out it was not installed on my system. I installed the package and now the above output is where I am at now.
    I also had the same error, which I resolved by installing aclocal and/or automake (don't recall specifically which).
    Last edited by acetonitrile; 09-24-2007, 05:08 PM.

    Comment


    • #17
      I still have another problem... following the instructions posted, after running ./autogen.sh I get the following results

      Code:
      [root@localhost xf86-video-ati]# ./autogen.sh --prefix=/usr/
      autoreconf: Entering directory `.'
      autoreconf: configure.ac: not using Gettext
      autoreconf: running: aclocal
      autoreconf: configure.ac: tracing
      autoreconf: configure.ac: not using Libtool
      autoreconf: running: /usr/bin/autoconf
      autoreconf: running: /usr/bin/autoheader
      autoreconf: running: automake --add-missing --copy --no-force
      src/Makefile.am:50: Libtool library used but `LIBTOOL' is undefined
      src/Makefile.am:50:
      src/Makefile.am:50: The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
      src/Makefile.am:50: to `configure.ac' and run `aclocal' and `autoconf' again.
      Makefile.am:24: BUILD_LINUXDOC does not appear in AM_CONDITIONAL
      autoreconf: automake failed with exit status: 1
      I'm trying to get this running for a MythTV box, running MythDora 4 (Fedora Core 6). Up to this point I've already installed git, autoconf, aclocal, and automake all using the 'yum install' command (so whatever versions have been packaged up for FC6). Am I missing something?

      Comment


      • #18
        You might want to install libtool, or, just in case, libtool*.
        Anyway, to avoid more of these kind of errors the best would be to do a
        Code:
        yum install groupinstall "Development Tools" "Development Libraries"
        This will install most of the stuff usually used for such things.

        Comment


        • #19
          I need help with making this work

          Please help me. I'm somewhat-new to Linux but really want to make my s-video out to work.
          I'm running Fiesty Fawn 7.04 on an hp pavilion ze4200 that has ati Radeon IGP 340M. Supposedly, the fix on this page should work, however when I go into the termnal and type
          " git-clone git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati"
          cd xf86-video-ati
          git checkout origin/randr-1.2"
          I get:
          "error: pathspec 'origin/randr-1.2' did not match any."
          And I don't know where to find this.

          Same for the second set up steps
          When I type
          "git-clone git://anongit.freedesktop.org/git/xorg/app/xrandr
          cd xrandr
          ./autogen.sh --prefix=/usr/"
          I get:
          "./autogen.sh: 9: autoreconf: not found"

          Can anyone who knows what to do/ has done this, help me out?

          Comment


          • #20
            For the first one, you no longer need to do the git checkout origin/randr-1.2 as the randr-1.2 branch was merged into the master branch. So just skip that step.


            For the second one, make sure you have autoreconf/autoconf installed. Also, for Ubuntu 7.04 you will need to update to Xserver 1.3 in order to use the driver.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #21
              still need help

              Thanks for responding so fast.

              Sorry to be so inept at this but can you give me some pointers as how to:
              update to Xserver 1.3 in order to use the driver.
              I looked on synaptic but I couldn't figure out what exactly to get.

              Also when I skip
              "git checkout origin/randr-1.2"
              and type
              "./autogen.sh --prefix=/usr/"
              inside "~/xf86-video-ati$"
              I get

              "Can't exec "aclocal": No such file or directory at /usr/bin/autoreconf2.50 line 182.
              Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf2.50 line 182.
              Can't exec "automake": No such file or directory at /usr/bin/autoreconf2.50 line 183.
              Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf2.50 line 183.
              autoreconf2.50: Entering directory `.'
              autoreconf2.50: configure.ac: not using Gettext
              autoreconf2.50: running: aclocal --output=aclocal.m4t
              Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 290.
              autoreconf2.50: failed to run aclocal: No such file or directory"

              Don't really know what means...

              Comment


              • #22
                Originally posted by captain-murphy View Post
                Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 290.
                You might want to make sure that the following packages are installed:
                * GNU make
                * autoconf 2.58 (or newer)
                * automake 1.8
                * libtool 1.5
                * m4
                You should also check for other versions of automake and install them as well, if supported by Ubuntu. Afterwards, try again.

                Comment


                • #23
                  Xserver 1.3 needs to be downloaded from a Gutsy repository or upgrade to a Gutsy testing release.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #24
                    Sorry for being terrible at this.

                    Thanks both of you for helping.
                    I got all the packages you recomended and figured out how to get gusty in my respositories and then get x server 1.3, and things got a little bit further...

                    however I can't figure out why it doesn't work.
                    For example for the first step: after

                    "xf86-video-ati: ./autogen.sh --prefix=/usr/"

                    The commands:
                    "make"
                    and
                    "make install"
                    Don't know what to do so they stop. Thus I don't know if the xf86 video ati is really installed at all.

                    I got 'make' and 'make install' to work for xrandr, however when I type the commands

                    xrandr --addmode S-video 800x600
                    xrandr --output S-video --mode 800x600

                    It just accepts them and nothing happens. Nothing is being sent to me tv from my S-video...

                    Comment


                    • #25
                      Did you restart your computer (or X) after the make install of the radeon driver?
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment


                      • #26
                        Yes I turned it off and then started it back up and tried to type the
                        "xrandr --addmode S-video 800x600
                        xrandr --output S-video --mode 800x600"
                        but nothing happened.

                        What exactly does "xf86-video-ati" do and how do I know if it's installed/working correctly?

                        Comment


                        • #27
                          Originally posted by captain-murphy View Post
                          What exactly does "xf86-video-ati" do and how do I know if it's installed/working correctly?
                          That is the actual driver itself... It sounded like you may have installed it correctly. Can you post your xorg.0.log from /var/log/ ?
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #28
                            Yes, it's very long though, so I uploaded it to my old geocities account I had from hs.
                            http://www.geocities.com/kofflera/Xorg.0.log
                            thats the log.

                            Comment


                            • #29
                              I seem to be stuck at the same place as captain-murphy

                              I have successfully compiled the and installed the xf86-video-ati driver and randr as described in the how-to referred to from the first post of this thread.

                              When I try to enable the tv-out manually by executing:
                              Code:
                              xrandr --addmode S-video 800x600
                              xrandr --output S-video --mode 800x600
                              ... the following error occurs:
                              Code:
                              xrandr: cannot find crtc for output S-video
                              However, this error seems to be solved by disabling the DVI (My live monitor is connected to the VGA port) by
                              Code:
                              xrandr --output DVI-0 --off
                              But when I again try to enable the tv-out, the command seems to be accepted (no errors in the prompt) but my monitor picture increases the brightness a lot, and still no tv-out

                              I cannot understand the clues that might be in my x-server log, except the final lines look promising. Therefore I've posted my Xorg.0.log here, as it looks after a reboot and an attempt of manually enabling the tv-out as described above.

                              I will appreciate any comments a lot - Thanks

                              Background: I'm running Ubuntu 7.10 on my Asus Pundit-r which has an onboard ATI Radeon 9100 IGP graphics card. I connect to my TV using an s-video cable and the described error occurs no matter if the TV-out is forced from the BIOS or not. Oh, and I'm in a PAL-B/G-land

                              Comment


                              • #30
                                I have been waiting for this for years. Thanks, guys, keep up the good work.

                                Comment

                                Working...
                                X