Announcement

Collapse
No announcement yet.

I need help: How to patch radeon driver?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I need help: How to patch radeon driver?

    Hi all. I filed a bug against opensource radeon driver: https://bugs.freedesktop.org/show_bug.cgi?id=49761 . I have to apply patch and see if it fixes my problem. But I don't know how to do it. Can anybody guide me through it (step by step) or point me to some good patching guide/wiki?

    I am using Kubuntu 12.04.

    Thank you in advance

  • #2
    Thank you Alex Deucher for helping me.

    "To apply the patch, download the radeon driver (xf86-video-ati) and build deps
    and save a copy of the patch.

    1. git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-ati
    2. cd xf86-video-ati
    3. patch -p1 -i fdo49761.diff

    you many need to adjust the configure options below depending on your distro
    4. ./autogen.sh --prefix=/usr --libdir=/usr/lib64

    5. make
    6. make install"

    On 3rd step I got this error:
    Code:
    snele@KDevil:~/xf86-video-ati$ patch -p1 -i fdo49761.diff
    patch: **** Can't open patch file fdo49761.diff : No such file or directory
    And question about 4th step. I use 32bit Kubuntu so should command be
    Code:
    ./autogen.sh --prefix=/usr --libdir=/usr/lib
    (without "64") ?

    Sorry for stupid noob questions, but I really don't know what I am doing

    Comment


    • #3
      On 32bit, you can just use ./autogen.sh --prefix=/usr which is equivalent to ./autogen.sh --prefix=/usr --libdir=/usr/lib

      Comment


      • #4
        Originally posted by schnelle View Post
        Thank you Alex Deucher for helping me.

        "To apply the patch, download the radeon driver (xf86-video-ati) and build deps
        and save a copy of the patch.

        1. git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-ati
        2. cd xf86-video-ati
        3. patch -p1 -i fdo49761.diff

        you many need to adjust the configure options below depending on your distro
        4. ./autogen.sh --prefix=/usr --libdir=/usr/lib64

        5. make
        6. make install"

        On 3rd step I got this error:
        Code:
        snele@KDevil:~/xf86-video-ati$ patch -p1 -i fdo49761.diff
        patch: **** Can't open patch file fdo49761.diff : No such file or directory
        You have to replace 'fdo49761.diff' with the name of the patch attached and downloaded from the bug.

        Comment


        • #5
          Originally posted by agd5f View Post
          On 32bit, you can just use ./autogen.sh --prefix=/usr which is equivalent to ./autogen.sh --prefix=/usr --libdir=/usr/lib
          On Ubuntu (and derivatives) you don't need to specify --libdir at all, even on 64-bit as /lib is used there, /lib64 is a symlink.

          Comment


          • #6
            Originally posted by oibaf View Post
            You have to replace 'fdo49761.diff' with the name of the patch attached and downloaded from the bug.
            Thank you oibaf for the help. I thought that patch is automatically downloaded from internet with that command. I thought wrong

            Now I manually downloaded the patch and command works

            Comment


            • #7
              Originally posted by AlbertP View Post
              On Ubuntu (and derivatives) you don't need to specify --libdir at all, even on 64-bit as /lib is used there, /lib64 is a symlink.
              Thank you for clarification So I don't need to run that command on Kubuntu? Because if I run the command I get following output:
              Code:
              snele@KDevil:~/xf86-video-ati$ ./autogen.sh --prefix=/usr
              ./autogen.sh: 9: ./autogen.sh: autoreconf: not found
              Then I installed autogen and autoconf packages and now I get this output:
              Code:
              snele@KDevil:~/xf86-video-ati$ ./autogen.sh --prefix=/usr
              Can't exec "libtoolize": No such file or directory at /usr/bin/autoreconf line 196.
              Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 196.
              autoreconf: Entering directory `.'
              autoreconf: configure.ac: not using Gettext
              autoreconf: running: aclocal 
              configure.ac:34: error: must install xorg-macros 1.8 or later before running autoconf/autogen
              configure.ac:34: the top level
              autom4te: /usr/bin/m4 failed with exit status: 1
              aclocal: /usr/bin/autom4te failed with exit status: 1
              autoreconf: aclocal failed with exit status: 1

              Comment


              • #8
                Make sure you install m4, xutils-dev and libtool packages. Actually, this command may be the most helpful:
                Code:
                sudo apt-get build-dep xserver-xorg-video-ati

                Comment


                • #9
                  Originally posted by DanL View Post
                  Make sure you install m4, xutils-dev and libtool packages. Actually, this command may be the most helpful:
                  Code:
                  sudo apt-get build-dep xserver-xorg-video-ati
                  Thank you. That command did the trick. But now I have new problem with make :
                  Code:
                  snele@KDevil:~/xf86-video-ati$ make
                  make  all-recursive
                  make[1]: Entering directory `/home/snele/xf86-video-ati'
                  Making all in src
                  make[2]: Entering directory `/home/snele/xf86-video-ati/src'
                    CC     ati.lo
                    CC     atimodule.lo
                    CCLD   ati_drv.la
                    CC     radeon_accel.lo
                  radeon_accel.c: In function 'RADEONEngineReset':
                  radeon_accel.c:232:20: warning: variable 'host_path_cntl' set but not used [-Wunused-but-set-variable]
                    CC     radeon_cursor.lo
                    CC     radeon_legacy_memory.lo
                    CC     radeon_driver.lo
                    CC     radeon_video.lo
                  radeon_video.c: In function 'radeon_pick_best_crtc':
                  radeon_video.c:174:2: error: unknown type name 'drmmode_crtc_private_ptr'
                  radeon_video.c:174:42: warning: initialization makes integer from pointer without a cast [enabled by default]
                  radeon_video.c:176:18: error: invalid type argument of '->' (have 'int')
                  radeon_video.c: In function 'RADEONPutImage':
                  radeon_video.c:2894:36: warning: variable 'bpp' set but not used [-Wunused-but-set-variable]
                  radeon_video.c: In function 'RADEONPutVideo':
                  radeon_video.c:3452:53: warning: variable 's2offset' set but not used [-Wunused-but-set-variable]
                  radeon_video.c:3451:17: warning: variable 'pitch' set but not used [-Wunused-but-set-variable]
                  make[2]: *** [radeon_video.lo] Error 1
                  make[2]: Leaving directory `/home/snele/xf86-video-ati/src'
                  make[1]: *** [all-recursive] Error 1
                  make[1]: Leaving directory `/home/snele/xf86-video-ati'
                  make: *** [all] Error 2

                  Comment


                  • #10
                    I builded and installed libdrm from git but it doesn't help. Make gives me same error: http://paste.kde.org/485372/

                    Anyone have idea what's wrong?

                    Comment

                    Working...
                    X