Announcement

Collapse
No announcement yet.

AMD RadeonSI HD 7000 Gallium3D Still Being Raised

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Qaridarium View Post
    :-( this is a complete shame

    in a consumer point of view this is a complete disaster.
    I dissagree, this is open source SOMEONE/S have to program the driver, graphics drivers have always been difficult. and working in within does NOT make it easier.

    maybe used cards from ebay help ?
    Hmmm and have a good possiblilty of getting a card that has been cooked badly from either it or the CPU being overclocked to hell.
    Also I live in a remote area the cost of traveling to look at a card would nearly pay for a new card.

    Comment


    • #17
      [QUOTE=Kano;263540]@Blacksmith

      Do you use debian squeeze (maybe with backports) or wheezy or sid?

      [\QUOTE]

      Three of the machines use stable, one is testing.

      fglrx was already removed from wheezy, it is still in sid. But: sid has xserver 1.12 so fglrx 12-4 would not work. So you could downgrade to wheezy (pin to 1001 or more, then d-u) and use fglrx 12-4 with it. It is just a matter of time till wheezy will get xserver 1.12 and fglrx is impossible - or is there a magical update in the pipe that nobody knows of?
      I have always used the catalyst package as provided by AMD and have never had any probem on install or removing it, remember I have been with Linux for 20 years and there is little i have not seen.

      The machine is use for 3D development work uses a Samsung 305T 2560x1600 monitor, the problem with fglrx on this is the 2D performance is best to say PATHETIC, the redrawing of the background taking around 1/5 of a second. The 3D works great but the 2D performance makes the system unusable inspite of Xorg.log saying 2D accelartion is enabled. The open source driver works great the 2D being first class and the 3D quite up to scratch for the type of work I am doing at this stage in the development, but unfortunately the display locks up with monotonous regularlity using the latest packages from testing. A search on the net appeared to show this was a well known fault with the current series of kernels. I have tried it on 2.6.39.4. 3.0.2 and 3.3.2 did the same on all of them.

      Sadly the Nvidia works perfectly, I say sadly because I way prefer open source, but one has to in the end uses what works. One also can get an older Nvidia card say a GTX 560 whose performance is VERY good quite cheaply these days.

      But in the end open source will win out.

      One aspect the needs to be considered is I do NOT have a decent internet connection living in a relatively remote area, large downloads say installing testing or unstable is something difficult not say VERY expensive for me to do. For the last testing install I downloaded the first 6 cd's from the internet cafe in town 30 kilometres away, this had 95% of what was required downloading the rest no problems . There is a site in Sweden that provides cd's for sid. I may have a crack at those.

      Blacksmith

      Comment


      • #18
        It is definitely no good idea to run those installers on wheezy. Also if you used the nvidia installer you have to uninstall nvidia first. It is better to use the debian packages as you can switch between the drivers very easyly.

        Comment


        • #19
          So far I have had no trouble with the AMD installers on Debian 6.x and I am well aware of the amount of items these installers change, both AMD and Invidia and have always taken great care. I have not tried the debian packages for the closed src driver for some time, the times I have tried it failed to do the job. Note I have not used th Catalyst driver much over the past say 12 months (since I purchased the GTX 560) due to the pathetic 2D performance. How anyone can call it reasonable I do not know.
          I also do not change ANYTHING on the systems unless there is absolutely no other alternative, long experience showing me the more you change the more problems are created.
          I find the 2D performance a bit of a puzzle actually as the 3D is quite good.

          Comment

          Working...
          X