Announcement

Collapse
No announcement yet.

Radeon r300-500 series + oibaf repository

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon r300-500 series + oibaf repository

    Hello there,
    i have X1200 and use oibaf PPA and have a lot of issues with my card. Basic 3D in kwin works, but for games im completely screwed. I have tried Heroes of Newerth (poor performance, UI bugged, particle effects looks like having poor resolution), Penumbra Black Plague (worked out with very low details - when shaders kicks in, textures disappears or GPU locks up) and 0AD (worked out with poor performance at lowest settings for a while, then GPU locked up.
    Anyone else experiencing these issues? I've taken a look on Radeon wiki on Xorg and these games are supposed to work pretty well, so im pretty much confused - is it mesa bug? PPA bug? Card malfunction? Missing feature?

  • #2
    You can try reverting to standard Ubuntu packages to see if you still experience problems.

    Anyway I can say that on my RV530 I also experienced lockups recently, I think it's due to the 12.04 kernel. Unfortunately I still didn't find a way to reliable reproduce the problem. If you found a reliable way to reproduce lockups please open a bug on freedesktop.

    Comment


    • #3
      And lightsmark works properly for you ? I have rendering issues there too.

      Comment


      • #4
        The open source radeon driver has had lock ups since forever. I don't know if it's the same bug but ever since I started using Ubuntu (since like 5.04 on a Radeon 7500 mobility). The r200/r300/r500 drivers have always had a bug where the graphics will randomly freeze or cause xorg to segfault. It had stopped doing that in the last year or so but it seems to have started locking up on my laptop which has an rv515 chip.

        As mentioned it is hard to reproduce since it seems to happen randomly and sometimes my system can run a very long time without it happening.

        Comment


        • #5
          This bug may be related: https://bugs.launchpad.net/ubuntu/+s...rg/+bug/993187

          Comment


          • #6
            Do you all have AGP versions or PCI-E?

            Comment


            • #7
              I have laptop GPU with RS600 chipset. I already reported bug for faulty rendering, lockups are related to this imo. Anyway, with basic 3D (composite desktop) i NEVER had lockup on that machine (though a lot of flickering happens when flash or some image editing kicks in).
              https://bugs.freedesktop.org/show_bug.cgi?id=50149

              Comment

              Working...
              X