Announcement

Collapse
No announcement yet.

R600 Gallium3D LLVM Shader Compiler Hooked Up

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    nice but.... i do not have R600/SI hardware. r600/SI is hd6000 right ?

    and also its openCL only for now and my card hd4770 is in the planet obsolescence to not get openCL support. '

    Comment


    • #12
      The article doesn't say it:
      It needs exactly llvm 3.1. It won't compile with llvm 3.2svn either...

      Comment


      • #13
        Originally posted by cl333r View Post
        Or maybe in the meantime the shaders aren't compiled at all, maybe they're interpreted or read from punch cards.
        You are half-way right!
        http://people.freedesktop.org/~mareko/ir.gif

        r600g doesn't compile shaders to get max potential from the target architecture, it simply retranslates TGSI opcodes for now.

        Comment


        • #14
          Originally posted by Pontostroy View Post
          Useless for now, Unigine heaven shows green screen, lightmark does not render a model of the robot, ET:QW receives a segmentation fault.
          R600_USE_LLVM=0 environment variable does not change anything, LLVM shader compiler is used anyway.
          LLVM sharder compiler doesn't have needed texture support ( OpenCL doesn't need textures).
          I have difficulties compiling mesa master, which LLVM branch/commit are you using?

          Comment


          • #15
            Originally posted by Qaridarium View Post
            nice but.... i do not have R600/SI hardware. r600/SI is hd6000 right ?

            and also its openCL only for now and my card hd4770 is in the planet obsolescence to not get openCL support. '
            http://www.x.org/wiki/RadeonFeature

            R600 = HD2000 HD3000 and HD4000 series. Evergreen = HD5000 and up to the HD6870. Northern Islands = HD6900. Southern Islands = HD7000.

            I know you're a fucking idiot but even you know this, now stop wining about your non issue of your GPU "losing support" when you'll still be able to use it with FGLRX 12.7 for 3-5 years and with the OSS drivers for about a decade or basically till it just up and dies and is no longer worth trying to fix again.

            Comment


            • #16
              Originally posted by Kivada View Post
              http://www.x.org/wiki/RadeonFeature

              R600 = HD2000 HD3000 and HD4000 series. Evergreen = HD5000 and up to the HD6870. Northern Islands = HD6900. Southern Islands = HD7000.

              I know you're a fucking idiot but even you know this, now stop wining about your non issue of your GPU "losing support" when you'll still be able to use it with FGLRX 12.7 for 3-5 years and with the OSS drivers for about a decade or basically till it just up and dies and is no longer worth trying to fix again.
              the tropic is: openCL with the opensource driver. and the "R600 Gallium3D LLVM Shader Compiler" only support hd5000-hd6900

              another list: http://dri.freedesktop.org/wiki/GalliumCompute

              R700 -->OpenCL5 1.0 = N/A6 (6 Only partial OpenCL support is possible, support through vertex shaders. )

              also r600 isn't on the list at all because r600(hd2900) needs full openGL emulation of openCL with all openCL spezific buffers emulated in vram.

              now just tell me why the opensource driver do not support openCL through vertex shaders for r700 and openCL through openGL for the r600 hd2900 ?

              or yes is the new opensource hacker slogan "buy new hardware" instead of "write better code" ?

              Comment


              • #17
                oh great. Q. is in full throttle stupid mode again
                ........................

                Comment


                • #18
                  Originally posted by Drago View Post
                  LLVM sharder compiler doesn't have needed texture support ( OpenCL doesn't need textures).
                  I have difficulties compiling mesa master, which LLVM branch/commit are you using?
                  I use trank LLVM-3.2_svn20120421

                  Lightmark warning message:
                  warning: failed to translate tgsi opcode F2I to LLVM
                  warning: failed to translate tgsi opcode F2I to LLVM
                  et:qw
                  pure virtual method called
                  terminate called recursively
                  terminate called recursively
                  pure virtual method called
                  terminate called recursively
                  pure virtual method called
                  Segmentation fault

                  Comment


                  • #19
                    Originally posted by AnonymousCoward View Post
                    ........................
                    yes yes i know i need to buy new hardware

                    "the new opensource hacker slogan "buy new hardware" instead of "write better code""

                    buy new hardware is always the solution you don't need to write any code you can buy new hardware all the time!

                    and if you do have a bug? buy new hardware!

                    new hardware is really to cheap no one write software anymore they all buy new hardware to fix there problems.

                    Comment


                    • #20
                      Just curious... Is r600 simply not very OpenCL friendly (needing some wierd and ugly hacks?)?

                      (I roll on Evergreen for now)

                      Comment

                      Working...
                      X