Announcement

Collapse
No announcement yet.

RADEON GPU accel not working Debian 6.0.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by bridgman View Post
    Any chance you're missing the HW microcode images ? I think Debian considers them as firmware and leaves them out by default.

    It's hard to tell from the logs if that is the problem because of the gap in dmesg output, but IIRC there are some missing lines. Believe the package name is firmware-linux-nonfree.
    Thank you for the reply, I will have to confirm what is happening here, I do have the non-free firmware on the system and in kernel 2.6.39.1 the KMS code spits out an error if these files are not there. The system is not currently connected up to my network (cannot find a cat5 cable) and this makes it diffcult to debug as one has to ssh into the system to read the kernel log or in this case reboot to another kernel to read the log, very messy when exprimenting. As it seems this should be working I will put a bit more effort in to to get it to go. I was having a bit of abreak as I was not sure if this card should have GPU accelaration support in xserver, I assume from your reply it has.

    A bit of experimenting does not trouble me, back in the early days such work was vital when linux was still fairly new as few were avaible to answer questions. Most Linux users now do not know they are alive .

    Many thanks,
    Blacksmith

    Comment


    • #12
      Originally posted by Blacksmith View Post
      A bit of experimenting does not trouble me, back in the early days such work was vital when linux was still fairly new as few were avaible to answer questions. Most Linux users now do not know they are alive .
      glorious days and I hope it will become a monument for eternity!

      Comment


      • #13
        You can use backports on Debian stable. Right now there are kernel 3.2.15, xorg-server 1.10.4,
        drm 2.4.26, radeon 6.14.2 and mesa 7.10.3.

        All you need to do is to, recompile or even backport some packages for you:

        1. libdrm to 2.4.33 (or git master)
        2. radeon to 6.14.4 (or git master)
        3. mesa 8.0.2 (or git master)

        That way your graphics stack can be mostly recent on Debian Squeeze.

        Comment


        • #14
          Originally posted by Qaridarium View Post
          glorious days and I hope it will become a monument for eternity!
          Yes they were, while Linux is excelent now one must remember in 1992 we were running windows 3.1 which wouid crash if given a dirty look. While the amount of apps availble on Linux was REALLY limited (the whole distributuion plus source code not even filling a single cdrom) it was absolutely bullet proof. The first time I ever ran linux was on a (I think it was a long time ago) a 386 with 8meg of ram. The distribution was Ygdrasil and had a demo mode, which would start the xserver, then called X386, and play some tunes, run a video of a girl with a hula hoop amongst other things. You couild see it trying to start apps and failing due to the very small amount or ram, but it did not crash absolutely amazing. I still think its one of the best computer demos I have every seen.

          I still have the 2nd version of Linux I every had, basicly unusable now due to the major changes over the years to the ide driver.

          Blacksmith

          Comment


          • #15
            Originally posted by dungeon View Post
            You can use backports on Debian stable. Right now there are kernel 3.2.15, xorg-server 1.10.4,
            drm 2.4.26, radeon 6.14.2 and mesa 7.10.3.

            All you need to do is to, recompile or even backport some packages for you:

            1. libdrm to 2.4.33 (or git master)
            2. radeon to 6.14.4 (or git master)
            3. mesa 8.0.2 (or git master)

            That way your graphics stack can be mostly recent on Debian Squeeze.
            Thank you for the reply, the problem though is with the kernel, the kms code not starting correctly, given that R600 KMS code for the Radeon 3870 apparently works so well it must be something in the install. This could only really be the micro code, as during the kernel startup very little of the system is active. The micro code used is not from the debian packaging system. which may be the problem. I do have the latest non-free firmware deb so I will install that and see what happens.

            Blacksmith

            Comment


            • #16
              Sorry for the delay in the update..........

              The problem was an incorrect directory structure in /lib/firmware, the radeon directory not being there, works great now. A couple of points might be worth mentioning, first this is definitely a problem I have had before and I simply forgot the remedy, one has done so much expirmenting over the years. The second point is the reason for the incorrect structure is I have not got an internet connection capable of installing any version of Linux, being still on dialup, this makes the installation particularly of an updated version of Debian difficult.

              The test machine is working well, I will give it a little more work and I will consider upgrading my main machines to Debian testing, one of them anyway.

              Thanks everyone for your help its been much apreciated,
              Blacksmith
              Last edited by Blacksmith; 05-04-2012, 12:43 AM.

              Comment


              • #17
                Since I have got the GPU accelration working the display has been locking up very regularly. The cursor is still active but nothing can draw into the display and the keyboard does not work. One can ssh into the machine and reboot it no problems. A search on the net shows this is a known problem and it seems the kernel is the villian of the piece. With any kind of luck 3.4 will fix the problem. At least one work around was given (kernel command line that disabled a number of things) I have not treid it though. At this stage just set up an xorg.conf that uses fbdev, as this is a test machine this is a non issue.

                Comment

                Working...
                X