Announcement

Collapse
No announcement yet.

MESA 8.1 (Git-Oibaf) is broken for games right now testet with oilrush+arma2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by oibaf View Post
    The version with the fix is still building, wait for an hour or so...
    the ppa still do not have newer files to fix this ...

    Comment


    • #12
      Originally posted by oibaf View Post
      The version with the fix is still building, wait for an hour or so...
      just for the record its still broken or maybe the build process was not successful ?

      Comment


      • #13
        Q, try setting R600_STREAMOUT to 0.

        Comment


        • #14
          Originally posted by DaemonFC View Post
          That would probably be fallout from the llvm 3.0 libraries. I've encountered some nasty bugs when building against them. That's the biggest change that he's listed in his build process lately.
          If DaemonFC is right, you can try starting game from console using:
          DRAW_USE_LLVM=0 game

          Like (just my guesses):
          DRAW_USE_LLVM=0 oilrush
          DRAW_USE_LLVM=0 arma2

          There is some know problem with LLVM, you can take a look at:
          http://llvm.org/bugs/show_bug.cgi?id=12151 (the right place)
          http://bugs.winehq.org/show_bug.cgi?id=29786 (cross-report)
          https://bugzilla.novell.com/show_bug.cgi?id=747333 (cross-report)

          Comment


          • #15
            Originally posted by pingufunkybeat View Post
            Q, try setting R600_STREAMOUT to 0.
            wow thank you this works for oilrush.

            i just reinstall the ppa and test your way and it works.

            Comment

            Working...
            X