Announcement

Collapse
No announcement yet.

Radeon HyperZ In Open-Source On Older Hardware

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by keivan View Post
    I have one of those r300 cards and I want to test HyperZ. Is there anybody knows how to enable it?
    Thanks in advance
    Edit: first make sure you have the latest git code, as there are known bugs otherwise.

    set the env var RADEON_HYPERZ and run piglit with parameters: -c 0

    r500 hardware defaults on, r300/r400 need the environment variable set.

    To double check it's on, watch stdout of the GL application for "radeon: Acquired Hyper-Z." And apparently the hardware only supports 1 app at a time with HyperZ, so make sure you aren't running more than 1. (compositors for desktop graphics are blacklisted).
    Last edited by smitty3268; 12-02-2012, 11:28 PM.

    Comment


    • #12
      Edit: first make sure you have the latest git code, as there are known bugs otherwise.

      set the env var RADEON_HYPERZ and run piglit with parameters: -c 0

      r500 hardware defaults on, r300/r400 need the environment variable set.

      To double check it's on, watch stdout of the GL application for "radeon: Acquired Hyper-Z." And apparently the hardware only supports 1 app at a time with HyperZ, so make sure you aren't running more than 1. (compositors for desktop graphics are blacklisted).
      RADEON_HYPERZ = 1
      It was amazing!! Thanks. WAW!!
      I'm not a gammer. I just need to enable this for unity or firefox. Is there a workaround for this?

      Comment


      • #13
        Originally posted by keivan View Post
        RADEON_HYPERZ = 1
        It was amazing!! Thanks. WAW!!
        I'm not a gammer. I just need to enable this for unity or firefox. Is there a workaround for this?
        Well, you can rename the executable to avoid the blacklist, or you can edit the list directly here: http://cgit.freedesktop.org/mesa/mes...dcf0e0c3680688

        Marek seemed to think desktop compositors didn't even trigger the z clears that hyperz gets activated on, but that Firefox did.

        Comment


        • #14
          The motivation behind the blacklist is that Hyper-Z should be turned on for games and benchmarks while there is firefox and a compositor running in the background.

          I think Hyper-Z for firefox is useless if you don't use WebGL.

          Comment


          • #15
            Is there a way to disable it, just for benchmarking? RADEON_HYPERZ=0 seems to not work.

            Comment


            • #16
              Originally posted by marek View Post
              The motivation behind the blacklist is that Hyper-Z should be turned on for games and benchmarks while there is firefox and a compositor running in the background.

              I think Hyper-Z for firefox is useless if you don't use WebGL.
              First of all, let me tell you that I really appreciate your works. In my case performance boost was more than what is shown in this benchmarks.

              However, I think it would be more appropriate to have some options other than what you think should be the default options for the most of the users. We live in the GNU word. There is always some specific conditions that a user, like me, wants to have non-default settings.

              In my case, I have turned on the power management options, and because of that performance of Firefox's smooth scrolling is poor.

              Comment


              • #17
                keivan> Firefox won't benefit from Hyper-Z unless you are running some WebGL app. Hyper-Z only improves perfomance in the 3D apps which use a zbuffer and only if the bottleneck is bandwidth.

                oibaf> To turn off Hyper-Z, set: RADEON_DEBUG=nozmask,nohiz

                Comment


                • #18
                  Thanks for the reply, I'll test tomorrow.

                  Interestingly it looks this started with a problem detected by Coverity, so leaving bugged features merged but disabled has some usefulness.

                  This pages should also be updated:

                  Comment


                  • #19
                    Originally posted by oibaf View Post
                    Unfortunately xorg wiki editing is disabled at the moment due to the amount of spam.

                    Comment


                    • #20
                      Originally posted by marek View Post
                      oibaf> To turn off Hyper-Z, set: RADEON_DEBUG=nozmask,nohiz
                      I tested 0 A.D. and openarena but with my RV530 I wasn't able to notice any performance difference at all. openarena also didn't print the 'radeon: Acquired Hyper-Z.' message.

                      Comment

                      Working...
                      X