No announcement yet.

Evergreen HDMI audio success, need testers

  • Filter
  • Time
  • Show
Clear All
new posts

  • Evergreen HDMI audio success, need testers

    I've added support for HDMI audio support on my Evergreen 1002:9806. It works great for me, however to make it work on all Evergreens I need dumps from other machines.

    Who can help?
    Anyone with:
    1) Evergreen GPU
    2) Audio capable TV/monitor
    3) Knowledge to checkout, modify and compile radeontool
    4) Courage to install fglrx

    How to help?
    Let's start with the installation of radeontool (it contains avivotool we will use).
    git checkout git://
    cd radeontool
    git am 0001-avivotool-dump-0000-e000-as-all-on-Evergreen.patch
    ./ && make && sudo make install
    After that you've to install fglrx, connect audio capable TV/monitor and play some music over HDMI. While playing music (make sure it works, that you hear it), execute the following:
    avivotool regs all > fglrx.txt

    That's it. Please provide me via e-mail following info:
    1) lspci -nn | grep VGA
    2) dmesg | grep drm
    3) fglrx.txt
    Last edited by Zajec; 12-04-2011, 07:08 AM.

  • #2
    The instructions should say "git clone" and not checkout.

    Will provide you with the regs, would be wonderful to finally be able to make use of my radeon card!


    • #3
      As soon as i arrive home i'll do it . Anywhere on IRC tonight so i test and feedack interactively? I'm GMT+1


      • #4
        Originally posted by admiral0 View Post
        As soon as i arrive home i'll do it . Anywhere on IRC tonight so i test and feedack interactively? I'm GMT+1
        You can try to catch me on #radeon channel, but I'll be traveling from my parent's house today. Can be late on IRC or not at all (hopefully tomorrow will find some time).


        • #5
          Thank you for your work.


          • #6

            What e-mail address should I mail the dumps to?

            Also, s/git checkout/git clone/ ;-P

            Thanks so much for your great work!


            • #7
              Originally posted by Aquous View Post
              What e-mail address should I mail the dumps to?
              zajec5 at gmail please

              Originally posted by Aquous View Post
              Also, s/git checkout/git clone/ ;-P
              Whoops, that's right, thanks.


              • #8
                Originally posted by Zajec View Post
                zajec5 at gmail please
                mail sent


                • #9
                  error segment :-(

                  i have radeon 5450 :-)

                  only this
                  02:00.0 VGA compatible controller [0300]: ATI Technologies Inc Cedar PRO [Radeon HD 5450] [1002:68f9]

                  vincenzo@vincenzo-System-Product-Name:~$ dmesg | grep drm
                  vincenzo@vincenzo-System-Product-Name:~$ avivotool regs all > fglrx.txt
                  mapping ctrl region
                  Errore di segmentazione
                  Last edited by Vincenzov; 12-04-2011, 09:50 AM.


                  • #10
                    OK after command sudo :-)


                    • #11
                      This is not safe.

                      Running as a normal user, I also got segmentation fault, strace told me it was because of lack of permissions to a sysfs-file, so I ran it as root.

                      Instant system lockup and after a reboot, my ethernet controller was broken.

                      Rebooted the system, no change.

                      Powered off the system, removed power cord, let it be for a while, powered on.

                      Took about 15-20 seconds until it started after powering on, ethernet controller back.

                      Tried again with another fglrx, same freeze.

                      I have yet to be able to get the computer to boot (even just spin up the fans before bios).

                      The power led just keeps blinking and sometimes manages to start spinning up the fans until it dies again and get stuck in a loop.


                      • #12
                        Originally posted by Vincenzov View Post
                        error segment :-(
                        I guess this should read "Segmentation Fault"


                        • #13
                          hehehehe ok :-)


                          • #14
                            Good work,

                            so all the other drivers (intel, nouveau) seem to pass the ELD stuff into the hardware at some point, not sure if you can work out from radeontool or you need more tracing to see if this happens on ATI hw.


                            • #15
                              If anyone needs the radeontool rpm, the latest version (1.6.2) is here: