Announcement

Collapse
No announcement yet.

No HDMI sound after upgrade to Kubuntu 11.10 with my hd4770

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

    after sudo update-grub2
    workssssssssssssss

    thanks

    Comment


    • #22
      why does the same functionality works with the catalyst ?

      in my point of view this can't be the source if the catalyst do not have the same black screen ...

      maybe they build an magic auto-detect ?

      Comment


      • #23
        i dont use catalyst, ati free. I have 785g (radeon hd 4200) and hdmi work good with this grub patch.

        Comment


        • #24
          Originally posted by ooHe0Eejem1 View Post
          why does the same functionality works with the catalyst ?

          in my point of view this can't be the source if the catalyst do not have the same black screen ...

          maybe they build an magic auto-detect ?
          its not a magic autodetect its a DRM UVD shit some displays force you to use this shit.

          Comment


          • #25
            No HDMI sound on ATI Radeon HD 5700 Series

            Hello,

            I'm on Arch Linux 64bit and use the open source radeon driver.

            Unfortunately I switched to the latest kernel *and* from proprietary catalyst driver to open source radeon driver, so I can't say whether it worked before the new kernel with the open source driver.

            lspci recognises the audio as
            Code:
            01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
            and I enabled radeon.audio=1 in menu.lst
            Code:
            kernel /boot/vmlinuz26 root=/dev/disk/by-uuid/f16ef16a-2e5c-4725-97e0-9ae1f947c86f ro radeon.modeset=1 radeon.agpmode=-1 radeon.audio=1
            but I can't play back audio. When I try, the audio software plays back at incredible speed and no sound is there. mplayer, vlc, audacity, paplay, aplay, speaker-test all show the same behavior.
            pavucontrol however indicates a level change in the audio volume.

            My card is an Evergreen model and http://www.x.org/wiki/RadeonFeature indicates that HDMI audio is not supported for them. Although shouldn't lspci not be able to see it then?

            Comment


            • #26
              No, lspci devices always appear regardless of the driver used. The HDMI audio is just detected as a seperate chip, which also needs a driver to be loaded. It seems like Juniper HDMI Audio is not yet supported by snd-hda-intel.

              Comment


              • #27
                I'm currently experiencing the exact same as `qubodup`. I did add `radeon.audio=1` and ran update-grub, but it still doesn't work. Furthermore, audio plays at incredible speed (like qubodup reported).

                Is there a know fix for this behaviour?

                Comment

                Working...
                X