Announcement

Collapse
No announcement yet.

R600g Now Works With Xorg State Tracker

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by drag View Post
    You just make it.

    sudo mkdir -p /etc/adobe/
    echo "OverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg

    http://blogs.adobe.com/penguinswf/20...fg_file_1.html
    Thanks!

    10 char limit

    Comment


    • #12
      Just tried with 6870;

      skewed mouse pointer
      gnome-settings-daemon cant start

      Comment


      • #13
        Originally posted by RealNC View Post
        How do you use that anyway? Is it an xorg.conf tweak?
        I was wrong in previous comment.
        Driver "r600g" in xorg.conf

        I tried with 4850.
        Big striped mouse cursor in KDE 4.7, on screenshot all ok.

        Comment


        • #14
          Sort of works here (RS780). No corruption but 2D accel seems to be disabled by default, have to add Option "2DAccel" "on" to xorg.conf. With 2D accel enabled there's some corruption and a lot of spam in xorg.log

          Code:
          R600G(0): xorg_composite_accelerated fallback Component alpha not supported with source alpha and source value blending. (op=3)
          It's also slower than regular ddx and doesn't seem to have all the xrandr options the regular ddx has. (e.g. missing option to set underscan)

          Comment


          • #15
            Originally posted by monraaf View Post
            but 2D accel seems to be disabled by default,
            /var/log/Xorg.0.log
            Code:
            [    17.306] (II) R600G(0): #################################
            [    17.306] (II) R600G(0): # Useful debugging info follows #
            [    17.306] (II) R600G(0): #################################
            [    17.306] (II) R600G(0): Using Gallium3D backend
            [    17.306] (II) R600G(0): 2D Acceleration is disabled
            [    17.306] (II) R600G(0): Fallback debugging is disabled
            [    17.306] (--) R600G(0): 3D Acceleration is enabled
            [    17.306] (==) R600G(0): Swap Throttling is enabled.
            [    17.306] (==) R600G(0): Dirty Throttling is disabled.
            [    17.306] (II) R600G(0): ##################################
            Radeon HD4850.

            Comment


            • #16
              Have just a mouse cursor bug there. And that bug affect dual screen support....
              Enabling Software mouse fix it.

              [ 1741.350] (II) R600G(0): [XvMC] Associated with Gallium3D Textured Video.
              [ 1741.350] (II) R600G(0): [XvMC] Extension initialized.
              [ 1741.350] (II) R600G(0): [DRI2] Setup complete
              [ 1741.350] (II) R600G(0): [DRI2] DRI driver: r600
              [ 1741.350] (II) R600G(0): #################################
              [ 1741.350] (II) R600G(0): # Useful debugging info follows #
              [ 1741.350] (II) R600G(0): #################################
              [ 1741.350] (II) R600G(0): Using Gallium3D backend
              [ 1741.350] (II) R600G(0): 2D Acceleration is enabled
              [ 1741.350] (II) R600G(0): Fallback debugging is enabled
              [ 1741.350] (--) R600G(0): 3D Acceleration is enabled
              [ 1741.350] (==) R600G(0): Swap Throttling is enabled.
              [ 1741.350] (==) R600G(0): Dirty Throttling is disabled.
              [ 1741.350] (II) R600G(0): ##################################
              [ 1741.350] (==) R600G(0): Backing store disabled
              [ 1741.350] (==) R600G(0): Silken mouse enabled

              Comment


              • #17
                Originally posted by monraaf View Post
                Sort of works here (RS780). No corruption but 2D accel seems to be disabled by default, have to add Option "2DAccel" "on" to xorg.conf. With 2D accel enabled there's some corruption and a lot of spam in xorg.log

                Code:
                R600G(0): xorg_composite_accelerated fallback Component alpha not supported with source alpha and source value blending. (op=3)
                The same thing here, but I don't find it any slower than before. However, I'm a bit disappointed because of this:

                [ 2951.342] (WW) R600G(0): Option "ColorTiling" is not used
                [ 2951.342] (WW) R600G(0): Option "RenderAccel" is not used
                [ 2951.342] (WW) R600G(0): Option "AccelMethod" is not used
                [ 2951.342] (WW) R600G(0): Option "DRI" is not used
                [ 2951.342] (WW) R600G(0): Option "SubPixelOrder" is not used
                [ 2951.342] (WW) R600G(0): Option "EnablePageFlip" is not used
                [ 2951.342] (WW) R600G(0): Option "SwapbuffersWait" is not used
                Does this means I now don't have Page Flipping?

                Comment

                Working...
                X