Announcement

Collapse
No announcement yet.

Starcraft 2 on Fedora 15 with FOSS Radeon Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Starcraft 2 on Fedora 15 with FOSS Radeon Driver

    Hi all!

    Just tried to do a fresh install of Starcraft 2 on Crossover Games 10.1.1, finding out how Starcraft 2 is doing with the FOSS Radeon Driver since some people report WOW being playable with it!

    I can report:

    - The Installation worked flawless
    - Game starts without any error
    - Main Menu looks perfect
    - Matches start without any error
    - Maps are mainly blank, but I could command the WBFs to harvest minerals and I saw the Commandocenter
    - performance at lowest graphic settings was smooth (45FPS)

    Looks very very promising and it was much better as I expected!!!
    Maybe with some tweaks you can get much better results and I am optimistic that on Linux Gaming we can say goodbye to fglrx soon!

    Fedora 15
    Kernel 2.6.38.8-35.fc15.i686.PAE
    4 GB RAM
    Intel(R) Core(TM)2 Quad CPU Q9300 @ 2.50GHz

    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD RV770 Radeon HD 4870 1GB VideoRAM
    OpenGL version string: 2.1 Mesa 7.11-rc1
    OpenGL shading language version string: 1.20

  • #2
    Do install the s3tc lib, if you haven't yet.

    Comment


    • #3
      Yes, blank maps usually imply missing textures.

      Fixing this might bring down the frame rate too.

      Comment


      • #4
        Hey!

        Thank you so much for the hint with s3tc libs!

        Starcraft 2 is working now perfectly and on the lowest graphic settings its is more than playable...
        I just finished a multiplayer match without any problems at 30-35FPS!

        The next thing I am gong to do is to bring this Information into the Crossover Games Howtos...

        Great work of the FOSS Radeon Developers!!!

        Claus

        Comment


        • #5
          I played through the demo with r300g and last time I checked with r600g everything was working fine. Performance is lacking, but that's nothing new.

          Most things that's working with Wine and proprietary drivers seems to work with r600g, Fallout 3 and Crysis just to name a few.

          Comment


          • #6
            I had some problems with FPS dropping down to 1fps. It would act like it just got 'stuck' at 1fps. It would cause the game to start lagging for other people, which is unfortunate. I tried the ATI proprietary drivers, but those things broke my desktop and performance was barely better.

            With PlayOnLinux and the 1.3.25 Wine release it solved this issue for me. Unfortunately it broke my audio. It would cut out randomly about 2-20 minutes into the game. This was due to conflicts between Wine and pulseaudio, which is unfortunate. I am not going back to using just Alsa... it's far too miserable and I use Mumble. Trying to manage multiple audio outputs and mic without PA is just too hateful to contemplation. I know how to do it, but I am just not going to put up with it.

            With PlayOnLinux and 1.3.26, however, now things finally are looking up. The system is stable and performance is acceptable enough to play against other people (and kick their asses)

            Comment


            • #7
              its a little offtopic, but can anybody point me to a howto for installing the latest drivers and mesa and whatnot on fedora?

              Comment


              • #8
                Pulseaudio and Wine

                Originally posted by drag View Post
                With PlayOnLinux and the 1.3.25 Wine release it solved this issue for me. Unfortunately it broke my audio. It would cut out randomly about 2-20 minutes into the game. This was due to conflicts between Wine and pulseaudio, which is unfortunate. I am not going back to using just Alsa... it's far too miserable and I use Mumble. Trying to manage multiple audio outputs and mic without PA is just too hateful to contemplation. I know how to do it, but I am just not going to put up with it.
                Wine does not officially support Pulseaudio (PA), but there are patches which bring support for it. Gentoo has USE-flag for inclusion of PA-support and it is working perfectly for me. Ubuntu probably includes the same patches.

                Wine is aiming for OpenAL -support which PA offers and AFAIK it should bring end to the soundsystem woes.

                Comment


                • #9
                  For a minor performance improvement, with Wine 1.3.27 try setting the "AlwaysOffscreen" Direct3D registry setting to "enabled". It avoids a fallback in the driver related to depth copies. The same setting exists in CrossOver Games, but for an unfortunate reason the value to enable it is "enable" instead of "enabled".

                  Comment


                  • #10
                    I hope this is considered on topic, otherwise I'll go start a new thread.

                    When I tried playing Starcraft 2 with wine on the FOSS driver, it crashes with an error message saying something out my "Nvidia 5500" isn't supported. I don't recall the exact model, but it's an extremely old GPU, that I don't have. Looking at the wine output, it looks like wine doesn't find a GPU at all, and maybe SC2 is just "defaulting" to the oldest GPU it knows about.

                    Is there something I've missed if you other can get this running and I can't? Other things work fine, such as desktop effects, and I installed "extreme tuxracer" to see that 3d rendering otherwise works as it should.

                    Comment

                    Working...
                    X