Announcement

Collapse
No announcement yet.

[vgaswitcheroo] Problem with card Intel/ATI

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [vgaswitcheroo] Problem with card Intel/ATI

    Hi,

    (Sorry for my english.)

    I have buy a laptop (HP Pavilion dv7-6090ef) with 2 graphics cards

    The result of the command "cat /sys/kernel/debug/vgaswitcheroo/switch" is
    Code:
    0:DIS: :Pwr:0000:01:00.0
    1:IGD:+:Pwr:0000:00:02.0
    If i use the command "echo OFF > /sys/kernel/debug/vgaswitcheroo/switch", the result is :
    Code:
    0:DIS: :Off:0000:01:00.0
    1:IGD:+:Pwr:0000:00:02.0
    If i use the command "echo DIS > /sys/kernel/debug/vgaswitcheroo/switch", the laptop freeze. The /var/log/messages :
    Code:
    kernel: [   51.431992] fbcon: Remapping primary device, fb0, to tty 1-63
    kernel: [   51.432259] i915: switched off
    kernel: [   65.405216] SysRq : Emergency Sync

    The kernel : 2.6.38-gentoo-r6 and 2.6.39-gentoo.

    I don't understand why the laptop frozen.

    Thanks.

  • #2
    no trail to solve the problem ?

    Comment


    • #3
      Well, there's your problem

      Originally posted by Ackak View Post
      If i use the command "echo DIS > /sys/kernel/debug/vgaswitcheroo/switch", the laptop freeze. The /var/log/messages :
      Code:
      kernel: [   51.431992] fbcon: Remapping primary device, fb0, to tty 1-63
      kernel: [   51.432259] i915: switched off
      kernel: [   65.405216] SysRq : Emergency Sync
      Well, there's your problem. DIS tells the kernel to immediately switch the card in use, so the display is still pointing at the other one. Instead of DIS, use DDIS (Delayed DIScrete), which will wait until the X server is restarted to switch the card in use. At present, it is impossible to seamlessly switch between the cards in linux. To restart the X server, either simply logout (if you're using gdm), restart your display manager, or hit Ctrl + Alt + Delete (if that shortcut is enabled)

      Comment


      • #4
        Thanks for your response.

        I have make the test with DDIS and i have the same bugs.

        I have post in the kernel bugzilla and i must wait development of Xorg
        http://bugzilla.kernel.org/show_bug.cgi?id=37362

        Comment

        Working...
        X