Announcement

Collapse
No announcement yet.

DVI output not working with radeon on RV610

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DVI output not working with radeon on RV610

    Hi, I have an RV610 card attached to an LG 22LH2000. The LG 22LH2000 has a 1366x768 native resolution and does have VGA and HDMI but not DVI. The Radeon HD2400 does have VGA and DVI but not HDMI, so I'm using a DVI-HDMI converter.
    When I use the VGA output everything works fine, but I don't get a 1:1 pixel mapping because I have to set a 1360x768 or 1368x768 resolution and the monitor is not smart enough when using vga. Instead when I attach the monitor to my laptop's Intel GMA45 HDMI output I can get a 1:1 pixel mapping even using a 1360x768 resolution.
    Unfortunately when using the HD2400 DVI output the monitor does not show anything, at least after loading the radeon module. In fact when loading the bios or starting grub the DVI output works flawlessly. nomodeset does not help. I even tried setting another resolution with xrandr (it automatically set 1920x1080i, but I tried 1360x768, 1280x800, 1024x768 and 800x600 and it still does not work).

    Distro is Debian Unstable amd64 with kernel 2.6.39 and xorg-edgers ppa.
    It's the only monitor I will be able to use for a couple of months, it's critical for me to get it working.

    Thank you
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

  • #2
    Please file a bug (https://bugs.freedesktop.org) and attach your xorg log and dmesg output.

    Comment


    • #3
      https://bugs.freedesktop.org/show_bug.cgi?id=38010

      Filed the bug at 14:13:06 PDT, solved at 14:13:06 PDT
      ## VGA ##
      AMD: X1950XTX, HD3870, HD5870
      Intel: GMA45, HD3000 (Core i5 2500K)

      Comment


      • #4
        It looks that you attached the same tv on vga and dvi? It seems that the radeon driver added some extra modes when audio is detected. fglrx enables underscan when audio is available - the win driver too btw. Must be fun to check for audio capabilities to trigger some settings nobody really wants to use...

        Comment


        • #5
          Originally posted by Kano View Post
          It looks that you attached the same tv on vga and dvi? It seems that the radeon driver added some extra modes when audio is detected.
          The radeon driver doesn't add any different modes for DVI vs VGA vs HDMI. TV's generally have different EDIDs depending on the input used. Depending on the TV, VGA often only has a limited number of modes (generally 1024x786 for PC capability) or no EDID at all in some cases; DVI usually has the native mode and a few PC compatibility modes, and HDMI usually has the native mode and a bunch of HDTV modes defined in CEA EDID extension blocks.

          The behaviour of the TV can also vary depending on the input used. Some TV's overscan all inputs by default (hence the drivers offering underscan modes), sometimes with no way to disable it, others only overscan HDMI, etc.

          Comment

          Working...
          X