Announcement

Collapse
No announcement yet.

Chromium and fireox 4 no webgl with r600g

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chromium and fireox 4 no webgl with r600g

    hi there since like a month ago webgl stopped working with both browsers, so im not sure if this is cuz a change on the egl libraries or the way im building mesa git. So ill post my bash (very simple but it works) so in case is my fault someone can tell me what im doing wrong XD

    -----------------------------------------------------------------------------------
    export R600_ENABLE_S3TC=1
    make distclean
    export CFLAGS="-m32"
    export CXXFLAGS="-m32"
    ./configure --prefix=/usr USE_EXTERNAL_DXTN_LIB=1 --enable-shared-dricore --enable-gles1 --enable-gles2 --enable-openvg --enable-xcb --enable-gallium-egl --enable-gl-osmesa --enable-gallium-swrast --enable-gallium-r600 --with-dri-drivers=swrast --with-egl-platforms="x11,drm" --build=i686-pc-linux-gnu --libdir=/usr/lib32
    make -j16
    sudo make install
    make distclean
    export CFLAGS="-O3 -g0 -mtune=amdfam10 -mmmx -msse -msse2 -msse3 -mfpmath=sse -msseregparm -pipe -ffast-math -fexpensive-optimizations -ftree-loop-linear -floop-interchange -floop-block -floop-strip-mine -fgraphite-identity -ftree-loop-distribution -fivopts -m64"
    export CXXFLAGS="-O3 -g0 -mtune=amdfam10 -mmmx -msse -msse2 -msse3 -mfpmath=sse -msseregparm -pipe -ffast-math -fexpensive-optimizations -ftree-loop-linear -floop-interchange -floop-block -floop-strip-mine -fgraphite-identity -ftree-loop-distribution -fivopts -m64"
    ./configure --prefix=/usr USE_EXTERNAL_DXTN_LIB=1 --enable-shared-dricore --enable-gles1 --enable-gles2 --enable-openvg --enable-xcb --enable-gallium-egl --enable-gallium-llvm --enable-gl-osmesa --enable-gallium-r600 --with-dri-drivers=swrast --with-egl-platforms="x11,drm"
    make -j16
    sudo make install
    make distclean

    -----------------------------------------------------------------------------------

    don't mind the custom cflags cuz i tested without them too and i like to test creepy cflags XD

    thx in advance

  • #2
    Don't know about Chromium, but you don't need EGL to use WebGL with Firefox. Firefox will do just fine with regular GL libs. For Firefox you just have to add some environment variable to circumvent the blacklist.

    Comment


    • #3
      FWIW, the envvar is MOZ_GLX_IGNORE_BLACKLIST, and like moonraf said EGL isn't needed, neither is ES1/2. Chances are that you can drastically cut down on all the configure options unless you know you really need it.

      I usually use something like this for r300g:
      --with-dri-drivers=r300 --enable-gallium-radeon --disable-egl --disable-glu --disable-glw --disable-glut --prefix=/home/foo/mesa/

      Comment


      • #4
        When I run Chromium with the following arguments it works for me:

        Code:
        --enable-webgl --ignore-gpu-blacklist
        You can check the GPU acceleration status in Chromium under chrome://gpu/

        Comment


        • #5
          Originally posted by runeks View Post
          When I run Chromium with the following arguments it works for me:

          Code:
          --enable-webgl --ignore-gpu-blacklist
          You can check the GPU acceleration status in Chromium under chrome://gpu/
          works for me


          at chrome experiments the quake map rendering is however pretty slow (at low energy profile ! :P , so at high profile it should be somewhat fine)

          and there were some significant display errors at some other chrome experiments or webgl accelerated content - don't know which anymore ...

          once I run again into it I'll post the address to it

          Comment

          Working...
          X