Announcement

Collapse
No announcement yet.

Can't enable Gallium3D on R700 (4650)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't enable Gallium3D on R700 (4650)

    Hi,

    I can't enable Gallium3D on my system. System Specs:

    Distro: Ubuntu 10.10 (Linux Mint 10)

    Kernel: 2.6.37-020637-generic

    xorg-edgers PPA added, Mesa 7.11-git, xf86-video-ati 6.13.99

    When I add Option "ForceGallium" "True" in xorg.conf, Xorg log says Option "ForceGallium" not used.

    Another question: How can I install 2.6.38? Latest kernel build in kernel ppa is 2.6.37-999

    Any help will be appreciated.

  • #2
    Hello,

    you should build mesa with --enable-gallium-r600 to activate gallium driver, and you don't need to use that option in xorg.conf.

    Comment


    • #3
      Originally posted by lucx View Post
      Hello,

      you should build mesa with --enable-gallium-r600 to activate gallium driver, and you don't need to use that option in xorg.conf.
      Thanks. Turns out that the newest mesa/radeon in xorg-edgers lost that option. However, I installed the packages from xorg-edgers/radeon and gallium was enabled by default.

      Comment


      • #4
        I have the xorg-edgers/ppa and xorg-edgers/radeon ppas. I think gallium is enabled but I'm not sure. What I do know is that programs don't run as well with gallium as they did last month. Am I doing something wrong?

        Comment


        • #5
          Originally posted by JDShu View Post
          I have the xorg-edgers/ppa and xorg-edgers/radeon ppas. I think gallium is enabled but I'm not sure. What I do know is that programs don't run as well with gallium as they did last month. Am I doing something wrong?
          Remove /ppa and leave just /radeon. Or better yet, remove both of them, then add /radeon and you should have gallium on by default. Tried that yesterday evening, it was working fine. Tried it with Penumbra Overture, huge performance gain.

          Comment


          • #6
            Thank you! Works perfectly now

            Exciting times ahead for radeon oss drivers.

            Comment


            • #7
              Hello,

              to be shure that you have gallium driver build do an:

              glxinfo | grep "OpenGL"

              and you should not have something like this :


              glxinfo |grep "OpenGL"
              OpenGL vendor string: Tungsten Graphics, Inc
              OpenGL renderer string: Mesa DRI Mobile IntelĀ® GM45 Express Chipset GEM 20100330 DEVELOPMENT x86/MMX/SSE2
              OpenGL version string: 2.1 Mesa 7.11-devel
              OpenGL shading language version string: 1.20
              OpenGL extensions:


              this is just classic mesa, with galluim you will see something with "OpenGL version Gallium 0.4"

              Comment


              • #8
                What about us that are on Natty?

                Comment


                • #9
                  Originally posted by zika View Post
                  What about us that are on Natty?
                  Sacrificed midory and epiphany, re-installed xserver-xorg-input-{all,synpatics} and, voila, 1.9.99.901...
                  Thank You xorg-edgers...

                  Comment


                  • #10
                    When we can expect to see Gallium for Natty?

                    Comment


                    • #11
                      Originally posted by dekomote View Post
                      Remove /ppa and leave just /radeon. Or better yet, remove both of them, then add /radeon and you should have gallium on by default. Tried that yesterday evening, it was working fine. Tried it with Penumbra Overture, huge performance gain.
                      I set up Gallium using the /ppa. I couldn't find any examples of an xorg.conf for this, and I found that getting the syntax wrong causes X to refuse to start. This /etc/xorg.conf works for me:

                      Section "Device"
                      Identifier "Default screen"
                      Option "ForceGallium" "True"
                      EndSection

                      Comment


                      • #12
                        Originally posted by joolsa View Post
                        I set up Gallium using the /ppa. I couldn't find any examples of an xorg.conf for this, and I found that getting the syntax wrong causes X to refuse to start. This /etc/xorg.conf works for me:

                        Section "Device"
                        Identifier "Default screen"
                        Option "ForceGallium" "True"
                        EndSection
                        I tried that, it didn't work for me. However the /radeon ppa worked.

                        Comment


                        • #13
                          Originally posted by joolsa View Post
                          I set up Gallium using the /ppa. I couldn't find any examples of an xorg.conf for this, and I found that getting the syntax wrong causes X to refuse to start. This /etc/xorg.conf works for me:

                          Section "Device"
                          Identifier "Default screen"
                          Option "ForceGallium" "True"
                          EndSection
                          Cool! It works! Thank You!
                          (Natty, 2.6.38-rc1, ATI HD3650)

                          Comment


                          • #14
                            It worked for me too, thanks!

                            Comment

                            Working...
                            X