Announcement

Collapse
No announcement yet.

How to use xf86-video-ati with HD6850 (with KMS)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to use xf86-video-ati with HD6850 (with KMS)

    I'm a owner of Radeon HD 6850 and use only linux (expect for games and some video authoring and conversions). The FGLRX driver did not work for me, when I login, the gnome-panel appears filled with artifacts, blinking, and with the logo "unsupported".

    I think I can give my feedback about the work on xf86-video-ati and kernel kms posting here how I'm doing this.

    -First step I've done was download the snapshot from drm-radeon-testing kernel, patched with KMS support for Barts chip:
    http://git.kernel.org/?p=linux/kerne...68c134448e03a5

    -Extracted the kernel.

    -then, just to be sure all files are patched to the 2.6.37 final, I download and applied this: http://www.kernel.org/pub/linux/kern...-rc8-final.bz2

    -Downloaded and ALL copied these files to /lib/firmware/2.6.37/radeon/

    -Compiled and installed the kernel. (using my old config)

    -Downloaded the source from Debian experimental for xserver-xorg-video-ati and libgl1-mesa-glx.

    -Downloaded Mesa-7.10 (ftp://ftp.freedesktop.org/pub/mesa/7.10/)

    -Downloaded xf86-video-ati from git: http://cgit.freedesktop.org/xorg/dri...9cbd03ff0f4b82

    -Copied the debian directory from Debian sources to inside the sources of respective packages( mesa and xserver-xorg-video-ati ) and run dpkg-buildpackage for both.

    -Now I have a 2.6.37 with kernel mode setting supporting radeon barts chips and open source driver fully working. At this moment I'm using gnome-shell, tested glxgears, all working fine. If I test something else I post here.

  • #2
    Sorry, I forgot to put the url in the 4th item: http://people.freedesktop.org/~agd5f/radeon_ucode/

    All these files must be copied to /lib/firmware/2.6.37/radeon/.

    Comment


    • #3
      Thanks for the info. Want to try soon.

      Comment


      • #4
        As soon as I use modprobe radeon modeset=1, got black screen and kernel lock. Doesn't respond to CTRL+ALT+DEL or power button at case but reset.
        I think fglrx will live little more

        Comment


        • #5
          Originally posted by epinter View Post
          Sorry, I forgot to put the url in the 4th item: http://people.freedesktop.org/~agd5f/radeon_ucode/

          All these files must be copied to /lib/firmware/2.6.37/radeon/.
          These files normally belong to /lib/firmware/radeon

          Comment


          • #6
            Originally posted by Death Knight View Post
            As soon as I use modprobe radeon modeset=1, got black screen and kernel lock. Doesn't respond to CTRL+ALT+DEL or power button at case but reset.
            I think fglrx will live little more
            If I don't install the firmwares in /lib/firmware/2.6.37/radeon, I got screen corruption. Maybe you problem is related to this ? Did you try Sysrq magic ?

            Comment


            • #7
              Originally posted by boris64 View Post
              These files normally belong to /lib/firmware/radeon
              If you have a newer udev(mine is 164), you can copy to /lib/firmware/`uname -r`/radeon or /lib/firmware/radeon ( and other directories)

              Comment


              • #8
                I have udev 157. I added /lib/firmware/`uname -r`/radeon directory as a sym link but it doesn't help. There is no problem with
                Code:
                modprobe radeon modeset=0
                . Also don't know how could I debug this since screen gonna black... I wish first rc of 2.6.38 works...

                Comment


                • #9
                  Possibly Easier Method?

                  Since the same method applies to HD5xxx FOSS these days, I'll post what I did to get everything up to snuff (while I started with MS5 of openSuSE 11.4, this works for 11.3 as well).

                  1. Grabbed the latest kernel (2.6.38-rc2) from kernel.org; however, do NOT extract and compile it yet! There's a nice helpful aid you should grab first!
                  2. The shell-script in this thread (page two, and specifically post #17, has the most up-to-date version of the script) walks you through all the openSuSE-isms required in coverting general kernels to openSuSE-usable kernels. (http://forums.opensuse.org/english/g...ts-here-2.html)
                  3. Add the Factory OSS and Factory Xorg repos to your update repository lists. (If you run KDE, add the Factory KDE repo as well.)
                  4. Run the shell-script I pointed you to in #2. Before rebooting into your new kernel, run "sudo zypper dup" against your updated repo list.
                  5. Reboot (making sure to select your newly-compiled kernel).

                  Comment


                  • #10
                    Kernel Choices

                    Originally posted by Death Knight View Post
                    As soon as I use modprobe radeon modeset=1, got black screen and kernel lock. Doesn't respond to CTRL+ALT+DEL or power button at case but reset.
                    I think fglrx will live little more
                    What kernel are you using?

                    If older than 2.6.37, there are still issues with KMS with any HD-Xxxx GPU; that is why the FGLRX binary blob forces KMS off.

                    With 2.6.38-rc2, I have HD5450, no binary blob, and solid OpenGL and DRI2 support. And KMS is on with this kernel (due to it beiong the default).

                    Comment


                    • #11
                      And while compiling Mesa, do not forget to DISABLE GALLIUM.
                      r600c is much faster and reliable than r600g.

                      Comment


                      • #12
                        Originally posted by Death Knight View Post
                        And while compiling Mesa, do not forget to DISABLE GALLIUM.
                        r600c is much faster and reliable than r600g.
                        There's no need for that, unless you simply want less compilation time. The "dri-r600g" target is not built by default - you have to explicitly enable it with --enable-gallium-r600 (and even then it's not used by default, even if r600c is not built).

                        Comment

                        Working...
                        X