Announcement

Collapse
No announcement yet.

r600_dri.so: undefined symbol: _glapi_tls_Context

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • r600_dri.so: undefined symbol: _glapi_tls_Context

    Can anyone help with this? I assume I've got a wrong library file.

    Running Debian testing with kernel 2.6.36.2 with a:
    01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350]

    $ glxinfo
    libGL: XF86DRIGetClientDriverName: 4.3.0 r600 (screen 0)
    libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/tls/r600_dri.so
    libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/r600_dri.so
    libGL error: dlopen /usr/X11R6/lib/modules/dri/r600_dri.so failed (/usr/X11R6/lib/modules/dri/r600_d
    ri.so: undefined symbol: _glapi_tls_Context)
    libGL error: unable to load driver: r600_dri.so
    libGL: XF86DRIGetClientDriverName: 4.3.0 r600 (screen 0)
    libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/tls/r600_dri.so
    libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/r600_dri.so
    libGL error: dlopen /usr/X11R6/lib/modules/dri/r600_dri.so failed (/usr/X11R6/lib/modules/dri/r600_d
    ri.so: undefined symbol: _glapi_tls_Context)
    libGL error: unable to load driver: r600_dri.so
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    server glx vendor string: SGI
    server glx version string: 1.2
    [...]

    $ ls -l `locate r600_dri.so`
    -rw-r--r-- 1 root root 2481888 Jul 15 16:36 /usr/lib/dri/r600_dri.so
    lrwxrwxrwx 1 root root 24 Dec 14 13:14 /usr/X11R6/lib/modules/dri/r600_dri.so -> /usr/lib/dri/r600_dri.so

    no errors in Xorg log:
    $ grep EE /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER

    I'm sure there's more info I should be giving. Please ask...

  • #2
    Your Mesa and X have been built with different TLS settings (enabled in the other, disabled in the other).

    Comment


    • #3
      Originally posted by curaga View Post
      Your Mesa and X have been built with different TLS settings (enabled in the other, disabled in the other).
      any idea how to fix this? AFAIK I'm using all the latest packages from debian testing. Is there an easy way to check I'm using the right ones?

      Should I have TLS enabled or disabled?

      Comment


      • #4
        Since they're not built by you, file a bug at Debian

        TLS is disabled by default IIRC, but enabling it should improve performance.

        Comment

        Working...
        X